You are not logged in.

#1 Re: Installation » archlinux32.gpg does not exist » 2018-09-27 12:59:28

oh I feel confused to answer you, sorry. But you are better aware of my previous problems, you can visit this first issues. The point is I want to install arclinux on an android device, not on a PC / laptop. For that I have to go through some steps, first I have to install Termux (available on google playstore), after that I install archlinux by following TermuxArch, but it turns out my device has failed when installing it, because of architectural problems, after making the issue in its repository but the owner also did not provide enough solutions, I finally looked for the solution myself, until finally I arrived in this community. So if you see from each stage of the problem that is passed then the part of the file that I mark to ignore that does not need to be updated. That's all, but ... even though I thank the fellow community members for archipelux32 I was willing to reply to my question, and I'm sorry if I was wrong in choosing the title smile

#2 Re: Installation » archlinux32.gpg does not exist » 2018-09-26 12:17:26

Finally, the problem is resolved perfectly, first edit pacman.conf, disable SigLevel by changing the value to Never, then install the ca-certificates-utils first before full upgrade,

pacman -S ca-certificates-utils

After it is installed, run the

pacman -Syu

After full upgrade is complete, check the history during installation, if there is a warning stating that there is a new file created with filename.pacnew then use the filemanager to replace the old file with the newly created file.

For example, a new file named pacman.conf.pacnew, then change the old file name pacman.conf to pacman.conf.bak (for backup if there is a problem can be returned immediately), then rename the new file pacman.conf.pacnew to pacman.conf .

Ignore the warning section:

warning: /etc/group installed as /etc/group.pacnew
warning: /etc/gshadow installed as /etc/gshadow.pacnew
warning: /etc/passwd installed as /etc/passwd.pacnew
warning: /etc/resolv.conf installed as /etc/resolv.conf.pacnew
warning: /etc/shadow installed as /etc/shadow.pacnew

#3 Re: Installation » archlinux32.gpg does not exist » 2018-09-26 04:57:06

problem # 1

error: failed retrieving file 'core.db' from mirror.archlinux32.org : The requested URL returned error: 404                                                           
error: failed to update core (unexpected error)

can be fixed by changing the architecture part from auto to i686 in pacman.conf. But still having problems

downloading required keys...
error: key "2C146C01A952AC0F" could not be looked up remotely
error: key "C8E8F5A0AF9BA7E7" could not be looked up remotely
error: key "74EDA3C6B06D0506" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded

#4 Re: Installation » archlinux32.gpg does not exist » 2018-09-26 04:48:59

I am also confused, for you to know, I use Android Asus Zenfone 2, then install Termux, in termux the installed package is marked with i686 architecture, in the repository there is no jdk which I want to install. There is information if you want to install the JDK then you must install TermuxArch, but as I mentioned above, when installing Android devices using x86_64 architecture, but the installation takes i686.

run on Termux

$ uname -a
Linux localhost 3.10.20-x86_64_moor-265462-gfd33dd4 #1 SMP PREEMPT Fri Sep 30 15:31:23 CST 2016 x86_64 Android

run on TermuxArch

$ uname -a
Linux localhost 3.10.20-x86_64_moor-265462-gfd33dd4 #1 SMP PREEMPT Fri Sep 30 15:31:23 CST 2016 x86_64 GNU/Linux

also getprop

$ getprop ro.product.cpu.abi                                                       
x86
$ getprop ro.product.cpu.abilist32
x86,armeabi-v7a,armeabi
$ getprop ro.product.cpu.abilist64

$ getprop ro.product.cpu.abilist
x86,armeabi-v7a,armeabi
$ getprop ro.config.hwrlib
T9_x86
$ getprop sys.kernel.version
3.10.20-x86_64_moor-265462-gfd33dd4

#5 Installation » archlinux32.gpg does not exist » 2018-09-25 08:50:01

Jogoboyo
Replies: 7

i try install archlinux for android, use TermuxArch https://github.com/sdrausty/TermuxArch, for my device, the script detect x86_64 then install archlinux-bootstrap-2017.03.01-i686.tar.gz automatically. Im stuck when full upgrade. I think about my architectur. Then i found this website (archlinux32) then follow guide on download page, but stuck here...


$ pacman -Syy archlinux32-keyring-transition
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from mirror.archlinux32.org : The requested URL returned error: 404                                                           error: failed to update core (unexpected error)                                    error: failed retrieving file 'extra.db' from mirror.archlinux32.org : The requested URL returned error: 404                                                          error: failed to update extra (unexpected error)                                   error: failed retrieving file 'community.db' from mirror.archlinux32.org : The requested URL returned error: 404
error: failed to update community (unexpected error)                               error: failed to synchronize any databases                                         error: failed to init transaction (unexpected error)



$ pacman-key --populate archlinux32
==> ERROR: The keyring file /usr/share/pacman/keyrings/archlinux32.gpg does not exist

Board footer

Powered by FluxBB