You are not logged in.

#1 Re: Installation » arch-boostrap.sh error i686 » 2018-10-09 17:16:03

It looks like the error above is actually coming from curl:

https://github.com/curl/curl/blob/e13f0 … ssl.c#L287

That error exists in quite a few places in the curl source.

I'm not sure if that helps any or not though.

#2 Re: Installation » arch-boostrap.sh error i686 » 2018-10-09 15:32:13

Thanks for your reply.  Sorry, I forgot to mention that we've modified the script a little so it works with the i686 arch.  We've added/changed the below, and it was working up until recently (I noticed it this week).

DEFAULT_i686_REPO_URL="http://mirror.archlinux32.org"
get_default_repo() {
  local ARCH=$1
  if [[ "$ARCH" == arm* || "$ARCH" == aarch64 ]]; then
    echo $DEFAULT_ARM_REPO_URL
  elif [[ "$ARCH" == i686 ]]; then
    echo $DEFAULT_i686_REPO_URL
  else
    echo $DEFAULT_REPO_URL
  fi
}
get_core_repo_url() {
  local REPO_URL=$1 ARCH=$2
  if [[ "$ARCH" == arm* || "$ARCH" == aarch64 || "$ARCH" == i686 ]]; then
    echo "${REPO_URL%/}/$ARCH/core"
  else
    echo "${REPO_URL%/}/core/os/$ARCH"
  fi
}

get_template_repo_url() {
  local REPO_URL=$1 ARCH=$2
  if [[ "$ARCH" == arm* || "$ARCH" == aarch64 || "$ARCH" == i686 ]]; then
    echo "${REPO_URL%/}/$ARCH/\$repo"
  else
    echo "${REPO_URL%/}/\$repo/os/$ARCH"
  fi
}

It successfully downloads the files to the temp directory.  I get the error in the original post when it gets to the step of installing the packages.

#3 Installation » arch-boostrap.sh error i686 » 2018-10-09 12:29:09

rchamberlin
Replies: 7

We have been using arch-bootstrap to assist in creating an ISO that we use for devices.  It's been working fine for the last 6 months or so.  I just noticed a couple of days ago that it's failing now on 32-bit.  Here's the error we're seeing:

--- install packages: acl archlinux-keyring attr bzip2 curl expat glibc gpgme libarchive libassuan libgpg-error libnghttp2 libssh2 lzo openssl pacman pacman-mirrorlist xz zlib krb5 e2fsprogs keyutils libidn2 libunistring gcc-libs lz4 libpsl icu libunistring zstd filesystem coreutils bash grep gawk file tar systemd sed
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from mirror.archlinux32.org : error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
error: failed to update core (download library error)
error: failed retrieving file 'extra.db' from mirror.archlinux32.org : error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
error: failed to update extra (download library error)
error: failed retrieving file 'community.db' from mirror.archlinux32.org : error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
error: failed to update community (download library error)
error: failed to synchronize all databases

When searching for that error most say to reinstall ca-certificates* but it's not at a point yet where I can do that.

I realize this is a little off-topic but x86_64 boostraps work fine, and it was working up until recently.

Thanks!

Board footer

Powered by FluxBB