You are not logged in.

#1 2018-02-22 18:12:40

anselm
Member
Registered: 2017-11-21
Posts: 43

Mysteryous freezes at startup

I have an old mobo (INTEL D865-PERL - 2.4 Ghz P4) and I experience numerous freezes at startup, at seemingly random positions.

My GRUB config:

GRUB_DEFAULT=1
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset debug ignore_loglevel earlyprintk=vga,keep log_buf_len=16M systemd.debug-shell=1"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

I allowed early print of kernel messages so I can see when the freezes occur: they are seemingly random, sometimes when the hardware recognition tooks place.

After each freezes I have to switch off my PC and then switch it on. Interestingly pressing the reset button doesn't work this times. I have to switch the PC off and on for 2-7 times, to start the kernel finally.

Switching the PC off and on numerous times, and more than necessary isn't good for the hard drive, I think.

After the GUI is loaded (xfce in my case) I never experience any freezes, I can use my PC a whole day, even for up to 24 hours continuously without any freezes. So I think the memory modules are good.

Maybe I have to use some kernel parameters which makes the hardware recognition slower but safer?

Offline

#2 2018-03-14 15:19:51

anselm
Member
Registered: 2017-11-21
Posts: 43

Re: Mysteryous freezes at startup

Switching off Intel HyperThread technology in the BIOS settings menu has been resolved the problem. Maybe there was a race condition.

However switching off HT in the BIOS makes the system less responsive. Now the question is which magic kernel parameter should I use to make the system safely start when HT is switched on in the BIOS?

Last edited by anselm (2018-03-15 15:16:48)

Offline

Board footer

Powered by FluxBB