You are not logged in.

#1 2018-04-29 07:49:54

Stefan_1957
Member
From: Sinnerthal
Registered: 2018-04-28
Posts: 5

Solved German keyboard layout before login

Hello and good morning,
it's 8.50 a.m. in Germany.
Normally I use another computer with arch 64, and this is my eeepc with arch 32.
It's only a nice toy, only? no, a very nice friend! My first linux OS was SUSE 7 or 8, do not
know it anymore. But now to my question-
After a new installation a few months ago I noticed that after boot before I log in the keyboard layout is US and not DE as normally. It is not a problem, but strange. How can I correct this?
Many thanks and a beautiful sunday.

Stefan

Last edited by Stefan_1957 (2018-05-09 16:15:27)

Offline

#2 2018-04-29 09:23:10

Stefan_1957
Member
From: Sinnerthal
Registered: 2018-04-28
Posts: 5

Re: Solved German keyboard layout before login

Sometimes it is a huge advantage, when one is not blind!!!
I created a file /etc/X11/xorg.conf.d/20-keyboard.conf with the DE layout:
Section "InputClass"
        Identifier "keyboard"
        MatchIsKeyboard "yes"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
EndSection
Save, close and restart X and "gudd es". (gudd es ⁼ saarland slang for it is good)

Offline

#3 2018-05-03 07:06:18

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: Solved German keyboard layout before login

Sorry for late "answering", glad you found the solution. :-)

Offline

Board footer

Powered by FluxBB