You are not logged in.

#1 2018-05-21 18:35:46

archlinux32forever
Member
Registered: 2018-05-21
Posts: 24

[SOLVED] encfs error after upgrading

Hi

Yesterday I upgraded with:

sudo pacman -Syu

and encfs get this version:

$ LC_ALL=C pacman -Qi encfs
Name            : encfs
Version         : 1.9.4-1.0
Description     : Encrypted filesystem in user-space
Architecture    : i686
URL             : https://vgough.github.io/encfs/
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : openssl  fuse2  tinyxml2
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 1892.00 KiB
Packager        : Erich Eckner <arch32 at eckner dot net>
Build Date      : Mon Jan 29 22:24:33 2018
Install Date    : Mon May 21 19:02:24 2018
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

and when I try to see my encrypted directory I get this error:

$ LC_ALL=C encfs -i 15 ~/.personal2mj ~/personal2mj
encfs: malloc.c:2401: sysmalloc: Assertion `(old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)' failed.
Abortado (`core' generado)

On github.com I can see that this version has errors. I cannot create account in bugs.archlinux32.org. Could administrators upgrade encfs to last version, please?

Is very urgent.

Regards
Oscar

Last edited by archlinux32forever (2018-05-23 22:45:55)

Offline

#2 2018-05-22 08:21:17

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 608

Re: [SOLVED] encfs error after upgrading

there is encfs-1.9.5-1.0 in [community-testing] - you can take that if it's urgent.
But I'll try to promote it to [community] (may need to push some dependencies, too).

Offline

#3 2018-05-23 22:45:13

archlinux32forever
Member
Registered: 2018-05-21
Posts: 24

Re: [SOLVED] encfs error after upgrading

Very thanks!

After upgrade again and get the version 1.9.5-1.0 is working again!

Offline

Board footer

Powered by FluxBB