You are not logged in.

#1 2018-06-16 22:28:42

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 393

[SOLVED] mplayer not working since update to ffmpeg 1.4.0

Whenever I accept an update to ffmpeg, the version it installs seems to look for various versions of old libraries, and I need to roll back to ffmpeg-1:3.4.2-2.0 and x625-2.7-1.0.  When I run newer versions I get the following error:

mplayer: error while loading shared libraries: libswscale.so.4: cannot open shared object file: No such file or directory

Trouble is, ffmpeg ships a newer version of that file.  For me, it's been this way since ffmpeg-1:4.0 came around.

As I recall, when that first popped up, I tried creating links to the old lib version names, and ended up creating a good half dozen links by the time mplayer got to the next stage.  That next stage was it complaining that the version strings in those libs weren't valid though, so I undid all of those links, and just downgraded the package.  But it suggests there's more than just the version of that lib that mplayer's built against at fault.

FWIW: Under working mplayer from ffmpeg 1:3.4.2, sha256sum gives:
3c4f5556667fb72727714fb46f371c50fccc843a5bf169e19fcaa13e90092ae1  /usr/bin/mplayer

And under ffmpeg 1:4.0-3.0:
3c4f5556667fb72727714fb46f371c50fccc843a5bf169e19fcaa13e90092ae1  /usr/bin/mplayer

In other words, it looks like mplayer hasn't even been rebuilt against the new codebase.  Shurely shome mishtake?

Last edited by levi (2018-06-18 19:17:48)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#2 2018-06-17 16:35:34

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 393

Re: [SOLVED] mplayer not working since update to ffmpeg 1.4.0

FWIW, ffmpeg 1:4.0 seems to come from the testing repo, while in extra there's just the old working 1:3.4, so this shouldn't affect anyone without the testing repos enabled.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2018-06-18 04:55:35

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 433

Re: [SOLVED] mplayer not working since update to ffmpeg 1.4.0

I see in the database, that there is a linking problem. I rescheduled mplayer and mencoder, maybe it builds _this_time_ ...
Thanks for reporting!
Please consider opening a bug on bugs.archlinux32.org next time - this will prevent the automatic moving of broken packages.

cheers,
deep42thought

Offline

#4 2018-06-18 19:14:58

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 393

Re: [SOLVED] mplayer not working since update to ffmpeg 1.4.0

Thanks, that looks better.  I did a pacman -Syu and it reported there was an mplayer package ready to go.  Now I look, /usr/bin/mplayer is owned by the mplayer package, not the ffmpeg one - I'm not sure why I was looking at that as the culprit.  As I was receiving ffmpeg updates but not mplayer ones, it's not surprising the mplayer binary has not changed, but had stopped finding ffmpeg libs.  But now that mplayer is building everything has slotted together and we're sailing smoothly again.

FWIW, I noticed the mplayer package depends on ffmpeg but also ships the mencoder tool.  I've never used mencoder for my transcoding needs - I've always gone to ffmpeg and used that directly, so I'm not explicitly testing mencoder.  Although these days I tend to do even that on my more powerful general server, which runs archlinux64 anyway, and then use sshfs to mount and play them over the network.

I'll be sure to raise a bug directly if anything like this occurs again.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2018-06-28 16:46:20

vafe
Member
Registered: 2017-11-23
Posts: 7

Re: [SOLVED] mplayer not working since update to ffmpeg 1.4.0

It is broken for ffmpeg 1:3.4.2-2.0

felipe@dell ~/scripts $ pacman -Q | grep ffmpeg
ffmpeg 1:3.4.2-2.0
ffmpeg2.8 2.8.14-1.0
felipe@dell ~/scripts $ mplayer
mplayer: error while loading shared libraries: libswscale.so.5: cannot open shared object file: No such file or directory

Offline

#6 2018-06-28 19:44:17

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 393

Re: [SOLVED] mplayer not working since update to ffmpeg 1.4.0

Perhaps one of the broken releases from testing has been released to stable.  FWIW, what version of the mplayer package are you using?  It was an updated version of that that fixed the missing shared libs issue for me, but then I'm using the testing repos so it may not be available for you yet.

Perhaps if I'd submitted a bug for this it'd have been easier to track when moving packages to stable, but as yet I've not succeeded in creating an account for the bug tracker.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#7 2018-06-28 20:22:54

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 433

Re: [SOLVED] mplayer not working since update to ffmpeg 1.4.0

ffmpeg-1:4.0.1-1.0 is in extra since 2018-06-22
also, ffmpeg2.8 was dropped

levi: what's you username on the bugtracker? I cannot find a "levi" with insufficient rights there.

Offline

#8 2018-06-28 21:07:38

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 393

Re: [SOLVED] mplayer not working since update to ffmpeg 1.4.0

I don't think I even have an account there yet, as it tells me it's sending me an email to complete my application, but I can find no trace of that in my email client logs or my email provider's logging.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB