You are not logged in.

#1 2018-10-17 13:24:56

andav
Member
Registered: 2017-11-14
Posts: 22

can you help me install package thats in AUR but only in x64?

i want to install on archlinux32 master pdf editor.
it has a page in AUR:
https://aur.archlinux.org/packages/mast … ent-667070

i use yaourt.
so when i tried to install it in arch32 it tells me that this package is not for i686 and it abort the installation.
can i install this program on arch32?
if yes what do i need to do?
please explain me like i'm five.
i use arch a long time but more technically things are harder to grasp for me (but i'm trying :-)).

Offline

#2 2018-10-17 14:02:15

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 393

Re: can you help me install package thats in AUR but only in x64?

Has yaourt left you a PKGBUILD file to edit?  I can't remember if I've ever used yaourt but I did try something to keep my AUR packages up to date but it ended up being a bit of a faff, so I went back to manually updating things.  I should still probably try to script something so that it can notify me when a package has updates though.

If you've not got a PKGBUILD you might need to download your own.  Then edit it and the line that starts 'arch=' add 'i686' to the array of values in single quotes that's usually on the other side of the equals sign.  If it only builds for one platform, I guess that might not need to be an array, but all the examples I've seen so far have an array there.

If it isn't an array you might need to build your own.  The format is ('item1' 'item2' ...).  I don't think the order of items matters, by the way.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2018-10-17 15:19:29

andav
Member
Registered: 2017-11-14
Posts: 22

Re: can you help me install package thats in AUR but only in x64?

thanks.
i think yaourt is letting me edit the PKGBUILD  before the installation proccess begin so i will try to add 'i686' to there and save the file, and continue the installation and see if it will install it.
i'll update here if i succeeded.
thanks again!

Offline

#4 2018-10-17 19:03:28

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 757
Website

Re: can you help me install package thats in AUR but only in x64?

See my comments on https://aur.archlinux.org/packages/masterpdfeditor/.

I get:

/opt/master-pdf-editor-5/masterpdfeditor5
Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"

But it doesn't seem to have a negative effect, I could edit and save a PDF (with watermark).

Note, we cannot officially package or support packages from the AUR..

Offline

#5 2018-10-17 19:48:10

andav
Member
Registered: 2017-11-14
Posts: 22

Re: can you help me install package thats in AUR but only in x64?

well i needed 2 more lines for that to work.
i got the answer in the AUR page (in the comments) of this package archlinux AUR :-)
https://aur.archlinux.org/packages/masterpdfeditor/

this is the answer:

You have to change:

arch=('x86_64' 'i686')

and add two lines:

source_i686=("https://code-industry.net/public/master-pdf-editor-${pkgver}_i386.tar.gz")

sha1sums_i686=('451b9e78015942ebd94fabb4304b0cd96aa8a3d2')

now it successfully installed.
but i cant use the program.
when i ran it now i get this error:

masterpdfeditor5: error while loading shared libraries: libQtSvg.so.4: cannot open shared object file: No such file or directory

what do i need to do to overcome this?

Last edited by andav (2018-10-17 19:49:08)

Offline

#6 2018-10-17 19:51:42

andav
Member
Registered: 2017-11-14
Posts: 22

Re: can you help me install package thats in AUR but only in x64?

andreas_baumann wrote:

See my comments on https://aur.archlinux.org/packages/masterpdfeditor/.

I get:

/opt/master-pdf-editor-5/masterpdfeditor5
Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"

But it doesn't seem to have a negative effect, I could edit and save a PDF (with watermark).

Note, we cannot officially package or support packages from the AUR..

oh sorry i didn't see your message before sending (it was on editing for a long time so didn't refreshed :-))
thanks of course.
also thanked you there.
but i have a new problem.
it's like yours but a different file is missing and this file not letting me open the program.

Last edited by andav (2018-10-17 19:57:45)

Offline

#7 2018-10-17 20:53:26

andav
Member
Registered: 2017-11-14
Posts: 22

Re: can you help me install package thats in AUR but only in x64?

in the irc channel i suggested to install qt4 so i did and this error was solved.
but now i have same error as yours (andreas_baumann) but in my case i still can't open the program.
i already have icu installed.

Offline

#8 2018-10-17 20:58:58

andav
Member
Registered: 2017-11-14
Posts: 22

Re: can you help me install package thats in AUR but only in x64?

well the last thing i did (but i can't tell if that solved my problem) was to reinstall icu.
after that masterpdfeditor was opened and seems to work.
thanks you very much for your help!

Offline

Board footer

Powered by FluxBB