You are not logged in.

#1 2019-01-14 12:18:10

stronnag
Member
Registered: 2018-04-02
Posts: 2

[Solved] rubygems (ruby 2.6.0) installation error

Looks like have the gems package gets (half) installed under /usr/lib/ruby/2.5.0 (vice the new /usr/lib/ruby/2.6.0), which makes updating gems impossible, unless one manually moves the mis-installed files.

Last edited by stronnag (2019-01-14 18:27:51)

Offline

#2 2019-01-14 15:18:08

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 393

Re: [Solved] rubygems (ruby 2.6.0) installation error

I'm not a ruby coder or a knowing user of the language.  Do these files all belong to the same gems package, or are there multiples?  You can test individual files with pacman -Qo [filename], and I suggest you do that with at least one random file from each folder.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2019-01-14 18:26:45

stronnag
Member
Registered: 2018-04-02
Posts: 2

Re: [Solved] rubygems (ruby 2.6.0) installation error

thanks for the insight, it appears the package needs to be updated for the extant ruby package (2.6.0), as the rubygems package installs under 2.5.0.

Offline

#4 2019-01-14 18:42:04

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 393

Re: [Solved] rubygems (ruby 2.6.0) installation error

I'll just note that there appears to be a 3.0 version of rubygems in testing currently.  But it still installs things to /usr/lib/ruby/2.5.0, so it looks like that won't help.

There are various ruby packages currently failing to build but not the core ruby nor rubygems appear on this list.  Probably there's been no change to make rubygems build automatically, so I guess it needs to be manually prodded.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB