You are not logged in.

#1 2019-01-17 15:00:25

shroom
Member
Registered: 2018-08-21
Posts: 9

[SOLVED] LightDM issue

I did my weekly update few days ago and seems like it was a big one. Once finished, I saw that I couldn't mount Windows shares anymore. I thought a reboot would maybe clear that out.
But upon rebooting, I ended up with a black screen. I tested this on two different computers (one being a virtual machine). After chrooting, I discovered the issue was caused by LightDM (that I use with Mate) which now refuses to start properly.

Here's its log:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.28.0, UID=0 PID=5
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.01s] WARNING: Failed to get system bus: Could not connect: No such file or directory
[+0.02s] DEBUG: Adding default seat
[+0.02s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.02s] DEBUG: Seat seat0: Starting
[+0.02s] DEBUG: Seat seat0: Creating greeter session
[+0.02s] DEBUG: Seat seat0: Creating display server of type x
[+0.02s] DEBUG: posix_spawn avoided (fd close requested) 
[+0.02s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.02s] DEBUG: Using VT 7
[+0.02s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.02s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.02s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.02s] DEBUG: XServer 0: Launching X Server
[+0.02s] DEBUG: Launching process 9: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.02s] DEBUG: XServer 0: Waiting for ready signal from X server :0

Is there an easy fix to that or should I just roll back for now?

Last edited by shroom (2019-01-18 11:16:29)

Offline

#2 2019-01-17 17:59:10

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 254

Re: [SOLVED] LightDM issue

Two lines from that log look like they could be investigated:

[+0.01s] WARNING: Failed to get system bus: Could not connect: No such file or directory
[+0.02s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)

I'm not sure off the top of my head how significant the bus error is; I see that kind of thing quite a lot and it's often just noise, but I can imagine in something like a greeter it could be important. I also don't know where this 'plymouth' tool comes from; I don't have it on my systems, but I don't use greeters here.  I did download lightdm 1:1.28.0 which pulls in libxclavier 5.4-2.1 but these may be the broken packages (though their dates are november and september respectively).

Ah, I've found Plymouth.  It's an AUR package; do you recall building it and installing it, or is that just noise as well?

Offline

#3 2019-01-17 23:37:58

shroom
Member
Registered: 2018-08-21
Posts: 9

Re: [SOLVED] LightDM issue

I think it's just noise. Never built that AUR package and it is not reported as being installed.
I also have the same setup on a computer running the x64 version of Archlinux (also up-to-date) but lightdm starts and the log shows that a dbus is properly found:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.28.0, UID=0 PID=445
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Monitoring logind for seats
[+0.01s] DEBUG: New seat added from logind: seat0
[+0.01s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.01s] DEBUG: Seat seat0: Starting
[+0.01s] DEBUG: Seat seat0: Creating greeter session
[+0.02s] DEBUG: Seat seat0: Creating display server of type x
[+0.02s] DEBUG: posix_spawn avoided (fd close requested) 
[+0.02s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.02s] DEBUG: Using VT 7
[+0.02s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.02s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.02s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.02s] DEBUG: XServer 0: Launching X Server
[+0.02s] DEBUG: Launching process 460: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.02s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.03s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.03s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.17s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.17s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.26s] DEBUG: posix_spawn avoided (automatic reaping requested) (fd close requested) 
[+0.91s] DEBUG: Got signal 10 from process 460
[+0.91s] DEBUG: XServer 0: Got signal from X server :0
[+0.91s] DEBUG: XServer 0: Connecting to XServer :0
[+0.91s] DEBUG: posix_spawn avoided (fd close requested) (child_setup specified) 
[+0.91s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+0.91s] DEBUG: Session pid=481: Started with service 'lightdm-greeter', username 'lightdm'
[+0.92s] DEBUG: Session pid=481: Authentication complete with return value 0: Success
[+0.92s] DEBUG: Seat seat0: Session authenticated, running command
[+0.92s] DEBUG: Session pid=481: Running command /usr/bin/lightdm-gtk-greeter
[+0.92s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+0.92s] DEBUG: Session pid=481: Logging to /var/log/lightdm/seat0-greeter.log
[+1.00s] DEBUG: Activating VT 7
[+1.00s] DEBUG: Activating login1 session c1
[+1.00s] DEBUG: Seat seat0 changes active session to c1
[+1.00s] DEBUG: Session c1 is already active
[+1.30s] DEBUG: Greeter connected version=1.28.0 api=1 resettable=false
[+1.48s] DEBUG: Greeter start authentication for shroom
[+1.48s] DEBUG: Session pid=562: Started with service 'lightdm', username 'shroom'
[+1.48s] DEBUG: Session pid=562: Got 1 message(s) from PAM
[+1.48s] DEBUG: Prompt greeter with 1 message(s)
[+27.07s] DEBUG: Continue authentication
[+27.08s] DEBUG: Session pid=562: Authentication complete with return value 0: Success
[+27.08s] DEBUG: Authenticate result for user shroom: Success
[+27.08s] DEBUG: User shroom authorized
[+27.08s] DEBUG: Greeter requests session mate
[+27.08s] DEBUG: Seat seat0: Stopping greeter; display server will be re-used for user session
[+27.08s] DEBUG: Terminating login1 session c1
[+27.09s] DEBUG: Session pid=481: Sending SIGTERM
[+27.10s] DEBUG: Greeter closed communication channel
[+27.10s] DEBUG: Session pid=481: Exited with return value 0
[+27.10s] DEBUG: Seat seat0: Session stopped
[+27.10s] DEBUG: Seat seat0: Greeter stopped, running session
[+27.10s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+27.10s] DEBUG: posix_spawn avoided (fd close requested) (child_setup specified) 
[+27.10s] DEBUG: Session pid=562: Running command /etc/lightdm/Xsession mate-session
[+27.10s] DEBUG: Creating shared data directory /var/lib/lightdm-data/shroom
[+27.10s] DEBUG: Session pid=562: Logging to .xsession-errors
[+27.17s] DEBUG: Activating VT 7
[+27.17s] DEBUG: Activating login1 session 2
[+27.17s] DEBUG: Seat seat0 changes active session to 
[+27.17s] DEBUG: Seat seat0 changes active session to 2
[+27.17s] DEBUG: Session 2 is already active

Offline

#4 2019-01-18 07:23:59

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 605
Website

Re: [SOLVED] LightDM issue

dbus issues point to systemd and graphical login. Maybe downgrading systemd, libsystemd and systemd-sysvcompat to 239 helps.

Offline

#5 2019-01-18 11:04:16

shroom
Member
Registered: 2018-08-21
Posts: 9

Re: [SOLVED] LightDM issue

andreas_baumann wrote:

dbus issues point to systemd and graphical login. Maybe downgrading systemd, libsystemd and systemd-sysvcompat to 239 helps.

That did the trick, thanks smile

I had to cheat though as the lastest pacman version apparently requires the latest libidn2 (2.1.0) and the latest libidn2 (2.1.0) requires 240.
I cheated by copying the required .so file of the latest libidn2 (2.1.0) while retaining the previous package (2.0.5) installed.
Can (and then will) this be addressed at some point?

Last edited by shroom (2019-01-18 11:51:21)

Offline

Board footer

Powered by FluxBB