You are not logged in.

#1 2019-01-18 21:30:46

AVFritze
Member
Registered: 2018-11-14
Posts: 6

[solved] system boot fails

Hi, I cannot say why the system doesn't start anymore correctly nor what to do. I do not get the login dialog anymore. Some times I get a blank screen with a very thin cursor blinking in the upper left corner some times it stops booting with the attached picture.
If I get the blank screen I can use [Ctrl+ALT+F2] and can Login. With >startx< I can work. Is there any possibility to repair the system?
Thanks for your help in advance!

Last edited by AVFritze (2019-01-19 17:34:58)

Offline

#2 2019-01-18 23:09:42

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 255

Re: [solved] system boot fails

Are you using lightdm as your login manager by any chance?  An update to systemd seems to have broken that for the time being.

Ah yes, looks like lightdm from your photo.  As you've found, either disabling lightdm or switching to a different screen and logging in then starting x manually is the current workaround.

Offline

#3 2019-01-19 07:23:40

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 608
Website

Re: [solved] system boot fails

I don't like the link leading to the picture and the fact it asks for bitcoins (so I deleted it).

Please use a screenshot tool like https://wiki.archlinux.org/index.php/Pb in the future.

On lightdm, yes, the lightdm-gtk-greeter is currently broken, see also
https://bugs.archlinux32.org/index.php? … task_id=60
use another greeter or use another login manager like sddm, slim, lxdm,
for a complete list see https://wiki.archlinux.org/index.php/display_manager.

You can boot and login remotely via SSH and check, if you are using this lightdm greeter.

Another alternative is to disable the login manager, login via the text console and use 'startx'
to start the X session.

Offline

#4 2019-01-19 15:06:10

AVFritze
Member
Registered: 2018-11-14
Posts: 6

Re: [solved] system boot fails

Didn't see the bitcoin topic - so please excuse...
Yes I am using lightdm. I tried an other greeter (lightdm-slick-greeter) but no result. So I will check an other dm.

I installed sddm. Grafical login worked fine but then I get a blank screen again only with the mouse pointer and after a while a message box appears saying that a shell is missing. So I will check out the next one ;-)

lxdm is the one for now. Everything is perfect! Thanks for your help!

Last edited by AVFritze (2019-01-19 17:33:38)

Offline

#5 2019-01-19 19:55:11

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 608
Website

Re: [solved] system boot fails

No problem. BTW, there is a more precise forum topic around lightdm-gtk-greeter
here: https://bbs.archlinux32.org/viewtopic.php?id=2682

Offline

Board footer

Powered by FluxBB