You are not logged in.

#1 2019-02-12 11:20:01

radli
Member
Registered: 2018-04-27
Posts: 8

libsasl (2.1.27-1.0) breaks dependency 'libsasl=2.1.26'/ by cyrus-sasl

[aim@xcart-aim-arch:pts/3][~]$ yaourt -Syau --needed
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
warning: perl: ignoring package upgrade (5.26.2-1.0 => 5.28.1-1.0)
warning: thunderbird: ignoring package upgrade (52.9.1-1.0 => 60.5.0-1.0)
warning: thunderbird-i18n-ru: ignoring package upgrade (52.9.1-1.0 => 60.5.0-1.0)
warning: xfce4-terminal: ignoring package upgrade (0.6.3-3 => 0.8.7.4-1.1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libsasl (2.1.27-1.0) breaks dependency 'libsasl=2.1.26' required by cyrus-sasl
No database errors have been found!
[aim@xcart-aim-arch:pts/3][~]$

Offline

#2 2019-02-13 05:37:30

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 365

Re: libsasl (2.1.27-1.0) breaks dependency 'libsasl=2.1.26'/ by cyrus-sasl

hmm, I'll need to check a few lines in the buildmaster - it appears, that the version information was ignored.
I moved cyrus-sasl* to stable

Offline

#3 2019-02-13 11:54:46

radli
Member
Registered: 2018-04-27
Posts: 8

Re: libsasl (2.1.27-1.0) breaks dependency 'libsasl=2.1.26'/ by cyrus-sasl

Sorry, the error is still here.

[aim@xcart-aim-arch:pts/7][~]$ sudo pacman -Scccc   

Cache directory: /var/cache/pacman/pkg/
:: Do you want to remove ALL files from cache? [y/N] y
removing all files from cache...

Database directory: /var/lib/pacman/
:: Do you want to remove unused repositories? [Y/n] 
removing unused sync repositories...
[aim@xcart-aim-arch:pts/7][~]$ yaourt -Syau --needed
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
warning: perl: ignoring package upgrade (5.26.2-1.0 => 5.28.1-1.0)
warning: thunderbird: ignoring package upgrade (52.9.1-1.0 => 60.5.0-1.0)
warning: thunderbird-i18n-ru: ignoring package upgrade (52.9.1-1.0 => 60.5.0-1.0)
warning: xfce4-terminal: ignoring package upgrade (0.6.3-3 => 0.8.7.4-1.1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libsasl=2.1.26' required by cyrus-sasl
No database errors have been found!
[aim@xcart-aim-arch:pts/7][~]$ 

Offline

#4 2019-02-14 05:30:53

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 365

Re: libsasl (2.1.27-1.0) breaks dependency 'libsasl=2.1.26'/ by cyrus-sasl

ah, yes, I see - the move cyrus-sasl is also too old ... the right one is still stuck on the build list, I'll have a look why that is the case.

regards,
deep42thought

Offline

Board footer

Powered by FluxBB