You are not logged in.

#1 2019-03-08 11:58:10

aliemjay
Member
Registered: 2018-11-17
Posts: 15

"double-conversion 3.1.2" breaks ABI backward compatibility

double-conversion from 3.1.2 onward names the library libdouble-conversion.so.3, while in previous versions, the library name is libdouble-conversion.so.3.0.0.
This change is from upstream an is considered a fix to a faulty naming convention.
https://github.com/google/double-conver … ac532fba71

The problem is that all dependent packages needs rebuilding against the new version and many packages in build-list fails because of that, and these packages are many - essentially every qt app and others.
Archlinux updated the PKGBUILDs since 4 days to 3.1.2 but hasn't yet built it, so that new Plasma packages are built against the previous version (3.1.1).

So, should we patch the package and keep old naming?
or otherwise reschedule dependent packages for mass rebuild?

Offline

#2 2019-03-08 12:40:48

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 448

Re: "double-conversion 3.1.2" breaks ABI backward compatibility

I'm in favour of rescheduling.
Which packages need to be recompiled? (How do we find out?)

Offline

#3 2019-03-08 12:53:34

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 448

Re: "double-conversion 3.1.2" breaks ABI backward compatibility

according to the buildmaster's database only vtk and qt5-base are linked against libdouble-conversion.so.3.0.0 - so I will only reschedule those and see what happens smile

Offline

#4 2019-03-08 13:24:32

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: "double-conversion 3.1.2" breaks ABI backward compatibility

Yep. This also breaks a bunch of packages in the KDE realm because of:

/usr/bin/meinproc5 is owned by kdoctools 5.55.0-1.0

I'll try to rebuild kdoctools (hoping it doesn't depend on itself).

Offline

#5 2019-03-08 14:25:52

aliemjay
Member
Registered: 2018-11-17
Posts: 15

Re: "double-conversion 3.1.2" breaks ABI backward compatibility

In to my local install only, all the packages listed below have binaries linked to libdouble-conversion.

Most packages don't have explicit dependency, So I don't think rebuilding is a solution unless we rebuild all pactree:

 $ pactree -sru double-conversion 
 $ find /usr/bin/ /usr/lib/ -type f | { while read so; do if ldd "$so" | grep double-conversion > /dev/null; then echo $so; fi; done } | pacman -Qoq - | sort | uniq
appstream-qt
ark
attica
avahi
baloo
baloo-widgets
bluez-qt
breeze
calligra
dolphin
frameworkintegration
gpsd
grantlee
gwenview
k3b
kaccounts-integration
kactivities
kactivities-stats
karchive
kauth
kbookmarks
kcmutils
kcodecs
kcompletion
kconfig
kconfigwidgets
kcontacts
kcoreaddons
kcrash
kdbusaddons
kde-cli-tools
kdeclarative
kdeconnect
kdecoration
kdelibs4support
kdeplasma-addons
kdesu
kdiagram
kdnssd
kdoctools
keditbookmarks
kemoticons
kfilemetadata
kglobalaccel
kguiaddons
kholidays
khotkeys
khtml
ki18n
kiconthemes
kidletime
kio
kio-extras
kirigami2
kitemmodels
kitemviews
kjobwidgets
kjs
kjsembed
kleopatra
kmime
knewstuff
knotifications
knotifyconfig
kompare
konsole
kpackage
kparts
kpeople
kpimtextedit
kpmcore
kpty
kross
krunner
kscreenlocker
kservice
ktexteditor
ktextwidgets
kunitconversion
kwallet
kwayland
kwidgetsaddons
kwin
kwindowsystem
kxmlgui
libaccounts-qt
libdbusmenu-qt5
libkcddb
libkdcraw
libkexiv2
libkipi
libkleo
libkomparediff2
libksane
libkscreen
libksysguard
marble-common
milou
modemmanager-qt
networkmanager-qt
okteta
okular
oxygen
phonon-qt5
plasma-desktop
plasma-framework
plasma-workspace
polkit-qt5
poppler-qt5
powerdevil
prison
purpose
qca
qgpgme
qt5-base
qt5-declarative
qt5-location
qt5-multimedia
qt5-quickcontrols2
qt5-script
qt5-sensors
qt5-serialport
qt5-speech
qt5-svg
qt5-tools
qt5-virtualkeyboard
qt5-wayland
qt5-webchannel
qt5-webengine
qt5-webkit
qt5-x11extras
qt5-xmlpatterns
qtermwidget
qwt
signond
solid
sonnet
subversion
syntax-highlighting
systemsettings
telegram-qt
threadweaver

Last edited by aliemjay (2019-03-08 14:32:54)

Offline

#6 2019-03-08 14:29:19

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 448

Re: "double-conversion 3.1.2" breaks ABI backward compatibility

ldd also reports indirectly linked libraries e.g. "$binary1 -> $library1 -> $library2" (there, only $library1 would need to be rebuilt).
have a look at lddtree or 'objdump -x' to see more

Offline

#7 2019-03-08 14:35:16

aliemjay
Member
Registered: 2018-11-17
Posts: 15

Re: "double-conversion 3.1.2" breaks ABI backward compatibility

Goo point, I missed that !

Offline

#8 2019-03-08 14:49:20

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: "double-conversion 3.1.2" breaks ABI backward compatibility

kdoctools has been rebuilt, so I suspect things should recover now in most kde packages..

Offline

Board footer

Powered by FluxBB