You are not logged in.

#1 2019-05-04 15:02:50

gard
Member
Registered: 2019-05-04
Posts: 9

[Solved] empathy, gnome-control-center not work, icu packet...

Hello!
Few days ago I upgraded my archlinux from 2016 year to this day. Now I have updated system, but someone programms, aka gnome-control-center, empathy not work. I started it and

мая 04 19:57:27 tux gnome-control-center.desktop[824]: gnome-control-center: error while loading shared libraries: libicuuc.so.63: cannot open shared object file: No such file or directory
мая 04 19:57:33 tux org.gnome.Empathy.desktop[824]: empathy: error while loading shared libraries: libicuuc.so.63: cannot open shared object file: No such file or directory

I created symbol links for

ln -s libicuuc.so.64.2 libicuuc.so.63
ln -s libicui18n.so.64.2 libicui18n.so.63

But.. now:

мая 04 20:01:11 tux gnome-control-center.desktop[824]: gnome-control-center: symbol lookup error: /usr/lib/libjavascriptcoregtk-4.0.so.18: undefined symbol: uiter_setUTF8_63
мая 04 20:01:17 tux org.gnome.Empathy.desktop[824]: empathy: symbol lookup error: /usr/lib/libjavascriptcoregtk-4.0.so.18: undefined symbol: uiter_setUTF8_63

Any ideas?
Downgrade icu.. but how?

Last edited by gard (2019-05-05 07:26:45)

Offline

#2 2019-05-05 03:59:19

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 448

Re: [Solved] empathy, gnome-control-center not work, icu packet...

Downgrading icu will create more issues than it solves (that's why we moved it althought it broke some packages).
Unfortunately, gnome-control-center and empathy are yet to be built, so there are only two things you can do:
a) wait
b) extract libicuuc.so.63 and libicui18n.so.63 (and if those are symlinks, the files to which they point) from the respective package files

cd/
bsdtar -xf usr/lib/libicuuc.so.63 /var/cache/pacman/pkg/icu-....pkg.tar.xt

Offline

#3 2019-05-05 07:26:14

gard
Member
Registered: 2019-05-04
Posts: 9

Re: [Solved] empathy, gnome-control-center not work, icu packet...

Thanks for you reply!
I found icu63 and unpack, move files to /usr/lib/
Now gnome-control-center is started and empathy!
Hovewer, i have other problem for empathy, but it other stories )

Thansk, it's work for me!

Offline

#4 2019-05-05 18:00:46

archlinux32forever
Member
Registered: 2018-05-21
Posts: 16

Re: [Solved] empathy, gnome-control-center not work, icu packet...

deep42thought wrote:

Downgrading icu will create more issues than it solves (that's why we moved it althought it broke some packages).
Unfortunately, gnome-control-center and empathy are yet to be built, so there are only two things you can do:
a) wait
b) extract libicuuc.so.63 and libicui18n.so.63 (and if those are symlinks, the files to which they point) from the respective package files

cd/
bsdtar -xf usr/lib/libicuuc.so.63 /var/cache/pacman/pkg/icu-....pkg.tar.xt

After full system upgrade this morning I have similar issue:
When I run startx, mate doesn't show neither top bar nor task bar, so I can't go to menu and exit from mate normally (I can do it with CTRL+ALT+BACKSPACE). I don't have menus. Is unusable.

Log from /var/log/pacman.log:

[2019-05-05 08:19] [PACMAN] Running 'pacman -Syu'
[2019-05-05 08:19] [PACMAN] synchronizing package lists
[2019-05-05 08:19] [PACMAN] starting full system upgrade
[2019-05-05 08:26] [ALPM] transaction started
[2019-05-05 08:26] [ALPM] removed libmagick (7.0.8.34-1.0)
[2019-05-05 08:26] [ALPM] removed libsystemd (240.93-1.0)
[2019-05-05 08:26] [ALPM] upgraded linux-api-headers (4.17.11-1.1 -> 5.0.7-1.0)
[2019-05-05 08:26] [ALPM] upgraded glibc (2.28-5.5 -> 2.29-1.26)
[2019-05-05 08:26] [ALPM-SCRIPTLET] Generating locales...
[2019-05-05 08:26] [ALPM-SCRIPTLET]   es_ES.UTF-8... done
[2019-05-05 08:26] [ALPM-SCRIPTLET] Generation complete.
[2019-05-05 08:27] [ALPM] upgraded gcc-libs (8.2.1+20181127-1.0 -> 8.3.0-1.0)
[2019-05-05 08:27] [ALPM] upgraded ncurses (6.1-4.0 -> 6.1-6.0)
[2019-05-05 08:27] [ALPM] upgraded bash (5.0.002-1.0 -> 5.0.003-1.1)
[2019-05-05 08:27] [ALPM] upgraded cracklib (2.9.6-3.0 -> 2.9.7-1.0)
[2019-05-05 08:27] [ALPM] upgraded libutil-linux (2.33.1-1.0 -> 2.33.2-1.0)
[2019-05-05 08:27] [ALPM] upgraded perl (5.28.1-1.0 -> 5.28.2-1.0)
[2019-05-05 08:27] [ALPM] upgraded openssl (1.1.1.b-1.0 -> 1.1.1.b-1.1)
[2019-05-05 08:27] [ALPM] upgraded attr (2.4.48-1.3 -> 2.4.48-1.4)
[2019-05-05 08:27] [ALPM] upgraded shadow (4.6-2.0 -> 4.6-2.1)
[2019-05-05 08:27] [ALPM] upgraded libcap (2.26-1.0 -> 2.27-1.0)
[2019-05-05 08:27] [ALPM] upgraded lz4 (1:1.8.3-1.1 -> 1:1.9.1-1.0)
[2019-05-05 08:27] [ALPM] installed systemd-libs (242.19-1.0)
[2019-05-05 08:27] [ALPM] upgraded libcap-ng (0.7.9-1.3 -> 0.7.9-1.4)
[2019-05-05 08:27] [ALPM] upgraded util-linux (2.33.1-2.3 -> 2.33.2-1.0)
[2019-05-05 08:27] [ALPM] upgraded apr (1.6.5-1.0 -> 1.6.5-1.1)
[2019-05-05 08:27] [ALPM] upgraded expat (2.2.6-1.2 -> 2.2.6-1.3)
[2019-05-05 08:27] [ALPM] upgraded apr-util (1.6.1-3.1 -> 1.6.1-5.0)
[2019-05-05 08:27] [ALPM] upgraded bzip2 (1.0.6-8.6 -> 1.0.6-8.7)
[2019-05-05 08:27] [ALPM] warning: /etc/httpd/conf/httpd.conf installed as /etc/httpd/conf/httpd.conf.pacnew
[2019-05-05 08:27] [ALPM] upgraded apache (2.4.38-1.0 -> 2.4.39-1.0)
[2019-05-05 08:27] [ALPM] upgraded argon2 (20171227-3.3 -> 20171227-3.4)
[2019-05-05 08:27] [ALPM] upgraded glib2 (2.58.3-1.0 -> 2.60.1-1.0)
[2019-05-05 08:27] [ALPM] upgraded at-spi2-core (2.30.1-1.0 -> 2.32.1-1.0)
[2019-05-05 08:27] [ALPM] upgraded icu (63.1-2.1 -> 64.2-1.0)
[2019-05-05 08:27] [ALPM] upgraded libxml2 (2.9.9-1.2 -> 2.9.9-2.0)
[2019-05-05 08:27] [ALPM] upgraded atk (2.30.0-1.0 -> 2.32-1.0)
[2019-05-05 08:27] [ALPM] upgraded at-spi2-atk (2.30.1-1.0 -> 2.32.0-1.0)
[2019-05-05 08:27] [ALPM] upgraded avahi (0.7+18+g1b5f401-1.4 -> 0.7+18+g1b5f401-1.5)
[2019-05-05 08:27] [ALPM] upgraded libnsl (1.2.0-1.3 -> 1.2.0-1.4)
[2019-05-05 08:27] [ALPM] upgraded python (3.7.3-1.0 -> 3.7.3-1.1)
[2019-05-05 08:27] [ALPM] upgraded libunistring (0.9.10-1.10 -> 0.9.10-1.11)
[2019-05-05 08:27] [ALPM] upgraded libidn2 (2.1.0-1.1 -> 2.1.1-2.5)
[2019-05-05 08:27] [ALPM] upgraded json-c (0.13.1-2.4 -> 0.13.1-2.5)
[2019-05-05 08:27] [ALPM] upgraded bind-tools (9.13.5-4.0 -> 9.14.0-1.0)
[2019-05-05 08:27] [ALPM] upgraded binutils (2.31.1-4.0 -> 2.32-1.9)
[2019-05-05 08:27] [ALPM] upgraded bluez-libs (5.50-3.1 -> 5.50-6.0)
[2019-05-05 08:27] [ALPM] upgraded boost-libs (1.69.0-1.0 -> 1.69.0-2.0)
[2019-05-05 08:27] [ALPM] upgraded libtasn1 (4.13-1.3 -> 4.13-1.4)
[2019-05-05 08:27] [ALPM] upgraded pcre2 (10.32-2.0 -> 10.32-2.1)
[2019-05-05 08:27] [ALPM] upgraded device-mapper (2.02.183-1.0 -> 2.02.184-4.0)
[2019-05-05 08:27] [ALPM] upgraded libnfnetlink (1.0.1-3.1 -> 1.0.1-3.2)
[2019-05-05 08:27] [ALPM] upgraded libusb (1.0.22-1.5 -> 1.0.22-1.6)
[2019-05-05 08:27] [ALPM] upgraded libnl (3.4.0-1.3 -> 3.4.0-1.4)
[2019-05-05 08:27] [ALPM] upgraded libpcap (1.9.0-1.3 -> 1.9.0-1.4)
[2019-05-05 08:27] [ALPM] upgraded systemd (240.93-1.0 -> 242.19-1.0)
[2019-05-05 08:27] [ALPM] upgraded gnutls (3.6.6-1.0 -> 3.6.7-1.0)
[2019-05-05 08:27] [ALPM] upgraded libpng (1.6.36-1.0 -> 1.6.37-1.0)
[2019-05-05 08:27] [ALPM] upgraded libjpeg-turbo (2.0.2-1.0 -> 2.0.2-1.1)
[2019-05-05 08:27] [ALPM] upgraded zstd (1.3.8-1.0 -> 1.4.0-1.0)
[2019-05-05 08:27] [ALPM] upgraded libcups (2.2.11-1.0 -> 2.2.11-2.0)
[2019-05-05 08:27] [ALPM] upgraded libvpx (1.7.0-1.1 -> 1.8.0-1.0)
[2019-05-05 08:27] [ALPM] upgraded freetype2 (2.10.0-1.0 -> 2.10.0-2.0)
[2019-05-05 08:27] [ALPM] upgraded libbluray (1.1.0-1.1 -> 1.1.1-1.0)
[2019-05-05 08:27] [ALPM] upgraded wayland (1.17.0-1.0 -> 1.17.0-1.1)
[2019-05-05 08:27] [ALPM] upgraded libunwind (1.3.1-1.0 -> 1.3.1-1.1)
[2019-05-05 08:28] [ALPM] upgraded llvm-libs (7.0.1-2.0 -> 8.0.0-1.0)
[2019-05-05 08:28] [ALPM] upgraded libva (2.4.0-1.0 -> 2.4.1-1.0)
[2019-05-05 08:28] [ALPM] upgraded x264 (2:155.r0a84d986-2.1 -> 2:157.r72db4377-1.4)
[2019-05-05 08:28] [ALPM] upgraded x265 (2.9-1.1 -> 3.0-1.4)
[2019-05-05 08:28] [ALPM] upgraded opus (1.3-1.0 -> 1.3.1-1.0)
[2019-05-05 08:28] [ALPM] upgraded sysfsutils (2.1.0-10.2 -> 2.1.0-10.3)
[2019-05-05 08:28] [ALPM] upgraded ffmpeg (1:4.1-1.6 -> 1:4.1.2-2.1)
[2019-05-05 08:28] [ALPM] upgraded sqlite (3.27.1-1.0 -> 3.28.0-1.0)
[2019-05-05 08:28] [ALPM] upgraded dconf (0.30.1-1.0 -> 0.32.0-3.0)
[2019-05-05 08:28] [ALPM] upgraded libgudev (232-1.1 -> 232-1.2)
[2019-05-05 08:28] [ALPM] upgraded colord (1.4.3-2.2 -> 1.4.4-1.0)
[2019-05-05 08:28] [ALPM] upgraded pixman (0.38.0-2.0 -> 0.38.4-1.0)
[2019-05-05 08:28] [ALPM] upgraded pango (1:1.43.0-1.0 -> 1:1.43.0-2.0)
[2019-05-05 08:28] [ALPM] upgraded libxkbcommon (0.8.4-1.0 -> 0.8.4-1.1)
[2019-05-05 08:28] [ALPM] upgraded libcroco (0.6.12+4+g9ad7287-2.0 -> 0.6.13-1.0)
[2019-05-05 08:28] [ALPM] upgraded libtool (2.4.6+42+gb88cebd5-2.1 -> 2.4.6+42+gb88cebd5-3.0)
[2019-05-05 08:28] [ALPM] upgraded libpsl (0.20.2-3.0 -> 0.20.2-5.1)
[2019-05-05 08:28] [ALPM] installed adobe-source-code-pro-fonts (2.030ro+1.050it-5.0)
[2019-05-05 08:28] [ALPM] upgraded gsettings-desktop-schemas (3.28.1-1.0 -> 3.32.0-2.0)
[2019-05-05 08:28] [ALPM] upgraded glib-networking (2.58.0-1.0 -> 2.60.1+2+g1ce6b40-1.0)
[2019-05-05 08:28] [ALPM] upgraded chromium (72.0.3626.121-1.0 -> 73.0.3683.75-2.0)
[2019-05-05 08:28] [ALPM] upgraded coin-or-coinutils (2.11.1-1.0 -> 2.11.2-1.0)
[2019-05-05 08:28] [ALPM] upgraded coin-or-osi (0.108.3-1.0 -> 0.108.4-1.0)
[2019-05-05 08:28] [ALPM] upgraded coin-or-clp (1.17.1-1.0 -> 1.17.2-1.0)
[2019-05-05 08:28] [ALPM] upgraded coin-or-cgl (0.60.1-1.0 -> 0.60.2-1.0)
[2019-05-05 08:28] [ALPM] upgraded coin-or-cbc (2.10.1-1.0 -> 2.10.2-1.0)
[2019-05-05 08:28] [ALPM] upgraded findutils (4.6.0-4.0 -> 4.6.0-4.1)
[2019-05-05 08:28] [ALPM] upgraded curl (7.64.0-1.0 -> 7.64.1-2.1)
[2019-05-05 08:28] [ALPM] upgraded poppler (0.73.0-1.0 -> 0.74.0-1.1)
[2019-05-05 08:28] [ALPM] upgraded liblqr (0.4.2-2.1 -> 0.4.2-2.2)
[2019-05-05 08:28] [ALPM] upgraded imagemagick (7.0.8.34-1.0 -> 7.0.8.42-1.0)
[2019-05-05 08:28] [ALPM] upgraded liblouis (3.8.0-1.4 -> 3.9.0-1.0)
[2019-05-05 08:28] [ALPM] upgraded cups-filters (1.21.6-2.0 -> 1.22.5-1.0)
[2019-05-05 08:28] [ALPM] upgraded cups (2.2.11-1.0 -> 2.2.11-2.0)
[2019-05-05 08:28] [ALPM] upgraded dhcpcd (7.0.8-1.4 -> 7.2.1-1.0)
[2019-05-05 08:28] [ALPM] upgraded dnsmasq (2.80-2.1 -> 2.80-3.1)
[2019-05-05 08:28] [ALPM] upgraded double-conversion (3.1.1-1.0 -> 3.1.4-1.0)
[2019-05-05 08:28] [ALPM] upgraded less (530-1.5 -> 530-1.6)
[2019-05-05 08:28] [ALPM] upgraded engrampa (1.20.2-1.0 -> 1.22.0-1.0)
[2019-05-05 08:28] [ALPM] upgraded fuse-common (3.4.2-1.0 -> 3.5.0-1.0)
[2019-05-05 08:29] [ALPM] upgraded gcc (8.2.1+20181127-1.0 -> 8.3.0-1.0)
[2019-05-05 08:29] [ALPM] upgraded libgexiv2 (0.10.8-2.2 -> 0.12.0-1.0)
[2019-05-05 08:29] [ALPM] installed luajit (2.0.5-2.0)
[2019-05-05 08:29] [ALPM] upgraded lensfun (0.3.2-7.2 -> 0.3.2-7.3)
[2019-05-05 08:29] [ALPM] upgraded gegl (0.4.12-1.0 -> 0.4.14-1.0)
[2019-05-05 08:29] [ALPM] upgraded libheif (1.3.2-2.0 -> 1.4.0-1.1)
[2019-05-05 08:29] [ALPM] upgraded python2 (2.7.16-1.1 -> 2.7.16-1.2)
[2019-05-05 08:29] [ALPM] upgraded python2-cairo (1.18.0-1.2 -> 1.18.0-1.4)
[2019-05-05 08:29] [ALPM] upgraded pygobject2-devel (2.28.7-2.4 -> 2.28.7-2.5)
[2019-05-05 08:29] [ALPM] upgraded python2-gobject2 (2.28.7-2.4 -> 2.28.7-2.5)
[2019-05-05 08:29] [ALPM] upgraded pygtk (2.24.0-8.3 -> 2.24.0-8.4)
[2019-05-05 08:29] [ALPM] upgraded gimp (2.10.8-1.0 -> 2.10.10-1.0)
[2019-05-05 08:29] [ALPM] upgraded git (2.21.0-1.0 -> 2.21.0-1.1)
[2019-05-05 08:29] [ALPM] upgraded glibmm (2.58.0-1.0 -> 2.60.0-1.0)
[2019-05-05 08:29] [ALPM] upgraded glslang (7.11.3113-1.0 -> 7.11.3188-1.0)
[2019-05-05 08:29] [ALPM] upgraded gobject-introspection-runtime (1.58.3-1.0 -> 1.60.1-1.0)
[2019-05-05 08:29] [ALPM] upgraded groff (1.22.3-8.1 -> 1.22.4-1.0)
[2019-05-05 08:29] [ALPM] upgraded openal (1.19.1-1.0 -> 1.19.1-2.0)
[2019-05-05 08:29] [ALPM] upgraded vulkan-icd-loader (1.1.101-1.0 -> 1.1.107-1.0)
[2019-05-05 08:29] [ALPM] upgraded gstreamer (1.14.4-1.0 -> 1.16.0-1.0)
[2019-05-05 08:29] [ALPM] upgraded orc (0.4.28-1.1 -> 0.4.29-1.0)
[2019-05-05 08:29] [ALPM] upgraded gupnp-igd (0.2.5-1.4 -> 0.2.5+3+gedd78a6-2.0)
[2019-05-05 08:29] [ALPM] upgraded gst-plugins-bad (1.14.4-5.0 -> 1.14.4+22+ge87fb02c1-1.0)
[2019-05-05 08:29] [ALPM] upgraded gst-plugins-good (1.14.4-1.0 -> 1.14.4-2.0)
[2019-05-05 08:29] [ALPM] upgraded gtksourceview3 (3.24.10-1.0 -> 3.24.10-1.1)
[2019-05-05 08:29] [ALPM] upgraded libsecret (0.18.8-2.0 -> 0.18.8-2.1)
[2019-05-05 08:29] [ALPM] upgraded mdadm (4.0-2.0 -> 4.1-1.0)
[2019-05-05 08:29] [ALPM] upgraded ndctl (64.1-1.0 -> 64.1-2.0)
[2019-05-05 08:29] [ALPM] upgraded parted (3.2-8.0 -> 3.2-8.1)
[2019-05-05 08:29] [ALPM] upgraded xfsprogs (4.20.0-1.0 -> 4.20.0-2.0)
[2019-05-05 08:29] [ALPM] upgraded libaio (0.3.111-2.0 -> 0.3.112-1.0)
[2019-05-05 08:29] [ALPM] upgraded thin-provisioning-tools (0.7.6-1.2 -> 0.8.0-1.0)
[2019-05-05 08:29] [ALPM] upgraded libksba (1.3.5-1.2 -> 1.3.5-1.3)
[2019-05-05 08:29] [ALPM] upgraded pinentry (1.1.0-4.15 -> 1.1.0-4.18)
[2019-05-05 08:29] [ALPM] upgraded gvfs (1.38.1+8+ge4eec2bc-1.1 -> 1.38.2-1.0)
[2019-05-05 08:29] [ALPM] upgraded gvfs-mtp (1.38.1+8+ge4eec2bc-1.1 -> 1.38.2-1.0)
[2019-05-05 08:29] [ALPM] upgraded harfbuzz-icu (2.3.1-2.0 -> 2.4.0-2.0)
[2019-05-05 08:29] [ALPM] upgraded python-dbus-common (1.2.8-2.3 -> 1.2.8-2.4)
[2019-05-05 08:29] [ALPM] upgraded python-dbus (1.2.8-2.3 -> 1.2.8-2.4)
[2019-05-05 08:29] [ALPM] upgraded pygobject-devel (3.30.4-1.2 -> 3.32.0-1.0)
[2019-05-05 08:29] [ALPM] upgraded python-gobject (3.30.4-1.2 -> 3.32.0-1.0)
[2019-05-05 08:29] [ALPM] upgraded hplip (1:3.19.1-1.0 -> 1:3.19.3-1.0)
[2019-05-05 08:29] [ALPM] upgraded inetutils (1.9.4-7.1 -> 1.9.4-7.2)
[2019-05-05 08:29] [ALPM] upgraded iputils (20180629.f6aac8d-3.1 -> 20180629.f6aac8d-4.2)
[2019-05-05 08:29] [ALPM] upgraded talloc (2.1.16-1.0 -> 2.2.0-1.0)
[2019-05-05 08:29] [ALPM] upgraded ldb (1:1.4.6-1.0 -> 1:1.5.4-2.0)
[2019-05-05 08:29] [ALPM] upgraded libcdr (0.1.5-1.0 -> 0.1.5-2.0)
[2019-05-05 08:29] [ALPM] upgraded libe-book (0.1.3-4.2 -> 0.1.3-5.0)
[2019-05-05 08:29] [ALPM] upgraded libfbclient (2.5.8.27089-3.1 -> 3.0.4.33054-1.0)
[2019-05-05 08:30] [ALPM] upgraded libfreehand (0.1.2-1 -> 0.1.2-2.0)
[2019-05-05 08:30] [ALPM] upgraded libgnome-keyring (3.12.0-3.0 -> 3.12.0+11+g3766bcc-1.0)
[2019-05-05 08:30] [ALPM] upgraded libgtop (2.38.0+13+gcab8791f-1.1 -> 2.40.0-1.0)
[2019-05-05 08:30] [ALPM] upgraded libinput (1.12.6-1.0 -> 1.13.1-1.0)
[2019-05-05 08:30] [ALPM] upgraded libmatemixer (1.20.1-1.1 -> 1.22.0-1.0)
[2019-05-05 08:30] [ALPM] upgraded libmspub (0.1.4-4.1 -> 0.1.4-5.0)
[2019-05-05 08:30] [ALPM] upgraded libmwaw (0.3.14-1.1 -> 0.3.15-1.0)
[2019-05-05 08:30] [ALPM] upgraded libplist (2.0.0+11+gec9ba8b-2.5 -> 2.0.0+11+gec9ba8b-2.6)
[2019-05-05 08:30] [ALPM] upgraded libqxp (0.0.2-1.0 -> 0.0.2-2.0)
[2019-05-05 08:30] [ALPM] upgraded libvisio (0.1.6-5.1 -> 0.1.6-6.0)
[2019-05-05 08:30] [ALPM] upgraded libzmf (0.0.2-5.1 -> 0.0.2-6.0)
[2019-05-05 08:30] [ALPM] upgraded raptor (2.0.15-10.1 -> 2.0.15-11.0)
[2019-05-05 08:30] [ALPM] upgraded libreoffice-fresh (6.1.4-4.1 -> 6.2.0-3.0)
[2019-05-05 08:30] [ALPM] upgraded libsynctex (2018.48691-4.0 -> 2018.48691-6.0)
[2019-05-05 08:30] [ALPM] upgraded libtorrent-rasterbar (1:1.1.12-1.0 -> 1:1.1.12-1.2)
[2019-05-05 08:30] [ALPM] upgraded libwbclient (4.10.0-1.0 -> 4.10.2-1.0)
[2019-05-05 08:30] [ALPM] upgraded libxkbcommon-x11 (0.8.4-1.0 -> 0.8.4-1.1)
[2019-05-05 08:30] [ALPM] upgraded libxklavier (5.4-2.1 -> 5.4-2.2)
[2019-05-05 08:31] [ALPM] upgraded libxnvctrl (418.43-1.0 -> 418.56-1.0)
[2019-05-05 08:31] [ALPM] upgraded linux (5.0.6.arch1-1.0 -> 5.0.7.arch1-1.0)
[2019-05-05 08:31] [ALPM] upgraded lua (5.3.5-2.0 -> 5.3.5-2.1)
[2019-05-05 08:31] [ALPM] upgraded lua52 (5.2.4-4.0 -> 5.2.4-4.1)
[2019-05-05 08:31] [ALPM] upgraded man-db (2.8.5-1.1 -> 2.8.5-2.0)
[2019-05-05 08:31] [ALPM] upgraded mate-desktop (1.20.4-1.0 -> 1.22.0-1.0)
[2019-05-05 08:31] [ALPM] upgraded marco (1.20.3-1.0 -> 1.22.0-1.0)
[2019-05-05 08:31] [ALPM] upgraded mariadb-libs (10.3.12-5.0 -> 10.3.13-4.0)
[2019-05-05 08:31] [ALPM] upgraded mate-media (1.20.2-1.0 -> 1.22.0-1.0)
[2019-05-05 08:31] [ALPM] upgraded mate-menus (1.20.2-1.3 -> 1.22.0-1.0)
[2019-05-05 08:31] [ALPM] upgraded mate-system-monitor (1.20.2-1.0 -> 1.22.0-1.0)
[2019-05-05 08:31] [ALPM] upgraded mate-utils (1.20.2-1.0 -> 1.22.0-1.0)
[2019-05-05 08:31] [ALPM] upgraded smbclient (4.10.0-1.0 -> 4.10.2-1.0)
[2019-05-05 08:32] [ALPM] upgraded mplayer (38125-4.2 -> 38125-4.3)
[2019-05-05 08:32] [ALPM] upgraded nano (4.0-2.0 -> 4.2-1.0)
[2019-05-05 08:32] [ALPM] upgraded netdata (1.13.0-1.0 -> 1.13.0-2.0)
[2019-05-05 08:32] [ALPM] upgraded obconf (2.0.4-5.1 -> 2.0.4-6.0)
[2019-05-05 08:32] [ALPM] upgraded openssh (7.9p1-1.0 -> 8.0p1-1.0)
[2019-05-05 08:32] [ALPM] upgraded openssl-1.0 (1.0.2.r-1.0 -> 1.0.2.r-1.2)
[2019-05-05 08:32] [ALPM] upgraded pacman (5.1.3-1.0 -> 5.1.3-1.3)
[2019-05-05 08:32] [ALPM] upgraded pcmciautils (018-8.4 -> 018-8.5)
[2019-05-05 08:32] [ALPM] upgraded poppler-glib (0.73.0-1.0 -> 0.74.0-1.1)
[2019-05-05 08:32] [ALPM] upgraded postgresql-libs (11.1-3.0 -> 11.2-1.0)
[2019-05-05 08:32] [ALPM] upgraded python-aiorpcx (0.11.0-1.0 -> 0.13.0-1.0)
[2019-05-05 08:32] [ALPM] upgraded python-jsonrpclib-pelix (0.3.2-1.0 -> 0.4.0-1.0)
[2019-05-05 08:32] [ALPM] upgraded python-pyparsing (2.3.0-1.0 -> 2.3.1-1.0)
[2019-05-05 08:32] [ALPM] upgraded python-sip-pyqt5 (4.19.15-1.0 -> 4.19.16-1.0)
[2019-05-05 08:32] [ALPM] upgraded python2-dbus (1.2.8-2.3 -> 1.2.8-2.4)
[2019-05-05 08:32] [ALPM] upgraded python2-gobject (3.30.4-1.2 -> 3.32.0-1.0)
[2019-05-05 08:32] [ALPM] upgraded python2-mechanize (1:0.4.1-1.0 -> 1:0.4.2-1.0)
[2019-05-05 08:32] [ALPM] upgraded python2-regex (2019.03.12-1.0 -> 2019.04.14-1.0)
[2019-05-05 08:32] [ALPM] upgraded python2-setuptools (1:40.9.0-1.0 -> 1:41.0.1-1.0)
[2019-05-05 08:32] [ALPM] upgraded python2-sip-pyqt5 (4.19.15-1.0 -> 4.19.16-1.0)
[2019-05-05 08:32] [ALPM] upgraded qt5-base (5.12.1-2.0 -> 5.12.3-2.1)
[2019-05-05 08:32] [ALPM] upgraded qbittorrent (4.1.5-2.0 -> 4.1.5-2.1)
[2019-05-05 08:32] [ALPM] upgraded qt4 (4.8.7-26.0 -> 4.8.7-27.0)
[2019-05-05 08:32] [ALPM] upgraded qt5-location (5.12.1-1.1 -> 5.12.2-1.1)
[2019-05-05 08:33] [ALPM] upgraded rclone (1.46-1.0 -> 1.47.0-1.0)
[2019-05-05 08:33] [ALPM] upgraded s-nail (14.9.11-2.1 -> 14.9.13-2.1)
[2019-05-05 08:33] [ALPM] upgraded samba (4.10.0-1.0 -> 4.10.2-1.0)
[2019-05-05 08:33] [ALPM] upgraded subversion (1.11.0-1.1 -> 1.11.1-1.7)
[2019-05-05 08:33] [ALPM] upgraded systemd-sysvcompat (240.93-1.0 -> 242.19-1.0)
[2019-05-05 08:33] [ALPM] upgraded vim-runtime (8.1.0996-1.0 -> 8.1.1073-1.0)
[2019-05-05 08:33] [ALPM] upgraded vim (8.1.0996-1.0 -> 8.1.1073-1.0)
[2019-05-05 08:33] [ALPM] upgraded vlc (3.0.6-1.1 -> 3.0.6-11.0)
[2019-05-05 08:33] [ALPM] upgraded workrave (1.10.23-2.0 -> 1.10.31-1.0)
[2019-05-05 08:33] [ALPM] upgraded wpa_supplicant (2:2.6-2.0 -> 2:2.6-2.1)
[2019-05-05 08:33] [ALPM] upgraded xf86-video-intel (1:2.99.917+859+g33ee0c3b-1.0 -> 1:2.99.917+863+g6afed33b-1.1)
[2019-05-05 08:33] [ALPM] upgraded xorg-server-common (1.20.3-1.0 -> 1.20.4-1.0)
[2019-05-05 08:33] [ALPM] upgraded xorg-server (1.20.3-1.0 -> 1.20.4-1.0)
[2019-05-05 08:33] [ALPM] upgraded xorg-server-devel (1.20.3-1.0 -> 1.20.4-1.0)
[2019-05-05 08:33] [ALPM] upgraded xorg-server-xephyr (1.20.3-1.0 -> 1.20.4-1.0)
[2019-05-05 08:33] [ALPM] transaction completed
[2019-05-05 08:33] [ALPM] running '60-linux.hook'...
[2019-05-05 08:34] [ALPM] running '90-linux-lts.hook'...
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> Starting build: 4.19.34-1.0-lts
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [lvm2]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> Starting build: 4.19.34-1.0-lts
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-05-05 08:34] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2019-05-05 08:34] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [lvm2]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2019-05-05 08:35] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-05-05 08:35] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2019-05-05 08:35] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-05-05 08:35] [ALPM] running '90-linux.hook'...
[2019-05-05 08:35] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2019-05-05 08:35] [ALPM-SCRIPTLET] ==> Starting build: 5.0.7-arch1-1.0-ARCH
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [lvm2]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-05-05 08:35] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2019-05-05 08:35] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-05-05 08:35] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2019-05-05 08:36] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-05-05 08:36] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2019-05-05 08:36] [ALPM-SCRIPTLET] ==> Starting build: 5.0.7-arch1-1.0-ARCH
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-05-05 08:36] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2019-05-05 08:36] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [lvm2]
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-05-05 08:36] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2019-05-05 08:36] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-05-05 08:36] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2019-05-05 08:37] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-05-05 08:37] [ALPM] running 'detect-old-perl-modules.hook'...
[2019-05-05 08:37] [ALPM] running 'fontconfig.hook'...
[2019-05-05 08:37] [ALPM] running 'gio-querymodules.hook'...
[2019-05-05 08:37] [ALPM] running 'glib-compile-schemas.hook'...
[2019-05-05 08:37] [ALPM] running 'gtk-update-icon-cache.hook'...
[2019-05-05 08:37] [ALPM] running 'gvfsd.hook'...
[2019-05-05 08:37] [ALPM] running 'systemd-catalog.hook'...
[2019-05-05 08:37] [ALPM] running 'systemd-daemon-reload.hook'...
[2019-05-05 08:37] [ALPM] running 'systemd-hwdb.hook'...
[2019-05-05 08:37] [ALPM] running 'systemd-sysctl.hook'...
[2019-05-05 08:37] [ALPM] running 'systemd-sysusers.hook'...
[2019-05-05 08:37] [ALPM] running 'systemd-tmpfiles.hook'...
[2019-05-05 08:37] [ALPM] running 'systemd-udev-reload.hook'...
[2019-05-05 08:37] [ALPM] running 'systemd-update.hook'...
[2019-05-05 08:37] [ALPM] running 'texinfo-install.hook'...
[2019-05-05 08:37] [ALPM] running 'update-desktop-database.hook'...
[2019-05-05 08:37] [ALPM] running 'update-mime-database.hook'...
[2019-05-05 08:37] [ALPM] running 'update-vlc-plugin-cache.hook'...
[2019-05-05 08:37] [ALPM] running 'xorg-mkfontscale.hook'...

And these are the errors after full system upgrade:

$ mate-control-center 
mate-control-center: symbol lookup error: /usr/lib/libmate-slab.so.0: undefined symbol: matemenu_tree_directory_get_contents

$ ls -l /usr/lib/libmate-slab.so*
lrwxrwxrwx 1 root root     21 dic 21 06:32 /usr/lib/libmate-slab.so -> libmate-slab.so.0.0.0
lrwxrwxrwx 1 root root     21 dic 21 06:32 /usr/lib/libmate-slab.so.0 -> libmate-slab.so.0.0.0
-rwxr-xr-x 1 root root 119980 dic 21 06:32 /usr/lib/libmate-slab.so.0.0.0

$ mate-panel
mate-panel: symbol lookup error: mate-panel: undefined symbol: matemenu_tree_item_get_type

$ mate-screensaver
mate-screensaver: symbol lookup error: mate-screensaver: undefined symbol: matemenu_tree_item_get_type

$ mate-screensaver-preferences 
mate-screensaver-preferences: symbol lookup error: mate-screensaver-preferences: undefined symbol: matemenu_tree_item_get_type

$ gnucash 
gnucash: error while loading shared libraries: libicuuc.so.63: cannot open shared object file: No such file or directory

Using the following commands as you say I solved the issue with gnucash:

$ cd /
$ sudo bsdtar -xf /var/cache/pacman/pkg/icu-63.1-2.1-i686.pkg.tar.xz usr/lib/libicuuc.so.63.1
$ sudo bsdtar -xf /var/cache/pacman/pkg/icu-63.1-2.1-i686.pkg.tar.xz usr/lib/libicuuc.so.63
$ sudo bsdtar -xf /var/cache/pacman/pkg/icu-63.1-2.1-i686.pkg.tar.xz usr/lib/libicui18n.so.63.1
$ sudo bsdtar -xf /var/cache/pacman/pkg/icu-63.1-2.1-i686.pkg.tar.xz usr/lib/libicui18n.so.63
$ sudo bsdtar -xf /var/cache/pacman/pkg/icu-63.1-2.1-i686.pkg.tar.xz usr/lib/libicudata.so.63
$ sudo bsdtar -xf /var/cache/pacman/pkg/icu-63.1-2.1-i686.pkg.tar.xz usr/lib/libicudata.so.63.1

But I don't know how to solve the issue with mate-control-center and the others programs from mate.

My question is: ¿Is possible don't broke packages with full system upgrade?

I prefer that full system upgrade don't upgrade some libraries or packages and the system works fine and wait until all packages work together. I don't mind wait several weeks until a new full system upgrade is ready. Is very annoying to do a full system upgrade and notice that some packages are broken. I had this issue before.

I have archlinux 64Bits on another computer and I don't have this issue on it.

I know that is a lot of work build all packages, check them and maintain archlinux 32Bits, but is better to have a stable system than a system that broke frequently. Nobody wants a very unstable distribution.

Last edited by archlinux32forever (2019-05-05 18:46:31)

Offline

#5 2019-05-05 18:42:22

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 448

Re: [Solved] empathy, gnome-control-center not work, icu packet...

the problem with the updates was pretty good described by abaumann on irc:
[20:19:05] <abaumann> well. the problem is more or less like this: too few hands, too few testing..
[20:19:18] <abaumann> ..then things get stuck (I mean 1000nds of packages in testing).
[20:19:25] <abaumann> then we push. and things break. :-)

e.g. the regular scheduling logic works fine, but then we see almost no updates of certain packages. When we then force-move some stuff, we obviously break stuff.

Offline

#6 2019-05-05 19:05:19

archlinux32forever
Member
Registered: 2018-05-21
Posts: 16

Re: [Solved] empathy, gnome-control-center not work, icu packet...

I understand.

I would like help to test packages. I need instructions how to do it and what bunch of packages to test. If more people join we can avoid these issues. I hope more archlinux 32 users will join to test packages and make archlinux 32 more stable.

My time is limited and my netbook only has 94Gb free now.

Offline

#7 2019-05-06 05:02:17

radli
Member
Registered: 2018-04-27
Posts: 26

Re: [Solved] empathy, gnome-control-center not work, icu packet...

Hello,

I have the same problem with chromium

xcart-aim-arch[~]$ chromium          
/usr/lib/chromium/chromium: error while loading shared libraries: libicui18n.so.63: cannot open shared object file: No such file or directory

xcart-aim-arch[/usr/lib]$ sudo ln -s libicui18n.so.64.2 libicui18n.so.63
xcart-aim-arch[/usr/lib]$ l libicui18n*                                 
-rwxr-xr-x 1 root root 3167764 Apr 30 00:29 libicui18n.so.64.2*
lrwxrwxrwx 1 root root      18 Apr 30 00:29 libicui18n.so.64 -> libicui18n.so.64.2*
lrwxrwxrwx 1 root root      18 Apr 30 00:29 libicui18n.so -> libicui18n.so.64.2*
lrwxrwxrwx 1 root root      18 May  6 08:54 libicui18n.so.63 -> libicui18n.so.64.2*
xcart-aim-arch[/usr/lib]$ chromium 
/usr/lib/chromium/chromium: error while loading shared libraries: libicuuc.so.63: cannot open shared object file: No such file or directory
xcart-aim-arch[/usr/lib]$ l libicuuc*  
-rwxr-xr-x 1 root root 1918180 Apr 30 00:29 libicuuc.so.64.2*
lrwxrwxrwx 1 root root      16 Apr 30 00:29 libicuuc.so.64 -> libicuuc.so.64.2*
lrwxrwxrwx 1 root root      16 Apr 30 00:29 libicuuc.so -> libicuuc.so.64.2*
xcart-aim-arch[/usr/lib]$ sudo ln -s libicuuc.so.64.2 libicuuc.so.63
xcart-aim-arch[/usr/lib]$ l libicuuc*                               
-rwxr-xr-x 1 root root 1918180 Apr 30 00:29 libicuuc.so.64.2*
lrwxrwxrwx 1 root root      16 Apr 30 00:29 libicuuc.so.64 -> libicuuc.so.64.2*
lrwxrwxrwx 1 root root      16 Apr 30 00:29 libicuuc.so -> libicuuc.so.64.2*
lrwxrwxrwx 1 root root      16 May  6 08:55 libicuuc.so.63 -> libicuuc.so.64.2*
xcart-aim-arch[/usr/lib]$ chromium    
/usr/lib/chromium/chromium: symbol lookup error: /usr/lib/chromium/chromium: undefined symbol: u_iscntrl_63

Offline

#8 2019-05-06 06:18:16

gard
Member
Registered: 2019-05-04
Posts: 9

Re: [Solved] empathy, gnome-control-center not work, icu packet...

Archlinux32 have has something like "Arch Linux Archive" (rollback machine)?
This would solve a lot of problems with updates.

Last edited by gard (2019-05-06 06:19:00)

Offline

#9 2019-05-06 07:43:37

radli
Member
Registered: 2018-04-27
Posts: 26

Re: [Solved] empathy, gnome-control-center not work, icu packet...

gard wrote:

Archlinux32 have has something like "Arch Linux Archive" (rollback machine)?
This would solve a lot of problems with updates.

It has been broken now
https://bbs.archlinux32.org/viewtopic.php?id=2728

Offline

#10 2019-05-06 08:48:41

gard
Member
Registered: 2019-05-04
Posts: 9

Re: [Solved] empathy, gnome-control-center not work, icu packet...

I replied to the link.
It is surprising that ALA exists, but packages only until 11/22/2018.

Offline

#11 2019-05-06 08:51:28

radli
Member
Registered: 2018-04-27
Posts: 26

Re: [Solved] empathy, gnome-control-center not work, icu packet...

gard wrote:

I replied to the link.
It is surprising that ALA exists, but packages only until 11/22/2018.

Thank you.

Anyway,ALA hasn't helped me to fix the problem

/usr/lib/chromium/chromium: error while loading shared libraries: libicui18n.so.63: cannot open shared object file: No such file or directory

Offline

#12 2019-05-06 08:55:14

gard
Member
Registered: 2019-05-04
Posts: 9

Re: [Solved] empathy, gnome-control-center not work, icu packet...

icu63 installed?

Offline

#13 2019-05-06 09:01:55

radli
Member
Registered: 2018-04-27
Posts: 26

Re: [Solved] empathy, gnome-control-center not work, icu packet...

core/icu 64.2-1.0
and
extra/chromium 73.0.3683.75-2.0

are installed

Offline

#14 2019-05-06 09:18:25

gard
Member
Registered: 2019-05-04
Posts: 9

Re: [Solved] empathy, gnome-control-center not work, icu packet...

Chromium requires icu63.
You may follow the instructions above, download icu63:
https://archive.archlinux32.org/package … pkg.tar.xz
unpack it and placed need files to /usr/lib/

Or perform a system downgrade until 11/22/2018, as i write here:
https://bbs.archlinux32.org/viewtopic.php?id=2728

ps: libicui18n.so.63 if file prom icu packet.

Last edited by gard (2019-05-06 09:18:52)

Offline

#15 2019-05-07 01:59:55

K8ebBM214bp4UJV
Member
Registered: 2018-10-04
Posts: 15

Re: [Solved] empathy, gnome-control-center not work, icu packet...

hello.

for people having trouble with chromium 73 and icu 64, i got kind of a temp solution.  although downgrading icu is possible, like others have said it would cause more issues, and with the archive dead as roll back alternative, it's not easier.

now if you upgraded to the pentium4 arch, you need to go back to i686.  my "solution" is to install a precompiled chromium 74.  so with your system updated up and running on the i686 arch, look up for the manjaro archive /x32-testing/extra/ and download the file chromium-74.0.3729.131-0.2-i686.pkg.tar.xz  (about 49MB)

you can install the file manually by doing

sudo pacman -U chromium-74.0.3729.131-0.2-i686.pkg.tar.xz

things to consider: you would be installing a file from another project, though it will work, it will not have any archlinux32 patches or anything to do with archlinux32.  you are trusting the source you are downloading the package from, so if you are trusting the archlinux32 devs,  i don't think there would be a problem trusting manjaro's.  this is a "hack" solution.  if you currently moved to the pentium4 arch, you won't be able to install this as it would be the wrong architecture.

i'm currently running it without issues.  once the package is compiled by our wonderful devs, you could remove this one and get the one from the official archlinux32 repos, and maybe move to the pentium4 arch.

of course every other package depending on icu 63 is still broken.  you could try hunting down the updated precompiled package from manjaro but i havent tried.

good luck!

Offline

#16 2019-05-07 06:12:51

radli
Member
Registered: 2018-04-27
Posts: 26

Re: [Solved] empathy, gnome-control-center not work, icu packet...

Hello,

Thank you for your solutions.

Another one is changing
extra/chromium 73.0.3683.75-2.0
    A web browser built for speed, simplicity, and security

to

aur/chromium-dev 75.0.3770.15-1 (157) (0,46)
    The open-source project behind Google Chrome (Dev Channel)

Offline

#17 2019-05-07 19:28:00

K8ebBM214bp4UJV
Member
Registered: 2018-10-04
Posts: 15

Re: [Solved] empathy, gnome-control-center not work, icu packet...

radli wrote:

aur/chromium-dev 75.0.3770.15-1 (157) (0,46)
    The open-source project behind Google Chrome (Dev Channel)


not really.  most AUR packages are also 64 bits only.  just to see, i tried.  even modified the pkgbuild file and tried to feed 32 bit dependencies.  no dice.

Offline

#18 2019-05-08 05:49:43

tulainas
Member
Registered: 2019-05-08
Posts: 2

Re: [Solved] empathy, gnome-control-center not work, icu packet...

gard wrote:

Chromium requires icu63.
You may follow the instructions above, download icu63:
https://archive.archlinux32.org/package … pkg.tar.xz
unpack it and placed need files to /usr/lib/

Or perform a system downgrade until 11/22/2018, as i write here:
https://bbs.archlinux32.org/viewtopic.php?id=2728

ps: libicui18n.so.63 if file prom icu packet.

This actually solved part of the problem (although I was trying to run midori).

Now, it keeps telling me this:

$ midori
midori: symbol lookup error: /usr/lib/libharfbuzz-icu.so.0: undefined symbol: u_countChar32_64

Which i'm still thinking how to workaround.

Offline

#19 2019-05-08 10:50:03

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [Solved] empathy, gnome-control-center not work, icu packet...

lddtree /usr/bin/midori shows:

libwebkit2gtk-4.0.so.37 => /usr/lib/libwebkit2gtk-4.0.so.37
   libicuuc.so.63 => None
   libicui18n.so.63 => None

webkit2gtk on pentium4 should be ok. On i686 it needs rebuilding against icu 64, but this
fails at the moment, because the package needs some non-SSE2 patching (which has
to be done yet)..

You can unpack /usr/lib/libicu*.so.63 from an older icu package.

Offline

#20 2019-05-10 00:37:02

tulainas
Member
Registered: 2019-05-08
Posts: 2

Re: [Solved] empathy, gnome-control-center not work, icu packet...

tulainas wrote:
gard wrote:

Chromium requires icu63.
You may follow the instructions above, download icu63:
https://archive.archlinux32.org/package … pkg.tar.xz
unpack it and placed need files to /usr/lib/

Or perform a system downgrade until 11/22/2018, as i write here:
https://bbs.archlinux32.org/viewtopic.php?id=2728

ps: libicui18n.so.63 if file prom icu packet.

This actually solved part of the problem (although I was trying to run midori).

Now, it keeps telling me this:

$ midori
midori: symbol lookup error: /usr/lib/libharfbuzz-icu.so.0: undefined symbol: u_countChar32_64

Which i'm still thinking how to workaround.


After downgrading libxml2 and icu, and then re-updating them, I noticed pacman was complaining about libic***.so.63 to not being symbolic links (I actually just decompresed them into /usr/lib/ ).

So, I deleted them, and then made the respective links... And now everything is going normal again. Everything.

Probably this was just a workaround, but, it makes me happy for the time being.

Hope this helps anyone.

Last edited by tulainas (2019-05-10 01:06:40)

Offline

Board footer

Powered by FluxBB