You are not logged in.

#1 2019-05-08 05:07:43

rossboulet
Member
Registered: 2017-12-13
Posts: 36

[SOLVED] Another icu package mismatch

My last update broke my web server..I think I found the cause. I'm using package php-apache which installs libphp7.so. This module is looking for libicui18n.so.63 but icu now contains libicui18n.so.64

Last edited by rossboulet (2019-05-09 12:54:55)

Offline

#2 2019-05-08 21:28:18

rossboulet
Member
Registered: 2017-12-13
Posts: 36

Re: [SOLVED] Another icu package mismatch

Additional information FWIW: I downgraded icu to v63 but httpd still had a complaint about v64. I tracked it down to libxml2 and downgraded it too. I also found the icu downgrade broke named (from package bind) and postfix, so I downgraded them as well. Once php-apache gets an update, I can upgrade the others too,

Offline

#3 2019-05-09 06:50:07

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] Another icu package mismatch

Downgrading wont help as some things (actually most things) depend now on icu.64. What you can do is to
temporarily unpack the appripriate libraries /usr/lib/libicu*.63 from the 63 version of the icu package.
I'll reschedule php, but it will take a while, till it makes it's way to stable.

Offline

#4 2019-05-09 07:03:36

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] Another icu package mismatch

lddtree /usr/lib/httpd/modules/libphp.7:

    libxml2.so.2 => /usr/lib/libxml2.so.2
        libicuuc.so.64 => /usr/lib/libicuuc.so.64
            libicudata.so.64 => /usr/lib/libicudata.so.64
    liblzma.so.5 => /usr/lib/liblzma.so.5
    libicui18n.so.63 => None
    libicuuc.so.63 => None
    libicudata.so.63 => None

So libxml2 requires icu64, the module itself requires icu63. It's rescheduled.

Offline

#5 2019-05-09 08:55:12

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] Another icu package mismatch

Just pushed php 7.3.5-1.0 and php-apache 7.3.5-1.0 to stable for i686 and pentium4 architectures.
They should work now with icu.64.

Offline

#6 2019-05-09 12:54:23

rossboulet
Member
Registered: 2017-12-13
Posts: 36

Re: [SOLVED] Another icu package mismatch

Yes.It's all good now. Thank you.

Marking as solved.

Offline

Board footer

Powered by FluxBB