You are not logged in.

#1 2019-05-20 06:10:08

ess
Member
Registered: 2018-09-20
Posts: 8

After installation of pentium4 pack i can not install package from aur

Hello,

After successfully switching to the pentium 4 packages, I can no longer install teamviewer or anydesk from the aur. Generally I can not install a package with the extension i686.


[arch@myhost Pakete-Sicherung]$ sudo pacman -U teamviewer-14.2.8352-1-i686.pkg.tar.xz
Lade Pakete...
Fehler: Konnte den Vorgang nicht vorbereiten (Die Paket-Architektur ist ungültig)
:: Paket teamviewer-14.2.8352-1-i686 hat keine gültige Architektur 

pacman.conf:

 Architecture = auto 

Last edited by ess (2019-05-20 06:58:17)

Offline

#2 2019-05-20 08:00:16

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 818
Website

Re: After installation of pentium4 pack i can not install package from aur

Yes, Packages from the AUR have to be rebuilt. You have to add 'pentium4' to the 'arch' variable in the corresponding PKGBUILD files.

Offline

#3 2019-05-20 12:02:54

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 449

Re: After installation of pentium4 pack i can not install package from aur

note, that the change and rebuild will not be purely cosmetic:
If you merged your /etc/makepkg.conf before rebuilding the aur packages, you will actually build the packages with sse2 enabled - which may give you speed improvements (and incompatibility with older hardware, that is not capable of sse2).

Offline

Board footer

Powered by FluxBB