You are not logged in.

#1 2019-07-05 13:18:28

radli
Member
Registered: 2018-04-27
Posts: 26

[SOLVED] community/netbeans 10.0-0.0 doesn't work / Fatal error in JRE

Just installed community/netbeans 10.0-0.0 raises the error

xcart-aim-arch[~]$ sudo archlinux-java status
Available Java environments:
  java-11-openjdk
  java-8-openjdk (default)
xcart-aim-arch[~]$ /usr/bin/netbeans
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  Internal Error (os_linux_x86.cpp:291), pid=2512, tid=0xb6d98b40
#  fatal error: An irrecoverable SI_KERNEL SIGSEGV has occurred due to unstable signal handling in this distribution.
#
# JRE version: OpenJDK Runtime Environment (8.0_212-b01) (build 1.8.0_212-b01)
# Java VM: OpenJDK Server VM (25.212-b01 mixed mode linux-x86 )
# Core dump written. Default location: /home/aim/core or core.2512
#
# An error report file with more information is saved as:
# /home/aim/hs_err_pid2512.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
#
/usr/lib/netbeans/platform/lib/nbexec: line 425:  2512 Aborted                 (core dumped) "/usr/lib/jvm/default/bin/java" -Djdk.home="/usr/lib/jvm/default" -classpath "/usr/lib/netbeans/platform/lib/boot.jar:/usr/lib/netbeans/platform/lib/org-openide-modules.jar:/usr/lib/netbeans/platform/lib/org-openide-util.jar:/usr/lib/netbeans/platform/lib/org-openide-util-lookup.jar:/usr/lib/netbeans/platform/lib/org-openide-util-ui.jar:/usr/lib/jvm/default/lib/dt.jar:/usr/lib/jvm/default/lib/tools.jar" -Dnetbeans.default_userdir_root="/home/aim/.netbeans" -Dnetbeans.dirs="/usr/lib/netbeans/nb:/usr/lib/netbeans/ergonomics:/usr/lib/netbeans/ide:/usr/lib/netbeans/extide:/usr/lib/netbeans/java:/usr/lib/netbeans/apisupport:/usr/lib/netbeans/webcommon:/usr/lib/netbeans/websvccommon:/usr/lib/netbeans/enterprise:/usr/lib/netbeans/mobility:/usr/lib/netbeans/profiler:/usr/lib/netbeans/python:/usr/lib/netbeans/php:/usr/lib/netbeans/identity:/usr/lib/netbeans/harness:/usr/lib/netbeans/cnd:/usr/lib/netbeans/cndext:/usr/lib/netbeans/dlight:/usr/lib/netbeans/groovy:/usr/lib/netbeans/extra:/usr/lib/netbeans/javacard:/usr/lib/netbeans/javafx:" -Dnetbeans.home="/usr/lib/netbeans/platform" '-Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade' '-Xmx633m' '-XX:+UseStringDeduplication' '-Xss2m' '-Xms32m' '-Djdk.gtk.version=2.2' '-Dapple.laf.useScreenMenuBar=true' '-Dapple.awt.graphics.UseQuartz=true' '-Dsun.java2d.noddraw=true' '-Dsun.java2d.dpiaware=true' '-Dsun.zip.disableMemoryMapping=true' '-Dplugin.manager.check.updates=false' '-Dnetbeans.extbrowser.manual_chrome_plugin_install=yes' '--add-opens=java.base/java.net=ALL-UNNAMED' '--add-opens=java.base/java.lang.ref=ALL-UNNAMED' '--add-opens=java.base/java.lang=ALL-UNNAMED' '--add-opens=java.base/java.security=ALL-UNNAMED' '--add-opens=java.base/java.util=ALL-UNNAMED' '--add-opens=java.desktop/javax.swing.plaf.basic=ALL-UNNAMED' '--add-opens=java.desktop/javax.swing.text=ALL-UNNAMED' '--add-opens=java.desktop/javax.swing=ALL-UNNAMED' '--add-opens=java.desktop/java.awt=ALL-UNNAMED' '--add-opens=java.desktop/java.awt.event=ALL-UNNAMED' '--add-opens=java.prefs/java.util.prefs=ALL-UNNAMED' '--add-opens=jdk.jshell/jdk.jshell=ALL-UNNAMED' '--add-modules=jdk.jshell' '--add-exports=java.desktop/sun.awt=ALL-UNNAMED' '--add-exports=java.desktop/java.awt.peer=ALL-UNNAMED' '--add-exports=java.desktop/com.sun.beans.editors=ALL-UNNAMED' '--add-exports=java.desktop/sun.swing=ALL-UNNAMED' '--add-exports=java.desktop/sun.awt.im=ALL-UNNAMED' '--add-exports=jdk.internal.jvmstat/sun.jvmstat.monitor=ALL-UNNAMED' '--add-exports=java.management/sun.management=ALL-UNNAMED' '--add-exports=java.base/sun.reflect.annotation=ALL-UNNAMED' '--add-exports=jdk.javadoc/com.sun.tools.javadoc.main=ALL-UNNAMED' '-XX:+IgnoreUnrecognizedVMOptions' -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath="/home/aim/.netbeans/10.0/var/log/heapdump.hprof" org.netbeans.Main --cachedir "/home/aim/.cache/netbeans/10.0" --userdir "/home/aim/.netbeans/10.0" "--branding" "nb" 0<&0

Last edited by radli (2019-07-10 07:44:40)

Offline

#2 2019-07-05 13:25:22

radli
Member
Registered: 2018-04-27
Posts: 26

Re: [SOLVED] community/netbeans 10.0-0.0 doesn't work / Fatal error in JRE

/home/aim/hs_err_pid2512.log is here https://filebin.net/klo52jsgq2yx5elp

Offline

#3 2019-07-05 13:28:24

radli
Member
Registered: 2018-04-27
Posts: 26

Re: [SOLVED] community/netbeans 10.0-0.0 doesn't work / Fatal error in JRE

Also I tried
java-10-openjdk
java-11-openjdk
with no luck

Offline

#4 2019-07-05 13:34:46

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] community/netbeans 10.0-0.0 doesn't work / Fatal error in JRE

You are on pentium4 packages, I presume?

Online

#5 2019-07-05 13:40:35

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] community/netbeans 10.0-0.0 doesn't work / Fatal error in JRE

Currently one option is to go back to i686 if you need Java.
Java (all versions) currently don't play well on pentium4 (mildly put).

Online

#6 2019-07-05 14:18:56

radli
Member
Registered: 2018-04-27
Posts: 26

Re: [SOLVED] community/netbeans 10.0-0.0 doesn't work / Fatal error in JRE

Yes there is auto option in my pacman.conf

I will try to force i686

Thank you.

Offline

Board footer

Powered by FluxBB