You are not logged in.

#1 2021-01-24 09:21:40

hinojojojo
Member
Registered: 2021-01-24
Posts: 2

surf fails to build and install

Hi all,
I am starting to use again a laptop with Arch32 that was last updated on November29 2020, so I updated the packages today. After the update I noticed that my surf browser that compiled by myself stopped working, but I dont understood why, I didnt saw webkit2gtk or something like that updated this time. I tried to recompile and install again (make install) but it that process fails after throwing a lot of messages like these:

/usr/bin/ld: /usr/lib/libwebkit2gtk-4.0.so: undefined reference to `u_isalnum_67'
/usr/bin/ld: /usr/lib/libjavascriptcoregtk-4.0.so: undefined reference to `uplrules_selectWithFormat_67'
/usr/bin/ld: /usr/lib/libjavascriptcoregtk-4.0.so: undefined reference to `u_errorName_67'
/usr/bin/ld: /usr/lib/libwebkit2gtk-4.0.so: undefined reference to `UCNV_FROM_U_CALLBACK_SUBSTITUTE_67'
/usr/bin/ld: /usr/lib/libwebkit2gtk-4.0.so: undefined reference to `uscript_hasScript_67'
/usr/bin/ld: /usr/lib/libwebkit2gtk-4.0.so: undefined reference to `utext_close_67'
/usr/bin/ld: /usr/lib/libwebkit2gtk-4.0.so: undefined reference to `uidna_nameToUnicode_67'
/usr/bin/ld: /usr/lib/libwebkit2gtk-4.0.so: undefined reference to `unorm2_composePair_67'
/usr/bin/ld: /usr/lib/libwebkit2gtk-4.0.so: undefined reference to `usearch_reset_67'

and ends like this:
collect2: error: ld returned 1 exit status
make: *** [Makefile:29: surf] Error 1

So it actually looks like some issues with webkit and gtk dependencies. Has anyone had this issue too? how can I solve this?

Offline

#2 2021-01-24 09:47:23

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: surf fails to build and install

Yes, webkit2gtk refuses to rebuild currently and is still linked against an older version of ICU.
Try using the 'icu67' package to provide the old ICU version (can be installed in parallel to the
'icu' packge which is on version 68).

Offline

#3 2021-01-28 03:02:26

hinojojojo
Member
Registered: 2021-01-24
Posts: 2

Re: surf fails to build and install

Oh yea, that solved the issue. Thank you very much!

Offline

Board footer

Powered by FluxBB