You are not logged in.

#1 2021-04-22 18:25:04

megafreakshow
Member
Registered: 2018-03-09
Posts: 19

[SOLVED] Unable to upgrade libplacebo package required by mpv

Hi!

For several days now I've been unable to upgrade my system due to the following:

$ sudo pacman -Syu
doas (xxx@yyy) password:
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libplacebo (3.104.0-2.0) breaks dependency 'libplacebo.so=72-32' required by mpv

It seems mpv requires an older version of the library.

Cheers!

Last edited by megafreakshow (2021-04-23 10:29:57)

Offline

#2 2021-04-22 19:00:47

mocambo
Member
Registered: 2017-09-24
Posts: 23

Re: [SOLVED] Unable to upgrade libplacebo package required by mpv

Hello !

I have exactly the same problem since the beginning of April when I installed Archlinux32. It will probably take some time for the right packages to reach where they are needed.

The temporary solution is to enable testing repositories in

/etc/pacman.conf
[testing]
Include = /etc/pacman.d/mirrorlist

[core]
SigLevel = Optional TrustAll
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = Optional TrustAll
Include = /etc/pacman.d/mirrorlist

[community-testing]
Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = Optional TrustAll
Include = /etc/pacman.d/mirrorlist

After that

# pacman -Syyu

Or option II just upgrade without libplacebo.

pacman -Syu --ignore=libplacebo

Last edited by mocambo (2021-04-22 19:16:26)

Offline

#3 2021-04-23 05:43:19

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 608

Re: [SOLVED] Unable to upgrade libplacebo package required by mpv

I moved mpv from [community-testing] to [community], this should make the workaround unnecessary.

Offline

#4 2021-04-23 10:29:43

megafreakshow
Member
Registered: 2018-03-09
Posts: 19

Re: [SOLVED] Unable to upgrade libplacebo package required by mpv

Marking this as solved.

Offline

#5 2021-04-23 11:06:42

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 416
Website

Re: [SOLVED] Unable to upgrade libplacebo package required by mpv

Also mpv on i486 should work now.

Offline

#6 2021-05-28 18:26:09

Zohnsaxen
Member
From: Germany
Registered: 2020-12-24
Posts: 11

Re: [SOLVED] Unable to upgrade libplacebo package required by mpv

deep42thought - How did you move one package "mpv" from  [community-testing] to [community]?

Offline

#7 2021-05-29 05:55:33

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 608

Re: [SOLVED] Unable to upgrade libplacebo package required by mpv

we have scripts for moving packages around - especially, if we're "only" forcing them down their regular way.

Offline

Board footer

Powered by FluxBB