You are not logged in.

#26 2022-01-05 21:43:29

cx
Member
Registered: 2019-08-17
Posts: 107

Re: Enabling staging update broke packages dependency

So this is why firefox and thunderbird always crash since over a month?!

Currently I got libxml2 v2.9.12-3.1 installed; but it's not in the cache anymore. Would it be of help if I updated that one anyway?

Offline

#27 2022-01-05 22:28:02

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: Enabling staging update broke packages dependency

Yes, probably the same reason I haven't updated for a month now, and the rolled back until firefox started to work again.  I hope this can be fixed soon, but maybe it's time to buy a reconditioned laptop which will probably be able to run archlinux64.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#28 2022-01-06 21:40:42

cx
Member
Registered: 2019-08-17
Posts: 107

Re: Enabling staging update broke packages dependency

OK..
I thought switching to claws-mail then, but even this does not work:

claws-mail: error while loading shared libraries: liblber-2.4.so.2: cannot open shared object file: No such file or directory

Edit:

$ pacman -Ql claws-mail | grep .so

does not show anything with "liblber" – so what's the related pkg?

Last edited by cx (2022-01-06 21:56:39)

Offline

#29 2022-01-06 23:27:17

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: Enabling staging update broke packages dependency

Liblber.so is owned by libldap.  Very few libs are shipped with packages, and also few are listed in the pkgbuild.dependencies.  I think libldap was something I downgraded (back to v2.4) over a month ago in order to get everything working.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#30 2022-01-07 08:46:56

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Enabling staging update broke packages dependency

Yes, clamav or some libraries need a rebuild and a push to stable.
Thanks for reporting.
The problem currently is, more important things like python and systemd are currently breaking, so they are prio one.

thunderbird and firefox work if you install old versions of nss, libffi and icu (see various posts around)..

Offline

#31 2022-01-07 17:21:32

cx
Member
Registered: 2019-08-17
Posts: 107

Re: Enabling staging update broke packages dependency

Alas! I still provide backups of icu69 (and icu70 respectively) and nss3.72, so both ff and tb are up and running again~

Also just read the latest Arch32 news & added zstd + nss to "IgnorePkg" in pacman.conf at once!

Offline

#32 2022-01-07 19:43:22

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Enabling staging update broke packages dependency

BTW, there are packages for icu67, icu68, icu69 and libffi33 available in the stable repos exactly for this reason. :-)

Offline

Board footer

Powered by FluxBB