You are not logged in.

#1 2022-02-10 18:31:22

cx
Member
Registered: 2019-08-17
Posts: 107

Can't go graphical anymore

for a couple of days since the last update – be it X or wayland.

My pentium4 runs a radeon GPU, and is logging as follows:

. . .
[   374.555] (EE) 
[   374.555] (EE) Backtrace:
[   374.555] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x52) [0x5ef1f2]
[   374.555] (EE) 1: /usr/lib/Xorg (0x4af000+0x14b922) [0x5fa922]
[   374.556] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb7f01560]
[   374.556] (EE) 3: linux-gate.so.1 (__kernel_vsyscall+0x9) [0xb7f01549]
[   374.556] (EE) 4: /usr/lib/libc.so.6 (gsignal+0xc8) [0xb793b8a8]
[   374.556] (EE) 5: /usr/lib/libc.so.6 (abort+0x122) [0xb7924387]
[   374.556] (EE) 6: /usr/lib/libc.so.6 (0xb7907000+0x1d259) [0xb7924259]
[   374.556] (EE) 7: /usr/lib/libc.so.6 (0xb7907000+0x2ca0d) [0xb7933a0d]
[   374.556] (EE) 8: /usr/lib/xorg/modules/libexa.so (0xb7ee2000+0x29fb) [0xb7ee49fb]
[   374.556] (EE) 9: /usr/lib/xorg/modules/libexa.so (0xb7ee2000+0x4391) [0xb7ee6391]
[   374.556] (EE) 10: /usr/lib/Xorg (0x4af000+0xbd912) [0x56c912]
[   374.556] (EE) 11: /usr/lib/Xorg (0x4af000+0xe2bba) [0x591bba]
[   374.557] (EE) 12: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xb6ca3000+0x4af37) [0xb6cedf37]
[   374.557] (EE) 13: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xb6ca3000+0x4d2f1) [0xb6cf02f1]
[   374.557] (EE) 14: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xb6ca3000+0x403c9) [0xb6ce33c9]
[   374.557] (EE) 15: /usr/lib/Xorg (0x4af000+0x18d763) [0x63c763]
[   374.557] (EE) 16: /usr/lib/Xorg (0x4af000+0xeeb4c) [0x59db4c]
[   374.557] (EE) 17: /usr/lib/Xorg (0x4af000+0x2bc27) [0x4dac27]
[   374.557] (EE) 18: /usr/lib/libc.so.6 (__libc_start_main+0xed) [0xb792598d]
[   374.557] (EE) 19: /usr/lib/Xorg (_start+0x35) [0x4db515]
[   374.557] (EE) 
[   374.558] (EE) 
Fatal server error:
[   374.558] (EE) Caught signal 6 (Aborted). Server aborting
[   374.558] (EE) 
[   374.558] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   374.558] (EE) Please also check the log file at "/home/myuser/.local/share/xorg/Xorg.0.log" for additional information.
[   374.558] (EE) 
[   374.566] (EE) Server terminated with error (1). Closing log file.

I guess some other relevant package is missing an update, too.
"xf86-video-ati" is version 1:19.1.0.r9.g5eba006e-2(.2) and the same as in Arch64. – "xorg-server" on Arch32 is v. 21.1.3-1.1, and v. 21.1.3-2 on Arch64, so that's propably not the problem.

But it's dependency "mesa" looks outdated, as it currently is v. 21.2.1-1(.0) versus v. 21.3.5-1 on Arch64.

Or any other ideas?

Offline

#2 2022-02-10 23:25:02

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: Can't go graphical anymore

I guess that drivers/radeon_drv.so is owned by xf86-video-ati, and you've already checked that.  The build number after the hyphen in package versions is set by the package builder, so can and does differ between arch64 and this place.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2022-02-11 00:04:19

cx
Member
Registered: 2019-08-17
Posts: 107

Re: Can't go graphical anymore

Sure.
And hence probably some other Arch32 package/s' dep/s version/s is currently 'behind' Arch64, so there're conflicting package versions in Arch32; that issue will hopefully get magically resolved 'by itself' by upcoming Arch32 updates then. – In other words: If this is just a matter of patience, or another underlying problem, future will show.

Offline

#4 2022-02-11 00:41:24

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: Can't go graphical anymore

Yes, it's quite normal that the version on even out testing server are older than those in arch64, since as far as I know they only start to get built for staging here once they enter stable in arch64.  Those times in your logs indicate this happened at about five minutes after the xorg start, are you using some kind of greeter to log in and didn't log in after booting the machine for five minutes, or is there some other explanation for these timings?


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2022-02-11 14:13:31

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Can't go graphical anymore

I had a messup today with llvm12/13 and mesa, maybe that one also didn't help..

Offline

#6 2022-02-14 07:52:17

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Can't go graphical anymore

There is quite some more messup in Xorg, drivers and mesa...

Offline

#7 2022-02-14 17:37:46

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Can't go graphical anymore

[  3359.468] (EE)
[  3359.475] (EE) Backtrace:
[  3359.497] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x52) [0x5db8b2]
[  3359.505] (EE) 1: /usr/lib/Xorg (0x49b000+0x14c002) [0x5e7002]
[  3359.512] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb7fa9560]
[  3359.519] (EE) 3: /usr/lib/libc.so.6 (strcmp+0xe) [0xb7a26eee]
[  3359.526] (EE) 4: /usr/lib/Xorg (xf86ProbeOutputModes+0x7dd) [0x62dcad]
[  3359.534] (EE) 5: /usr/lib/Xorg (xf86InitialConfiguration+0x12d) [0x62e44d]
[  3359.542] (EE) 6: /usr/lib/xorg/modules/drivers/siliconmotion_drv.so (0xb6d95000+0x80e0) [0xb6d9d0e0]
[  3359.549] (EE) 7: /usr/lib/Xorg (InitOutput+0x188d) [0x603b0d]
[  3359.558] (EE) 8: /usr/lib/Xorg (0x49b000+0x2b016) [0x4c6016]
[  3359.565] (EE) 9: /usr/lib/libc.so.6 (__libc_start_main+0xed) [0xb79ba98d]
[  3359.573] (EE) 10: /usr/lib/Xorg (_start+0x35) [0x4c7515]
[  3359.581] (EE)
[  3359.589] (EE) Segmentation fault at address 0x0
[  3359.596] (EE)
Fatal server error:
[  3359.603] (EE) Caught signal 11 (Segmentation fault). Server aborting

mmh. nice. is this the sis driver or xorg being just crashing on a strcmp?

Offline

#8 2022-02-14 17:39:46

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Can't go graphical anymore

[  3497.157] (EE) Backtrace:
[  3497.160] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x52) [0x5618b2]
[  3497.163] (EE) 1: /usr/lib/Xorg (0x421000+0x14c002) [0x56d002]
[  3497.165] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb7fa9560]
[  3497.168] (EE) 3: /usr/lib/libc.so.6 (strlen+0x37) [0xb7a27347]
[  3497.170] (EE) 4: /usr/lib/Xorg (0x421000+0x19a9be) [0x5bb9be]
[  3497.173] (EE) 5: /usr/lib/Xorg (xf86RandR12Init+0x3e7) [0x5bc067]
[  3497.175] (EE) 6: /usr/lib/Xorg (xf86CrtcScreenInit+0x33) [0x5af173]
[  3497.177] (EE) 7: /usr/lib/xorg/modules/drivers/siliconmotion_drv.so (0xb6df5000+0x96f8) [0xb6dfe6f8]
[  3497.178] (EE) 8: /usr/lib/Xorg (AddScreen+0xe1) [0x48cc91]
[  3497.180] (EE) 9: /usr/lib/Xorg (InitOutput+0x3b8) [0x588638]
[  3497.182] (EE) 10: /usr/lib/Xorg (0x421000+0x2b016) [0x44c016]
[  3497.184] (EE) 11: /usr/lib/libc.so.6 (__libc_start_main+0xed) [0xb79ba98d]
[  3497.186] (EE) 12: /usr/lib/Xorg (_start+0x35) [0x44d515]
[  3497.187] (EE)
[  3497.188] (EE) Segmentation fault at address 0x0

fbdev. Ok. This is completely borked..

Offline

#9 2022-02-14 17:44:38

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Can't go graphical anymore

xf86-video-fbdev works on the Alix, so there is something else wrong here..

Offline

#10 2022-02-14 17:52:30

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: Can't go graphical anymore

Seems I don't have xf86-video-fbdev installed. I probably have instead xf86-video-intel, but then I am using internal intel graphics, and am not using any kind of graphics card and certainly not a radeon card.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#11 2022-02-20 09:19:11

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Can't go graphical anymore

xf86-video-intel is working on my eeepc too, I rebuilt and pushed all old 2D graphical X drivers.
The more exotic ones like Sis or Mach64 need manual fixing..

Offline

#12 2022-05-05 10:12:52

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Can't go graphical anymore

xf86-video-fbdev  works again with kernel 5.17.5 on my Alix :-)

Offline

Board footer

Powered by FluxBB