You are not logged in.

#1 2022-02-18 18:07:32

liewkj
Member
Registered: 2020-04-15
Posts: 26

GDM broken with pango 1.50.4-1

As titled.

/usr/lib/gdm-wayland-session[346]: /usr/lib/gnome-session-binary: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant
/usr/lib/gdm-x-session[370]: /usr/lib/gnome-session-binary: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant
/usr/lib/gdm-x-session[393]: /usr/lib/gnome-session-binary: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant
/usr/lib/gdm-x-session[417]: /usr/lib/gnome-session-binary: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant
/usr/lib/gdm-x-session[440]: /usr/lib/gnome-session-binary: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant
/usr/lib/gdm-x-session[463]: /usr/lib/gnome-session-binary: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_font_set_synthetic_slant

Fix by downgrading to pango 1.50.3-1

Offline

#2 2022-02-18 18:20:35

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: GDM broken with pango 1.50.4-1

Yes, another graphics thing is broken.  I think for the time being you will have to protect your pango downgrade against being upgraded.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2022-02-18 19:43:03

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: GDM broken with pango 1.50.4-1

Yep, but currently I'm fiddling in the gcc toolchain, and that is prio one. :-)

Offline

#4 2022-02-20 08:25:29

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: GDM broken with pango 1.50.4-1

Sounds like this one:

https://bugs.archlinux32.org/index.php? … us%5B0%5D=

I pushed harfbuzz to stable..

Offline

Board footer

Powered by FluxBB