You are not logged in.

#1 2022-03-06 09:56:41

clexp
Member
Registered: 2022-03-05
Posts: 2

[SOLVED] no boot post install, drop to EFI Shell ver 2.7

Hi,
New user,
Using a seeed odyssey, J4105 Celeron .
With western dig 240GB m2 sata green .
Using direct keyboard and mouse, no wifi - directly networked.
Vanilla arch install following the simplest steps on the arch wiki, no complexities. 
Installed as GPT, overwriting previous partitions (was ubuntu - worked ok).
All the instruction work fine. I go to reboot. 

No booting, goes to EFI Shell. 
Using F7 for boot option only lists EFI Shell. 
Going into set up for 'boot options' also only lists EFI Shell. 
In EFI Shell it does list all the partitions on the ssd.  It can see them, just not to boot. 

The boot partition, /dev/sda1, is mkfs.fat -F32.  The other two are swap and / is ext4. 

So not MBR so no bootable flag. 
Have I mangled something on re-writing the GPT partitions?

I just need the EFI firmware to correctly identify /dev/sda1 as the efi partition.  It is currently called /boot.  Does it need to be called /efi?

Last edited by levi (2022-03-06 22:15:21)

Offline

#2 2022-03-06 10:10:42

clexp
Member
Registered: 2022-03-05
Posts: 2

Re: [SOLVED] no boot post install, drop to EFI Shell ver 2.7

[Solved]
Follow the instructions.  I missed one.

Offline

#3 2022-03-06 22:14:51

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: [SOLVED] no boot post install, drop to EFI Shell ver 2.7

Care to document which step you missed, in case if helps anyone going forward?


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB