You are not logged in.

#1 2022-05-29 14:07:17

chrisd
Member
Registered: 2020-09-06
Posts: 5

[SOLVED] Xorg no longer works after upgrade

Dear All,

After upgrading my old laptop using pacman -Syu, Xorg no longer starts.
The package xf86-video-ati was not updated as part of this upgrade, though.
/var/log/Xorg.0.log follows.

[   160.931]
X.Org X Server 1.21.1.3
X Protocol Version 11, Revision 0
[   160.934] Current Operating System: Linux lappie 5.17.9-arch1-1.0 #1 SMP PREEMPT Wed, 25 May 2022 15:32:42 +0000 i686
[   160.935] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=5592db45-afef-4094-bbbf-5cd49c0dc65f rw quiet
[   160.937]
[   160.938] Current version of pixman: 0.40.0
[   160.939]   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   160.940] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   160.943] (==) Log file: "/var/log/Xorg.0.log", Time: Sun May 29 14:32:04 2022
[   161.036] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   161.077] (==) No Layout section.  Using the first Screen section.
[   161.077] (==) No screen section available. Using defaults.
[   161.077] (**) |-->Screen "Default Screen Section" (0)
[   161.077] (**) |   |-->Monitor "<default monitor>"
[   161.079] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   161.079] (==) Automatically adding devices
[   161.079] (==) Automatically enabling devices
[   161.079] (==) Automatically adding GPU devices
[   161.079] (==) Automatically binding GPU devices
[   161.079] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   161.115] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[   161.115]   Entry deleted from font path.
[   161.115] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[   161.115]   Entry deleted from font path.
[   161.115] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[   161.115]   Entry deleted from font path.
[   161.115] (==) FontPath set to:
   /usr/share/fonts/misc,
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF
[   161.115] (==) ModulePath set to "/usr/lib/xorg/modules"
[   161.115] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   161.115] (II) Module ABI versions:
[   161.115]   X.Org ANSI C Emulation: 0.4
[   161.115]   X.Org Video Driver: 25.2
[   161.115]   X.Org XInput driver : 24.4
[   161.115]   X.Org Server Extension : 10.0
[   161.117] (++) using VT number 1

[   161.124] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[   161.135] (--) PCI:*(1@0:5:0) 1002:5a62:1179:ff31 rev 0, Mem @ 0xd0000000/268435456, 0xc0000000/65536, I/O @ 0x00009000/256, BIOS @ 0x????????/131072
[   161.135] (II) LoadModule: "glx"
[   161.137] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   161.245] (II) Module glx: vendor="X.Org Foundation"
[   161.245]   compiled for 1.21.1.3, module version = 1.0.0
[   161.245]   ABI class: X.Org Server Extension, version 10.0
[   161.245] (==) Matched ati as autoconfigured driver 0
[   161.245] (==) Matched modesetting as autoconfigured driver 1
[   161.245] (==) Matched fbdev as autoconfigured driver 2
[   161.246] (==) Matched vesa as autoconfigured driver 3
[   161.246] (==) Assigned the driver to the xf86ConfigLayout
[   161.246] (II) LoadModule: "ati"
[   161.246] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[   161.263] (II) Module ati: vendor="X.Org Foundation"
[   161.264]   compiled for 1.21.1.3, module version = 19.1.0
[   161.264]   Module class: X.Org Video Driver
[   161.264]   ABI class: X.Org Video Driver, version 25.2
[   161.265] (II) LoadModule: "radeon"
[   161.265] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[   161.376] (II) Module radeon: vendor="X.Org Foundation"
[   161.376]   compiled for 1.21.1.3, module version = 19.1.0
[   161.376]   Module class: X.Org Video Driver
[   161.376]   ABI class: X.Org Video Driver, version 25.2
[   161.376] (II) LoadModule: "modesetting"
[   161.377] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   161.389] (II) Module modesetting: vendor="X.Org Foundation"
[   161.389]   compiled for 1.21.1.3, module version = 1.21.1
[   161.389]   Module class: X.Org Video Driver
[   161.389]   ABI class: X.Org Video Driver, version 25.2
[   161.389] (II) LoadModule: "fbdev"
[   161.397] (WW) Warning, couldn't open module fbdev
[   161.397] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   161.397] (II) LoadModule: "vesa"
[   161.397] (WW) Warning, couldn't open module vesa
[   161.397] (EE) Failed to load module "vesa" (module does not exist, 0)
[   161.397] (II) RADEON: Driver for ATI/AMD Radeon chipsets:
   ATI Radeon Mobility X600 (M24), ATI FireMV 2400,
   ATI Radeon Mobility X300 (M24), ATI FireGL M24 GL,
   ATI Radeon X600 (RV380), ATI FireGL V3200 (RV380),
   ATI Radeon IGP320 (A3), ATI Radeon IGP330/340/350 (A4),
   ATI Radeon 9500, ATI Radeon 9600TX, ATI FireGL Z1, ATI Radeon 9800SE,
   ATI Radeon 9800, ATI FireGL X2, ATI Radeon 9600, ATI Radeon 9600SE,
   ATI Radeon 9600XT, ATI FireGL T2, ATI Radeon 9650, ATI FireGL RV360,
   ATI Radeon 7000 IGP (A4+), ATI Radeon 8500 AIW,
   ATI Radeon IGP320M (U1), ATI Radeon IGP330M/340M/350M (U2),
   ATI Radeon Mobility 7000 IGP, ATI Radeon 9000/PRO, ATI Radeon 9000,
   ATI Radeon X800 (R420), ATI Radeon X800PRO (R420),
   ATI Radeon X800SE (R420), ATI FireGL X3 (R420),
   ATI Radeon Mobility 9800 (M18), ATI Radeon X800 SE (R420),
   ATI Radeon X800XT (R420), ATI Radeon X800 VE (R420),
   ATI Radeon X850 (R480), ATI Radeon X850 XT (R480),
   ATI Radeon X850 SE (R480), ATI Radeon X850 PRO (R480),
   ATI Radeon X850 XT PE (R480), ATI Radeon Mobility M7,
   ATI Mobility FireGL 7800 M7, ATI Radeon Mobility M6,
   ATI FireGL Mobility 9000 (M9), ATI Radeon Mobility 9000 (M9),
   ATI Radeon 9700 Pro, ATI Radeon 9700/9500Pro, ATI FireGL X1,
   ATI Radeon 9800PRO, ATI Radeon 9800XT,
   ATI Radeon Mobility 9600/9700 (M10/M11),
   ATI Radeon Mobility 9600 (M10), ATI Radeon Mobility 9600 (M11),
   ATI FireGL Mobility T2 (M10), ATI FireGL Mobility T2e (M11),
   ATI Radeon, ATI FireGL 8700/8800, ATI Radeon 8500, ATI Radeon 9100,
   ATI Radeon 7500, ATI Radeon VE/7000, ATI ES1000,
   ATI Radeon Mobility X300 (M22), ATI Radeon Mobility X600 SE (M24C),
   ATI FireGL M22 GL, ATI Radeon X800 (R423), ATI Radeon X800PRO (R423),
   ATI Radeon X800LE (R423), ATI Radeon X800SE (R423),
   ATI Radeon X800 XTP (R430), ATI Radeon X800 XL (R430),
   ATI Radeon X800 SE (R430), ATI Radeon X800 (R430),
   ATI FireGL V7100 (R423), ATI FireGL V5100 (R423),
   ATI FireGL unknown (R423), ATI Mobility FireGL V5000 (M26),
   ATI Mobility Radeon X700 XL (M26), ATI Mobility Radeon X700 (M26),
   ATI Radeon X550XTX, ATI Radeon 9100 IGP (A5),
   ATI Radeon Mobility 9100 IGP (U3), ATI Radeon XPRESS 200,
   ATI Radeon XPRESS 200M, ATI Radeon 9250, ATI Radeon 9200,
   ATI Radeon 9200SE, ATI FireMV 2200, ATI Radeon X300 (RV370),
   ATI Radeon X600 (RV370), ATI Radeon X550 (RV370),
   ATI FireGL V3100 (RV370), ATI FireMV 2200 PCIE (RV370),
   ATI Radeon Mobility 9200 (M9+), ATI Mobility Radeon X800 XT (M28),
   ATI Mobility FireGL V5100 (M28), ATI Mobility Radeon X800 (M28),
   ATI Radeon X850, ATI unknown Radeon / FireGL (R480),
   ATI Radeon X800XT (R423), ATI FireGL V5000 (RV410),
   ATI Radeon X700 XT (RV410), ATI Radeon X700 PRO (RV410),
   ATI Radeon X700 SE (RV410), ATI Radeon X700 (RV410),
   ATI Radeon X1800, ATI Mobility Radeon X1800 XT,
   ATI Mobility Radeon X1800, ATI Mobility FireGL V7200,
   ATI FireGL V7200, ATI FireGL V5300, ATI Mobility FireGL V7100,
   ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,
   ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,
   ATI Mobility Radeon X1400, ATI Radeon X1550 64-bit,
   ATI Mobility Radeon X1300, ATI Radeon X1300, ATI FireGL V3300,
   ATI FireGL V3350, ATI Mobility Radeon X1450,
   ATI Mobility Radeon X2300, ATI Mobility Radeon X1350,
   ATI FireMV 2250, ATI Radeon X1650, ATI Mobility FireGL V5200,
   ATI Mobility Radeon X1600, ATI Radeon X1300 XT/X1600 Pro,
   ATI FireGL V3400, ATI Mobility FireGL V5250,
   ATI Mobility Radeon X1700, ATI Mobility Radeon X1700 XT,
   ATI FireGL V5200, ATI Radeon X2300HD, ATI Mobility Radeon HD 2300,
   ATI Radeon X1950, ATI Radeon X1900, ATI AMD Stream Processor,
   ATI RV560, ATI Mobility Radeon X1900, ATI Radeon X1950 GT, ATI RV570,
   ATI FireGL V7400, ATI Radeon 9100 PRO IGP,
   ATI Radeon Mobility 9200 IGP, ATI Radeon X1200, ATI RS740,
   ATI RS740M, ATI Radeon HD 2900 XT, ATI Radeon HD 2900 Pro,
   ATI Radeon HD 2900 GT, ATI FireGL V8650, ATI FireGL V8600,
   ATI FireGL V7600, ATI Radeon 4800 Series, ATI Radeon HD 4870 x2,
   ATI Radeon HD 4850 x2, ATI FirePro V8750 (FireGL),
   ATI FirePro V7760 (FireGL), ATI Mobility RADEON HD 4850,
   ATI Mobility RADEON HD 4850 X2, ATI FirePro RV770,
   AMD FireStream 9270, AMD FireStream 9250, ATI FirePro V8700 (FireGL),
   ATI Mobility RADEON HD 4870, ATI Mobility RADEON M98,
   ATI FirePro M7750, ATI M98, ATI Mobility Radeon HD 4650,
   ATI Radeon RV730 (AGP), ATI Mobility Radeon HD 4670,
   ATI FirePro M5750, ATI RV730XT [Radeon HD 4670], ATI RADEON E4600,
   ATI Radeon HD 4600 Series, ATI RV730 PRO [Radeon HD 4650],
   ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
   ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
   ATI Mobility Radeon HD 4850, ATI FirePro M7740, ATI RV740,
   ATI Radeon HD 4770, ATI Radeon HD 4700 Series, ATI RV610,
   ATI Radeon HD 2400 XT, ATI Radeon HD 2400 Pro,
   ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000, ATI Radeon HD 2350,
   ATI Mobility Radeon HD 2400 XT, ATI Mobility Radeon HD 2400,
   ATI RADEON E2400, ATI FireMV 2260, ATI RV670, ATI Radeon HD3870,
  ATI Mobility Radeon HD 3850, ATI Radeon HD3850,
   ATI Mobility Radeon HD 3850 X2, ATI Mobility Radeon HD 3870,
   ATI Mobility Radeon HD 3870 X2, ATI Radeon HD3870 X2,
   ATI FireGL V7700, ATI Radeon HD3690, AMD Firestream 9170,
   ATI Radeon HD 4550, ATI Radeon RV710, ATI Radeon HD 4350,
   ATI Mobility Radeon 4300 Series, ATI Mobility Radeon 4500 Series,
   ATI FirePro RG220, ATI Mobility Radeon 4330, ATI RV630,
   ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,
   ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,
   ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,
   ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
   ATI FireGL V3600, ATI Radeon HD 2600 LE,
   ATI Mobility FireGL Graphics Processor, ATI Radeon HD 3470,
   ATI Mobility Radeon HD 3430, ATI Mobility Radeon HD 3400 Series,
   ATI Radeon HD 3450, ATI Radeon HD 3430, ATI FirePro V3700,
   ATI FireMV 2450, ATI Radeon HD 3600 Series, ATI Radeon HD 3650 AGP,
   ATI Radeon HD 3600 PRO, ATI Radeon HD 3600 XT,
   ATI Mobility Radeon HD 3650, ATI Mobility Radeon HD 3670,
   ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,
   ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
   ATI Radeon HD 3300 Graphics, ATI Radeon 3000 Graphics, SUMO, SUMO2,
   ATI Radeon HD 4200, ATI Radeon 4100, ATI Mobility Radeon HD 4200,
   ATI Mobility Radeon 4100, ATI Radeon HD 4290, ATI Radeon HD 4250,
   AMD Radeon HD 6310 Graphics, AMD Radeon HD 6250 Graphics,
   AMD Radeon HD 6300 Series Graphics,
   AMD Radeon HD 6200 Series Graphics, PALM, CYPRESS,
   ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
   AMD Firestream 9350, ATI Radeon HD 5800 Series,
   ATI Radeon HD 5900 Series, ATI Mobility Radeon HD 5800 Series,
   ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
   ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
   ATI Radeon HD 5670, ATI Radeon HD 5570, ATI Radeon HD 5500 Series,
   REDWOOD, ATI Mobility Radeon Graphics, CEDAR, ATI FirePro 2270,
   ATI Radeon HD 5450, CAYMAN, AMD Radeon HD 6900 Series,
   AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series, BARTS,
   AMD Radeon HD 6800 Series, AMD Radeon HD 6700 Series, TURKS, CAICOS,
   ARUBA, TAHITI, PITCAIRN, VERDE, OLAND, HAINAN, BONAIRE, KABINI,
   MULLINS, KAVERI, HAWAII
[   161.402] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   161.402] (II) [KMS] drm report modesetting isn't supported.
[   161.402] (EE) open /dev/dri/card0: No such file or directory
[   161.402] (WW) Falling back to old probe method for modesetting
[   161.402] (EE) open /dev/dri/card0: No such file or directory
[   161.402] (EE) Screen 0 deleted because of no matching config section.
[   161.402] (II) UnloadModule: "radeon"
[   161.402] (EE) Screen 0 deleted because of no matching config section.
[   161.402] (II) UnloadModule: "modesetting"
[   161.402] (EE) Device(s) detected, but none match those in the config file.
[   161.402] (EE)
Fatal server error:
[   161.403] (EE) no screens found(EE)
[   161.403] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   161.403] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   161.403] (EE)
[   161.408] (EE) Server terminated with error (1). Closing log file.

lspci contains info about the card.

01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RC410M [Mobility Radeon Xpress 200M] (prog-if 00 [VGA controller])
	Subsystem: Toshiba Corporation Device ff31
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 66 (2000ns min), Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 17
	Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Region 1: I/O ports at 9000 [size=256]
	Region 2: Memory at c0000000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
	Capabilities: [50] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit-
		Address: 00000000  Data: 0000
	Kernel driver in use: radeonfb
	Kernel modules: radeonfb, radeon, amdgpu

Anyone any ideas?

Kind Regards,
Chris

Last edited by chrisd (2022-05-29 15:24:39)

Offline

#2 2022-05-29 14:35:43

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

I think this is the same issue as mentioned in https://bbs.archlinux32.org/viewtopic.php?id=3233

The problem is not Xorg, I enabled some old framebuffer drivers like 'radeonfb' and that one conflicts
with the 'radeon' driver dealing with DRI. Just blacklist the radeonfb module as mentioned in the forum
post above.

Offline

#3 2022-05-29 15:23:59

chrisd
Member
Registered: 2020-09-06
Posts: 5

Re: [SOLVED] Xorg no longer works after upgrade

Thanks! disabling the radeonfb kernel module solved the problem for me!

Offline

#4 2022-05-31 18:20:07

alpage2
Member
Registered: 2022-05-31
Posts: 3

Re: [SOLVED] Xorg no longer works after upgrade

Same problem - but different cause and solution.

I just updated pacman with pacman -Syu and xorg would not run. The xorg server crashed with an error message saying that it could not load missing library libicuuc.so.70

pacman -Ss libicuuc
core/icu 71.1-1.1 [installed]
    International Components for Unicode library
core/icu67 67.1-1.3 (build-shims) [installed]
    International Components for Unicode library
core/icu68 68.2-1.1 (build-shims)
    International Components for Unicode library
core/icu69 69.1-1.1 (build-shims)
    International Components for Unicode library
core/icu70 70.1-1.0 (build-shims)
    International Components for Unicode library
[root@aspireD260-A alan]#

it looked like icu70 was the missing package, so I gave it

pacman -S icu70

and it woked - my xorg server is working again.
Hope that helps others.

Offline

#5 2022-05-31 21:32:01

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: [SOLVED] Xorg no longer works after upgrade

Yes  if any software you've just updated reports an error about not being able to load icu.so then look at what version it's looking for and install the shim package.  It's a special feature of arch32.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#6 2022-06-01 03:44:16

liewkj
Member
Registered: 2020-04-15
Posts: 26

Re: [SOLVED] Xorg no longer works after upgrade

levi wrote:

Yes  if any software you've just updated reports an error about not being able to load icu.so then look at what version it's looking for and install the shim package.  It's a special feature of arch32.

This is gonna be an ugly workaround. Basically, the packages dependencies are broken out-right. Wouldn't there be an easy way to rebuild the packages when icu was updated? Wayland session is busted, too, after the recent icu 71 update.

May 31 19:22:20 /usr/lib/gdm-wayland-session[405]: /usr/lib/gnome-session-binary: error while loading shared libraries: libicuuc.so.70: cannot open shared object file: No such file or directory

Offline

#7 2022-06-01 05:43:03

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

This is a icu to stable issue, temporarily solvable by installing the required icu70 library, as
already experienced many times, see https://bbs.archlinux32.org/viewtopic.p … 8765#p8765

I'll trigger a rebuild of all icu-dependencies (icu 71) and push them to stable.

Offline

#8 2022-06-01 07:09:34

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

shell> lddtree  /usr/lib/gnome-session-binary
libtracker-sparql-3.0.so.0 => /usr/lib/libtracker-sparql-3.0.so.0
                libstemmer.so.0 => /usr/lib/libstemmer.so.0
                libicuuc.so.70 => None
                libicui18n.so.70 => None
                libsqlite3.so.0 => /usr/lib/libsqlite3.so.0
                libxml2.so.2 => /usr/lib/libxml2.so.2

So the problem is not X, but 'tracker3' (part of Gnome).

Also affected is the gtk-greeter of lightdm, most likely affecting quite some people.

Offline

#9 2022-06-01 09:31:57

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

Also libxml2 and vte3 where still linked against icu 70, should be ok now.

Offline

#10 2022-06-01 15:51:38

Commander
Member
Registered: 2022-05-26
Posts: 12

Re: [SOLVED] Xorg no longer works after upgrade

After I upgraded yesterday evening via pacman -Syu there was again no LightDM and X.
This morning I started the upgrade again and there is a X-Server again, but no terminal emulator was working - still getting the message "unicode_start skipped on /dev/pts/0.." (/dev/pts/0 exist).  Since the installation of Xterm the emulators are working again, why ever. Fish is telling me "epiphany: error while loading shared libraries: libicui18n.so.70: cannot open shared object file: No such file or directory" after typing help, and for sure epiphany while starting also.

Looks like I have lost again, there is no icu70 i686-package in core, just i486 and p4 and i686 in testing.
Maybe you will find a magic way to solve ths problem ;-)

BTW: is there no way to install the new icu-version without removing the old one or better install all of them, because a missing version is the most happening error I have got?

Offline

#11 2022-06-01 16:19:27

Commander
Member
Registered: 2022-05-26
Posts: 12

Re: [SOLVED] Xorg no longer works after upgrade

Oh, another one:
quiterss: error while loading shared libraries: libicuuc.so.70: cannot open shared object file: No such file or directory

I think it was not the last one sad

Offline

#12 2022-06-01 16:32:53

Commander
Member
Registered: 2022-05-26
Posts: 12

Re: [SOLVED] Xorg no longer works after upgrade

ATM only a few more, I do not have time to test more right now, sorry.

midori: error while loading shared libraries: libicui18n.so.70: cannot open shared object file: No such file or directory
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libicuuc.so.70: cannot open shared object file: No such file or directory
sqlitebrowser: error while loading shared libraries: libicui18n.so.70: cannot open shared object file: No such file or directory
cmake-gui: error while loading shared libraries: libicui18n.so.70: cannot open shared object file: No such file or directory

Offline

#13 2022-06-01 17:13:46

liewkj
Member
Registered: 2020-04-15
Posts: 26

Re: [SOLVED] Xorg no longer works after upgrade

libical also requires icu 71 rebuild

/usr/lib/libical.so (interpreter => None)
    libicuuc.so.70 => None
    libicui18n.so.70 => None
    libc.so.6 => /usr/lib/libc.so.6
        ld-linux.so.2 => /usr/lib/ld-linux.so.2

Offline

#14 2022-06-01 18:41:38

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

yeah, I should automatize that..

Offline

#15 2022-06-02 17:31:02

Commander
Member
Registered: 2022-05-26
Posts: 12

Re: [SOLVED] Xorg no longer works after upgrade

Can you provide core/icu70 (build-shims) to i686? For this pc I already fixed it with extracting the needed libs from cache, but new installations will not have icu70 in the pkg-cache.

Offline

#16 2022-06-02 17:33:37

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

Actually, I published an icu70 package a week ago or so (in anticipation of the troubles ahead :-) ).

Offline

#17 2022-06-02 17:34:01

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

Maybe I didn't push it yet to stable.. will do.

Offline

#18 2022-06-02 17:34:25

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

BTW, a major icu rebuild is on its way (some 60 packages or so).

Offline

#19 2022-06-02 17:39:10

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED] Xorg no longer works after upgrade

yep, sorry. icu70 got stuck for i686. should be in stable now.

Offline

#20 2022-06-02 17:45:16

Commander
Member
Registered: 2022-05-26
Posts: 12

Re: [SOLVED] Xorg no longer works after upgrade

Wow, that was fast... already arrived: core/icu70 70.1-1.0 (build-shims)
Thank you!

Offline

Board footer

Powered by FluxBB