You are not logged in.

#1 2022-06-24 11:04:41

wristhairmoustache
Member
Registered: 2022-06-23
Posts: 3

[Solved] X/Framebuffer troubles

I'm trying to get X up and running on a Pentium 4 with a Geforce FX 5200 Ultra (NV34)

Right from the clean bootstrap, boot/display would lock up at the fsck part unless the nomodeset kernel param was given

At that stage, the nvidiafb module was loaded during boot

I've since installed the nouveau driver, made an explicit nvidiafb blacklist in /etc/modprode.d (as it conflicts with nouveau), and added the nouveau module to the mkinitcpio.conf MODULES array (and yes, I've rebuilt the initramfs :)

I still need to provide nomodeset to get the machine to a tty login

lsmod lists nouveau loaded, and nvidiafb not. nothing related from dmesg --level=err

When trying to start X, /var/log/Xorg.0.log tells me [drm] Failed to open DRM device: -19

Any pointers? there must be some piece I'm missing here

Last edited by wristhairmoustache (2022-06-24 23:56:41)

Offline

#2 2022-06-24 15:30:47

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [Solved] X/Framebuffer troubles

To my knowledge nouveau requires KMS enabled (so nomodeset will not work).

I would try this here: https://nouveau.freedesktop.org/KernelModeSetting.html
to restore the textconsole.

Sorry, just venting ideas here, I don't have any NVidia card, I cannot test. :-)

Offline

#3 2022-06-24 23:42:47

wristhairmoustache
Member
Registered: 2022-06-23
Posts: 3

Re: [Solved] X/Framebuffer troubles

> To my knowledge nouveau requires KMS enabled (so nomodeset will not work).

Yeah that's the thing. It locks up on the handover, and the only way to get to a login was to prevent the handover with nomodeset

I got it though. Went over the HW again, card has a 4 pin molex on it that I miiiiight have forgotten to reconnect after clearing some space to pull out a harddrive

Lo and behold, KMS handover, nouveaufb, and X launching. twas just me being an absolute boob

Offline

#4 2022-06-25 06:48:43

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [Solved] X/Framebuffer troubles

Oh, that's a nice one: so it could boot in text mode but in graphic mode it needs more power. :-)

Offline

#5 2022-06-25 08:31:42

wristhairmoustache
Member
Registered: 2022-06-23
Posts: 3

Re: [Solved] X/Framebuffer troubles

Yeah, I think I would have preferred if the card refused to work at all without the required power, but what can you do

Offline

Board footer

Powered by FluxBB