You are not logged in.

#1 2023-12-02 01:49:44

Zohnsaxen
Member
From: Germany
Registered: 2020-12-24
Posts: 19

Can't update - warning: cython & filesystem is newer than...

I've had this issue for a few weeks now and today I tried at least 4 very geographically different mirrors with the same results.  Is there a different mirror I should use?

SpaceMan@mini [Fri Dec 01 06:03 PM]  /etc/pacman.d
(30) -->  pacman -Syyu
:: Synchronizing package databases...
 core                                              170.6 KiB  86.6 KiB/s 00:02 [############################################] 100%
 extra                                               7.9 MiB   552 KiB/s 00:15 [############################################] 100%
 community                                         238.4 KiB   124 KiB/s 00:02 [############################################] 100%
:: Starting full system upgrade...
warning: cython: local (0.29.36-1.0) is newer than extra (0.29.35-2.2)
warning: filesystem: local (2023.09.18-1.0) is newer than core (2023.01.31-1.0)
 there is nothing to do
##
## Arch Linux 32 repository mirrorlist
## Generated on 2023-12-01
## https://archlinux32.org/mirrorlist/
##

## United States
#Server = https://32.arlm.tyzoid.com/$arch/$repo
#Server = https://mirror.clarkson.edu/archlinux32/$arch/$repo
#Server = https://mirror.math.princeton.edu/pub/archlinux32/$arch/$repo

## Germany
Server = https://de.mirror.archlinux32.org/$arch/$repo
#Server = https://mirror.archlinux32.org/$arch/$repo
# Reflector configuration file for the systemd service.
#
# Empty lines and lines beginning with "#" are ignored.  All other lines should
# contain valid reflector command-line arguments. The lines are parsed with
# Python's shlex modules so standard shell syntax should work. All arguments are
# collected into a single argument list.
#
# See "reflector --help" for details.

# Recommended Options

# Set the output path where the mirrorlist will be saved (--save).
--save /etc/pacman.d/mirrorlist

# Select the transfer protocol (--protocol).
--protocol https

# Select the country (--country).
# Consult the list of available countries with "reflector --list-countries" and
# select the countries nearest to you or the ones that you trust. For example:
# --country France,Germany

# Use only the  most recently synchronized mirrors (--latest).
--latest 5

# Sort the mirrors by synchronization time (--sort).
--sort age

Offline

#2 2023-12-02 09:29:15

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 833
Website

Re: Can't update - warning: cython & filesystem is newer than...

https://bugs.archlinux32.org/index.php? … ask_id=337

This is known and a caused by having two state files in upstream git package states for any _and_ x86_64.

Python is completely broken and needs a rebootstrap (but I need something I can do this manually with, with the buildmaster
it's simply not possible for me to do it).

Offline

#3 2024-01-20 13:31:30

chrisd
Member
Registered: 2020-09-06
Posts: 9

Re: Can't update - warning: cython & filesystem is newer than...

Hello All,

I have this as well. Furthermore, it also says

error: gawk: signature from "TasosSah (Arch32 Package Signing Key) <arch32@tasossah.com>" is marginal trust
:: File /var/cache/pacman/pkg/gawk-5.3.0-1.0-pentium4.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

The usual procedure of doing pacman -S archlinux-keyring does not help and also runs into the same error.

Is this related or a different problem?

Kind Regards,
Chris

Offline

#4 2024-01-21 08:00:06

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 1,001
Website

Re: Can't update - warning: cython & filesystem is newer than...

Use `pacman -S archlinux32-keyring` for the Archlinux32 keyring, the `archlinux-keyring` is the upstream keyring which contains signatures for upstream packages.

Offline

#5 2024-02-11 20:31:42

chrisd
Member
Registered: 2020-09-06
Posts: 9

Re: Can't update - warning: cython & filesystem is newer than...

Hello Abaumann,

Thanks for your hint and sorry for not trying out earlier. Today I managed to fix this but only by doing things that are 'not recommended'. Firstly, attempting to update archlinux32-keyring ran into

[root@lappie chrisd]# pacman -S archlinux32-keyring
resolving dependencies...
looking for conflicting packages...

Packages (1) archlinux32-keyring-20240131-5.0

Total Installed Size:  0.04 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] Y
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
error: archlinux32-keyring: signature from "Andreas Baumann (sign) <mail@andreasbaumann.cc>" is unknown trust
:: File /var/cache/pacman/pkg/archlinux32-keyring-20240131-5.0-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

I spent some time googling for solutions but I really don't have hours to spend on my old laptop that I most just use for backup and traveling, so I the end I just added TrustAll to /etc/pacman.conf, updating archlinux32-keyring, now without errors and remove TrustAll again and then updating again (pacman -Syu).

Kind Regards,
Chris

Offline

#6 2024-02-12 10:18:24

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 1,001
Website

Re: Can't update - warning: cython & filesystem is newer than...

Yes, the keyring package was signed with the (then expired) signature (more precicely, too few master keys were vouching for the signing keys).
The only way is to do a SigLevel=Never, pacman -S archlinux32-kerying, restore SigLevel, then pacman -Syyu

Offline

Board footer

Powered by FluxBB