You are not logged in.

#1 2024-06-28 16:02:32

horomancer
Member
Registered: 2021-11-27
Posts: 2

Fresh Install, Dbus won't start

Hello.
I've done a fresh install with archlinux32-2024.06.23-i686.iso and after removing the live USB and booting for the first time I could not initiate 'iwtcl'. It would state "Waiting for iwd ..." and hang. Some googling pointed to dbus being the culprit and checking 'journalctl -b' showed an issue with dbus-broker-launch failing to initiate dbus-broker

ERROR launcher_run_child @ ../dbus-broker-36/src/launch/auncher.c +326: Permission denied

How do i go about resolving this? other than having issues with signing keys and having to run the first pass or pacman with pacman.conf set to SigLevel = Never, install didn't give me any issues.

Offline

#2 2024-06-30 07:16:16

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 1,001
Website

Re: Fresh Install, Dbus won't start

Can you do a ldd iwtcl or lddtree iwtcl. I suspect, something requires icu in a specific version.
I start to consider to put icu74, icu73 shim packages onto the ISO.
To be honest, I didn't try wlan at all, I just installed a ISO in libvirt with a wired network to test the ISO.

Offline

#3 2024-06-30 08:30:10

horomancer
Member
Registered: 2021-11-27
Posts: 2

Re: Fresh Install, Dbus won't start

Something to note. I booted back into the live media to install the utilities package for lddtree and caught a Failed flag on live media bootup

The live media failed to mount /etc/pacman.d/gnupg

running systemctl status etc-pacman.d-gnupg.mount gives me the following-

mount: /etc/pacman.d/gnupg: fsconfig system call failed: tmpfs: Unknown parameter 'noswap'
dmesg(1) may have more information after a failed mount system call

Attempting to run 'lddtree iwctl' or 'lddtree iwd' result ing 'warning: xxx: did not match and paths'

Offline

#4 2024-07-10 09:57:23

quietsoviet
Member
Registered: 2024-07-10
Posts: 1

Re: Fresh Install, Dbus won't start

I also have this problem on fresh install

Jul 10 10:17:19 archretro dbus-broker-launch[317]: ERROR launcher_run_child @ ../dbus-broker-36/src/launch/launcher.c +326: Permission denied
Jul 10 10:17:19 archretro dbus-broker-launch[313]: ERROR service_add @ ../dbus-broker-36/src/launch/service.c +1011: Transport endpoint is not connected
Jul 10 10:17:19 archretro dbus-broker-launch[313]:       launcher_add_services @ ../dbus-broker-36/src/launch/launcher.c +805
Jul 10 10:17:19 archretro dbus-broker-launch[313]:       launcher_run @ ../dbus-broker-36/src/launch/launcher.c +1416
Jul 10 10:17:19 archretro dbus-broker-launch[313]:       run @ ../dbus-broker-36/src/launch/main.c +152
Jul 10 10:17:19 archretro dbus-broker-launch[313]:       main @ ../dbus-broker-36/src/launch/main.c +178
Jul 10 10:17:19 archretro dbus-broker-launch[313]: Exiting due to fatal error: -107
Jul 10 10:17:19 archretro systemd[1]: dbus-broker.service: Main process exited, code=exited, status=1/FAILURE
Jul 10 10:17:19 archretro systemd[1]: dbus-broker.service: Failed with result 'exit-code'.

This is journalctl from chroot. I cant do anything with my system it just repeat error message. And other services fail because they cannot connect to dbus.

Offline

Board footer

Powered by FluxBB