You are not logged in.

Announcement

The recovered forum pages can be found here.
Bugs can be entered here, anyone can open an account now.

#1 2020-01-12 20:03:45

archlinux32forever
Member
Registered: 2020-01-12
Posts: 6

[SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

Hi

Doing a full system upgrade reports this error:

[user@mypc ~]$ LC_ALL=C sudo pacman -Syu
[sudo] password for user: 
:: Synchronizing package databases...
 core                                           154.4 KiB   498 KiB/s 00:00 [###########################################] 100%
 extra                                         1908.3 KiB  2.30 MiB/s 00:01 [###########################################] 100%
 community                                        4.9 MiB  2.57 MiB/s 00:02 [###########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python2-pyqtwebengine and pyqtwebengine-common are in conflict
[user@mypc ~]$

This  happens since 2 weeks ago more or less.
Someone knows how solve this issue?

Thanks in advance.

Last edited by archlinux32forever (2020-01-18 11:48:17)

Offline

#2 2020-01-12 20:37:15

levi
Administrator
Registered: 2019-11-16
Posts: 65

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

I don't quite understand that error.  Does it mean that both those package advertise that they provide the same string, or that they deposit the same files on disc or something else?  Each case seems to require some more information to actually resolve, so it seems you need to do some more debugging.

Maybe pacman -Qi on both of those packages and reporting back will shine a light.

Offline

#3 2020-01-12 20:53:36

archlinux32forever
Member
Registered: 2020-01-12
Posts: 6

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

This is the output from pacman -Qi from both packages:

[user@mypc ~]$ LC_ALL=C pacman -Qi python2-pyqtwebengine
Name            : python2-pyqtwebengine
Version         : 5.13.2-1.0
Description     : Python 2 bindings for QtWebEngine
Architecture    : pentium4
URL             : https://www.riverbankcomputing.com/software/pyqtwebengine/intro
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : python2-pyqt5  pyqtwebengine-common
Optional Deps   : None
Required By     : calibre
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 535.72 KiB
Packager        : Erich Eckner <arch32 at eckner dot net>
Build Date      : Tue Nov 5 12:38:44 2019
Install Date    : Mon Dec 9 13:17:19 2019
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[user@mypc ~]$ 
[user@mypc ~]$ LC_ALL=C pacman -Qi pyqtwebengine-common
Name            : pyqtwebengine-common
Version         : 5.13.2-1.0
Description     : Common files shared between python-pyqtwebengine and python2-pyqtwebengine
Architecture    : pentium4
URL             : https://www.riverbankcomputing.com/software/pyqtwebengine/intro
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : qt5-webengine
Optional Deps   : None
Required By     : python2-pyqtwebengine
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 147.71 KiB
Packager        : Erich Eckner <arch32 at eckner dot net>
Build Date      : Tue Nov 5 12:38:44 2019
Install Date    : Mon Dec 9 13:17:18 2019
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[user@mypc ~]$ 

Offline

#4 2020-01-12 23:14:12

levi
Administrator
Registered: 2019-11-16
Posts: 65

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

Okay, neither explictly provide any more than their package names, so it can't be my first assumption.  But it looks like their might be common files since the first depends on the second, yet the second says it contains the intersection of common files between the python2 and python3 versions of the first lib.  Could you do a pacman  -Ql (lower case L) on both to prove that that's the problem being reported, please?

Offline

#5 2020-01-13 06:32:30

deep42thought
Administrator
From: Jena, Germany
Registered: 2019-11-14
Posts: 19
Website

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

someone pulls in pyqtwebengine-common which conflicts both packages.
Check what you need to remove in order to remove that package - python2-pyqtwebengine should be amongst them. Then you can upgrade. Or do you happen to try a partial upgrade here?

regards,
deep42thought

Offline

#6 2020-01-13 06:37:04

levi
Administrator
Registered: 2019-11-16
Posts: 65

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

Ah yes, if I do a pacman -Si on python2-pyqtwebengine on my system, it tells me it conflicts with pyqtwebengine-common.  Seems like you'll have to remove calibre before you can update, then hopefully you can add it back if you still need it.

Offline

#7 2020-01-14 22:24:18

archlinux32forever
Member
Registered: 2020-01-12
Posts: 6

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

I uninstalled calibre with his dependences with

$ sudo pacman -Rs calibre

And when I try a full system upgrade I get this error:

[user@mypc ~]$ LC_ALL=C sudo pacman -Syu
[sudo] password for user: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: python-pyqt5 and pyqt5-common are in conflict. Remove pyqt5-common? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python-pyqt5 and pyqt5-common are in conflict
[user@mypc ~]$ 

And if I choose Yes I get another error

[user@mypc ~]$ LC_ALL=C sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: python-pyqt5 and pyqt5-common are in conflict. Remove pyqt5-common? [y/N] Y
error: failed to prepare transaction (could not satisfy dependencies)
:: installing xorgproto (2019.2-2.0) breaks dependency 'xf86dgaproto' required by libxxf86dga
[user@mypc ~]$ 

Offline

#8 2020-01-14 22:36:47

levi
Administrator
Registered: 2019-11-16
Posts: 65

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

Yes, I think I have that latter error at the moment.  I think I saw that someone in these parts already resolved it, but I haven't yet found it, or figured out my own solution.

So I think you've fixed the title problem, and are with the rest of us again.

Offline

#9 2020-01-15 07:40:07

deep42thought
Administrator
From: Jena, Germany
Registered: 2019-11-14
Posts: 19
Website

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

can you remove pyqt5-common, too?

pacman -Rs pyqt5-common

Make sure to not remove something important, though (or to re-install it afterwards).

regards,
deep42thought

Offline

#10 2020-01-15 22:22:25

levi
Administrator
Registered: 2019-11-16
Posts: 65

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

He effectively did that when he said yes to pacman asking if it could be removed.  Then he hit the same error I get when I've recently tried to update.

In regards to that, trying to remove libxxf86dga tells me it can't becuase mplayer depends on it.

Ah, just figured out what I was doing wrong, I was calling -Si on pacman, which was effectively giving me the dependencies of the latest version on the server, which *doesn't* depend on libxxf86dga for good reason, but if I do a -Qi as I probably intended, it does tell me.  I'll have to wait until I finish my current playlist in mplayer before I can try fixing that - perhaps a partial upgrade of mplayer then the removal of libxxf86dga (if it didn't get removed by upgrading mplayer), followed by a system upgrade might be the neatest way to fix this.

Edit: Nope, doing a partial upgrade doesn't remove any orphaned packages, as far as the man pages would elucidate, So I removed mplayer using pacman -Rs then reinstalled it as part of a system upgrade.  This has passed the conflict check and is running now, so I think that's the trick.

Last edited by levi (2020-01-16 07:47:34)

Offline

#11 2020-01-18 11:47:32

archlinux32forever
Member
Registered: 2020-01-12
Posts: 6

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

Thanks a lot!

At end I could do a system upgrade.

I remove mplayer with your instructions

$ sudo pacman -Rs mplayer

and selected to remove pyqt5-common and the system upgrade ended correctly. The only problem that I had is that randomly the wifi connection fails (I don't know why) and after a while it returns. I will open another issue if I cannot solve it.

Offline

#12 2020-01-18 20:20:49

levi
Administrator
Registered: 2019-11-16
Posts: 65

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

Good to read you were able to resolve your issue from my slightly chain of thought post.

When you say your wifi connection fails and the returns after some time, you presumably mean it returns in the sense of the connection coming back, not in the sense of some process finishing, which is more common in these circles.  My new 802.11n wifi stick sometimes falls over, but I've not noticed it coming back yet, I've usually restarted it already with a 'sudo netctl restart <interface>' already, although if you're using networkmanager presumably you'll need to use that somehow instead.  I tend to think it's probably a hardware issue, or possibly a driver issue, but either way not something the good people of this parish can fix themselves.

Offline

#13 2020-01-18 21:56:16

archlinux32forever
Member
Registered: 2020-01-12
Posts: 6

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

Yes, I mean that the connection is broken and reconnect after a while. When I do

$ ping 8.8.8.8

Sometimes some packages are lost or sometimes 100% are lost and usually when I start graphical mode or sometimes in console mode, it lost connection and returns

192.168.1.129 icmp_seq=1 Destination Host Unreachable
192.168.1.129 icmp_seq=2 Destination Host Unreachable
192.168.1.129 icmp_seq=3 Destination Host Unreachable
192.168.1.129 icmp_seq=4 Destination Host Unreachable
192.168.1.129 icmp_seq=5 Destination Host Unreachable
192.168.1.129 icmp_seq=6 Destination Host Unreachable

I downloaded archlinux32 from January last year and boot from usb (I'm sure that it worked) to check if I have the same issue and I have the issue (some packets are lost), so I think that could be that wifi card fails.

Offline

#14 Today 17:14:20

archlinux32forever
Member
Registered: 2020-01-12
Posts: 6

Re: [SOLVED]python2-pyqtwebengine and pyqtwebengine-common are in conflict

I solved today the issue.

I made a mistake selecting a specifing channel in router's settings. At that moment was the faster channel.

Today I selected channel auto in router's settings and now it works fine.

Offline

Board footer

Powered by FluxBB