You are not logged in.

#1 2018-03-27 14:17:24

knedlyk
Member
Registered: 2018-03-27
Posts: 3

gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

Today after update I've got the following messages:
https://pastebin.com/EW7inx9p
It looks like some files are owned by the different packages. I tried to file a bug but didn't find a way to do it.

Offline

#2 2018-03-27 17:35:06

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

Experienced the same.

You can report bugs here or in the bug reporting system at https://bugs.archlinux32.org,
but for the later you have to register first and get unlocked by a bug master (for spam
reasons).

Offline

#3 2018-03-27 17:37:33

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

I just used `--force` in pacman..

Offline

#4 2018-03-27 18:11:22

knedlyk
Member
Registered: 2018-03-27
Posts: 3

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

Ach, OK, now I know why I couldn't file a bug, I should to be unlocked.
@andreas_baumann Using --force is not a good option, because same files are owned by the three different packages. You just rewrite them. When you occasionally delete one of that packages you also delete some files from another package. This kind of situation shouldn't happen in archlinux.

Offline

#5 2018-03-27 20:39:35

WyRe
Member
Registered: 2018-03-03
Posts: 19

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

I'm having got the same issue, I've used --force parameter to fix this but I get the followings errors:

error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/allocators/gstphysmemory.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/audio/gstaudioaggregator.h'
error: file owned by 'gst-plugins-bad' and 'gstreamer': 'usr/include/gstreamer-1.0/gst/base/gstaggregator.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/egl/gstegl.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/egl/gsteglimage.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/egl/gstgldisplay_egl.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/egl/gstglmemoryegl.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gl.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/all_functions.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/base.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/blending.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/buffers.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/debug.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/eglimage.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/fbo.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/fixedfunction.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/gles.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/gstgl_compat.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/gstgl_gles2compat.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/opengl.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/query.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/shaders.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/sync.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/glprototypes/vao.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstgl_enums.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstgl_fwd.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglapi.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglbasefilter.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglbasememory.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglbuffer.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglbufferpool.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglcolorconvert.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglcontext.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstgldebug.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstgldisplay.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglfeature.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglfilter.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglformat.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglframebuffer.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglmemory.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglmemorypbo.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstgloverlaycompositor.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglquery.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglrenderbuffer.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglshader.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglshaderstrings.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglsl.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglslstage.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglsyncmeta.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglupload.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglutils.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglviewconvert.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/gstglwindow.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/wayland/gstgldisplay_wayland.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/include/gstreamer-1.0/gst/gl/x11/gstgldisplay_x11.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/lib/girepository-1.0/GstGL-1.0.typelib'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/lib/gstreamer-1.0/include/gst/gl/gstglconfig.h'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/lib/gstreamer-1.0/libgstaudiomixer.so'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base': 'usr/lib/gstreamer-1.0/libgstopengl.so'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/lib/libgstgl-1.0.so'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/lib/libgstgl-1.0.so.0'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/lib/pkgconfig/gstreamer-gl-1.0.pc'
error: file owned by 'gst-plugins-bad' and 'gst-plugins-base-libs': 'usr/share/gir-1.0/GstGL-1.0.gir'

Every time I run yaourt -Syua, any idea to fix this messages?

Offline

#6 2018-03-27 20:50:30

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

Maybe just uninstalling gst-plugins-base-lib helps? Then do a pacman -Syyu again..

As it looks like, gst-plugins-base-lib is no more upstream and leaked through the Archlinux32
chain. :-)

Yes, I agree, --force is bad..

Offline

#7 2018-03-28 14:49:20

WyRe
Member
Registered: 2018-03-03
Posts: 19

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

Then what should I do if I've run pacman with --force parameter?


pacman is working fine, yaourt is spamming those msgs.

Last edited by WyRe (2018-03-28 14:51:10)

Offline

#8 2018-03-28 16:30:58

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

Did you try to remove gst-plugins-base-lib and everything which depends on it. Then reinstall everything
which used gst-plugins-base-lib..

Offline

#9 2018-03-28 19:21:01

Vladdy
Member
Registered: 2017-11-17
Posts: 8

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

andreas_baumann wrote:

Did you try to remove gst-plugins-base-lib and everything which depends on it. Then reinstall everything
which used gst-plugins-base-lib..

Well i faced this issue too and used --force parameter because if I tried to remove gst-plugins-base-lib it breaks lots of dependencies for me including my desktop environment.

Offline

#10 2018-03-28 19:33:53

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

--nodeps? naeh.. doesn't do what I expected..

Offline

#11 2018-03-28 19:41:56

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

You can use pactree -l -r gst-plugins-base-lib to get a list of things depending on gst-plugins-base-lib, so
reinstalling is easier..

Offline

#12 2018-03-29 15:07:02

vafe
Member
Registered: 2017-11-23
Posts: 7

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

With 
sudo pacman --force -Syyu

is fine

sudo pacman --force -Syyu
:: Sincronizando las bases de datos de los paquetes...
core                                                        178,0 KiB   885K/s 00:00 [#################################################] 100%
extra                                                         2,3 MiB  1763K/s 00:01 [#################################################] 100%
community                                                     5,0 MiB  1235K/s 00:04 [#################################################] 100%
:: Iniciando actualización completa del sistema...
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquetes (3) gst-plugins-base-1.14.0-1.0  gst-plugins-base-libs-1.14.0-1.0  gstreamer-1.14.0-1.0

Tamaño total de la instalación:  36,37 MiB
Tamaño neto tras actualizar:     4,31 MiB

:: ¿Continuar con la instalación? [S/n]
(3/3) comprobando las claves del depósito                                             [#################################################] 100%
(3/3) verificando la integridad de los paquetes                                       [#################################################] 100%
(3/3) cargando los archivos de los paquetes                                           [#################################################] 100%
(3/3) comprobando conflictos entre archivos                                           [#################################################] 100%
(3/3) comprobando el espacio disponible en el disco                                   [#################################################] 100%
:: Procesando los cambios de los paquetes...
(1/3) actualizando gstreamer                                                          [#################################################] 100%
(2/3) actualizando gst-plugins-base-libs                                              [#################################################] 100%
(3/3) actualizando gst-plugins-base                                                   [#################################################] 100%
:: Ejecutando los «hooks» de posinstalación...
(1/1) Arming ConditionNeedsUpdate...

Offline

#13 2018-03-30 07:07:33

Javier68
Member
Registered: 2018-03-30
Posts: 7

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

Hi !
I have same problem with yaourt command.
Please someone give us a clean solution

Offline

#14 2018-03-30 07:50:52

kde35
Member
Registered: 2017-12-18
Posts: 24

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

andreas_baumann wrote:

You can use pactree -l -r gst-plugins-base-lib to get a list of things depending on gst-plugins-base-lib, so
reinstalling is easier..

Here pactree -l -r gst-plugins-base-libs gives

gst-plugins-base-libs
gst-plugins-bad
webkit2gtk
epiphany
osmo
gst-plugins-base
handbrake
phonon-qt4-gstreamer
phonon-qt4
kdelibs
kdebase-runtime
kdepimlibs4
libkactivities4
libkcddb4
libkexiv2_4
libkscreen4
phonon-qt4-gstreamer
qt5-multimedia
qt5-speech
knotifications
kwallet
kio
kdeclarative
kcmutils
k3b
kaccounts-integration
purpose
okular
kinit
kded
knewstuff
k3b
kate
knotifyconfig
k3b
kparts
khtml
ktexteditor
kate
okular
libkcddb
k3b
signon-kwallet-extension
kaccounts-integration
ktextwidgets
kxmlgui
kbookmarks
kio
qt5-webkit
k3b
signon-ui
kaccounts-integration
qtwebkit
webkit2gtk
webkitgtk
webkitgtk2
wxgtk2
wxgtk3
filezilla

  Probably one wouldn't like to uninstall and install all these packages?  I am using kde, but presumably with the other DE, the situation would be more or less same...

Offline

#15 2018-03-31 11:41:19

emgaron
Member
Registered: 2018-03-31
Posts: 13

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

When I look at the versions of those packages, I notice that there have been several updates (output from "pacman -Ss gstreamer"):

extra/gst-plugins-bad 1.12.4-5.0 [installed]
extra/gst-plugins-base 1.14.0-1.0 [installed: 1.12.4-1.0]
extra/gst-plugins-base-libs 1.14.0-1.0 [installed: 1.12.4-1.0]
extra/gst-plugins-good 1.12.4-2.0 [installed]
extra/gst-plugins-ugly 1.12.4-3.0 [installed]
extra/gstreamer 1.14.0-1.0 [installed: 1.12.4-1.0]

(quite possible that I missed an update in between - been lazy recently)

Note that none of the gst-plugins-{good,bad,ugly} has an updated candidate for version 1.14.0 (yet). They do, however, exist in version 1.14.0 in the main Arch Linux package list, but they've only been updated on March 30th (i.e. yesterday).
Further, the package "gst-plugins-base-lib" does not exist yet on my installation.

My conclusion from this: There has been a major reshuffling of the file-to-package mapping between version 1.12.4 and 1.14.0 - apparently, some files have been moved from gst-plugin-{good,bad,ugly} to gst-plugin-base-lib. As the packages for gst-plugin-{good,bad,ugly} have not been updated to version 1.14.0 yet in the Arch32 repositories, this results in the conflicts that we see, as the old versions also still own those files. I will therefore wait for a couple of days before re-trying the update. I would not at all be surprised if this conflict vanished as soon as the new versions of said packages have been added to the Arch32 repositories.

Offline

#16 2018-04-02 15:02:53

WyRe
Member
Registered: 2018-03-03
Posts: 19

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

andreas_baumann wrote:

Did you try to remove gst-plugins-base-lib and everything which depends on it. Then reinstall everything
which used gst-plugins-base-lib..


I've done that:

┌————— [wyre] ————— [~] 
└▶ $ sudo pacman -Rsn gst-plugins-base-libs evince gst-plugins-bad gst-plugins-base gst-plugins-good webkit2gtk wxgtk3 xfburn epiphany java-openjfx parole wxpython playonlinux playonlinux5-git
comprobando dependencias...
:: ffmpeg requiere opcionalmente ladspa: LADSPA filters
:: gimp requiere opcionalmente ghostscript: for postscript support
:: git requiere opcionalmente perl-libwww: git svn
:: graphicsmagick requiere opcionalmente ghostscript: pdf, ps modules
:: jack requiere opcionalmente celt: NetJACK driver
:: jre8-openjdk requiere opcionalmente java-openjfx: for JavaFX GUI components support
:: libmagick6 requiere opcionalmente ghostscript: PS/PDF support
:: libproxy requiere opcionalmente webkit2gtk: PAC proxy support (Webkit2gtk engine)
:: libreoffice-fresh requiere opcionalmente gst-plugins-base-libs: for multimedia content, e.g. in Impress
:: texlive-core requiere opcionalmente ghostscript: for epstopdf, epspdf and other ConTeXt tools
:: texmaker requiere opcionalmente ghostscript: LaTeX to HTML conversion command
:: wine requiere opcionalmente openal
:: wine requiere opcionalmente openal
:: wine requiere opcionalmente gst-plugins-base-libs
:: wine requiere opcionalmente gst-plugins-base-libs
:: youtube-dl requiere opcionalmente rtmpdump: for rtmp streams support

Paquetes (78) aalib-1.4rc5-12  cdparanoia-10.2-5  celt-0.11.3-3  chromaprint-1.4.3-1.0  faac-1.29.9.2-1.0
              faad2-2.8.8-1.0  geoclue2-2.4.7-1  ghostscript-9.22-7.0  gnu-netcat-0.7.1-6  graphene-1.8.0-1.0
              gstreamer-1.14.0-1.0  icoutils-0.32.2-1  ijs-0.35-1  imagemagick-7.0.7.26-1.0  jbig2dec-0.14-1
              ladspa-1.13-6  libbs2b-3.1.0-6.0  libburn-1.4.8-1  libdc1394-2.2.5-1  libdca-0.0.5-5
              libdv-1.0.0-7  libfdk-aac-0.1.6-1.0  libgme-0.6.1-1  libgxps-0.3.0-1  libisofs-1.4.8-1
              libmagick-7.0.7.26-1.0  libmms-0.6.4-2  libmp4v2-2.0.0-4  libmpcdec-1:0.1+r475-1
              libmpeg2-0.5.1-5  libofa-0.9.3-7.1  libshout-1:2.4.1-3  libspectre-0.2.8-1.1
              libsrtp-1:2.1.0-1.0  libvisual-0.4.0-7.0  mjpegtools-2.1.0-3  openal-1.18.2-1  p7zip-16.02-4.0
              perl-encode-locale-1.05-3  perl-file-listing-6.04-4  perl-html-parser-3.72-5
              perl-html-tagset-3.20-6  perl-http-cookies-6.04-2  perl-http-daemon-6.01-5
              perl-http-date-6.02-4  perl-http-message-6.14-1.0  perl-http-negotiate-6.01-4
              perl-io-html-1.001-3  perl-libwww-6.31-1.0  perl-lwp-mediatypes-6.02-4  perl-net-http-6.17-1
              perl-try-tiny-0.30-1.0  perl-www-robotrules-6.02-4  rtmpdump-1:2.4.r96.fa8646d-3  sbc-1.3-1
              schroedinger-1.0.11-3  soundtouch-2.0.0-1  spandsp-0.0.6-1  vulkan-icd-loader-1.1.70.0-3.0
              wavpack-5.1.0-2.0  wget-1.19.4-3.0  wildmidi-0.4.2-1.0  wxgtk-common-3.0.4-1.0  zvbi-0.2.35-1
              epiphany-3.26.6-1.0  evince-3.26.0+14+g2a499547-1  gst-plugins-bad-1.12.4-5.0
              gst-plugins-base-1.14.0-1.0  gst-plugins-base-libs-1.14.0-1.0  gst-plugins-good-1.12.4-2.0
              java-openjfx-8.u172-1  parole-0.9.2-2.0  playonlinux-4.2.12-1
              playonlinux5-git-2:r1957.5b7a2aed-1  webkit2gtk-2.18.6-1.0  wxgtk3-3.0.4-1.0
              wxpython-3.0.2.0-7.0  xfburn-0.5.5-1.0

Tamaño total quitado:  487,54 MiB

:: ¿Desea quitar estos paquetes? [S/n] 
:: Ejecutando los «hooks» de preinstalación...
(1/1) Removing old entries from the info directory file...
:: Procesando los cambios de los paquetes...
( 1/78) quitando playonlinux5-git                                  [-------------------------------------] 100%
( 2/78) quitando playonlinux                                       [-------------------------------------] 100%
( 3/78) quitando wget                                              [-------------------------------------] 100%
( 4/78) quitando p7zip                                             [-------------------------------------] 100%
( 5/78) quitando imagemagick                                       [-------------------------------------] 100%
( 6/78) quitando libmagick                                         [-------------------------------------] 100%
( 7/78) quitando icoutils                                          [-------------------------------------] 100%
( 8/78) quitando perl-libwww                                       [-------------------------------------] 100%
( 9/78) quitando perl-www-robotrules                               [-------------------------------------] 100%
(10/78) quitando perl-try-tiny                                     [-------------------------------------] 100%
(11/78) quitando perl-net-http                                     [-------------------------------------] 100%
(12/78) quitando perl-http-negotiate                               [-------------------------------------] 100%
(13/78) quitando perl-http-daemon                                  [-------------------------------------] 100%
(14/78) quitando perl-http-cookies                                 [-------------------------------------] 100%
(15/78) quitando perl-http-message                                 [-------------------------------------] 100%
(16/78) quitando perl-io-html                                      [-------------------------------------] 100%
(17/78) quitando perl-lwp-mediatypes                               [-------------------------------------] 100%
(18/78) quitando perl-html-parser                                  [-------------------------------------] 100%
(19/78) quitando perl-html-tagset                                  [-------------------------------------] 100%
(20/78) quitando perl-file-listing                                 [-------------------------------------] 100%
(21/78) quitando perl-http-date                                    [-------------------------------------] 100%
(22/78) quitando perl-encode-locale                                [-------------------------------------] 100%
(23/78) quitando gnu-netcat                                        [-------------------------------------] 100%
(24/78) quitando wxpython                                          [-------------------------------------] 100%
(25/78) quitando parole                                            [-------------------------------------] 100%
(26/78) quitando java-openjfx                                      [-------------------------------------] 100%
(27/78) quitando epiphany                                          [-------------------------------------] 100%
(28/78) quitando xfburn                                            [-------------------------------------] 100%
(29/78) quitando libisofs                                          [-------------------------------------] 100%
(30/78) quitando libburn                                           [-------------------------------------] 100%
(31/78) quitando wxgtk3                                            [-------------------------------------] 100%
(32/78) quitando wxgtk-common                                      [-------------------------------------] 100%
(33/78) quitando webkit2gtk                                        [-------------------------------------] 100%
(34/78) quitando geoclue2                                          [-------------------------------------] 100%
(35/78) quitando gst-plugins-good                                  [-------------------------------------] 100%
(36/78) quitando wavpack                                           [-------------------------------------] 100%
(37/78) quitando libshout                                          [-------------------------------------] 100%
(38/78) quitando aalib                                             [-------------------------------------] 100%
(39/78) quitando gst-plugins-base                                  [-------------------------------------] 100%
(40/78) quitando libvisual                                         [-------------------------------------] 100%
(41/78) quitando cdparanoia                                        [-------------------------------------] 100%
(42/78) quitando gst-plugins-bad                                   [-------------------------------------] 100%
(43/78) quitando zvbi                                              [-------------------------------------] 100%
(44/78) quitando wildmidi                                          [-------------------------------------] 100%
(45/78) quitando vulkan-icd-loader                                 [-------------------------------------] 100%
(46/78) quitando spandsp                                           [-------------------------------------] 100%
(47/78) quitando soundtouch                                        [-------------------------------------] 100%
(48/78) quitando schroedinger                                      [-------------------------------------] 100%
(49/78) quitando sbc                                               [-------------------------------------] 100%
(50/78) quitando rtmpdump                                          [-------------------------------------] 100%
(51/78) quitando openal                                            [-------------------------------------] 100%
(52/78) quitando mjpegtools                                        [-------------------------------------] 100%
(53/78) quitando libdv                                             [-------------------------------------] 100%
(54/78) quitando libsrtp                                           [-------------------------------------] 100%
(55/78) quitando libofa                                            [-------------------------------------] 100%
(56/78) quitando libmpeg2                                          [-------------------------------------] 100%
(57/78) quitando libmpcdec                                         [-------------------------------------] 100%
(58/78) quitando libmms                                            [-------------------------------------] 100%
(59/78) quitando libgme                                            [-------------------------------------] 100%
(60/78) quitando libfdk-aac                                        [-------------------------------------] 100%
(61/78) quitando libdca                                            [-------------------------------------] 100%
(62/78) quitando libdc1394                                         [-------------------------------------] 100%
(63/78) quitando libbs2b                                           [-------------------------------------] 100%
(64/78) quitando ladspa                                            [-------------------------------------] 100%
(65/78) quitando graphene                                          [-------------------------------------] 100%
(66/78) quitando faad2                                             [-------------------------------------] 100%
(67/78) quitando faac                                              [-------------------------------------] 100%
(68/78) quitando libmp4v2                                          [-------------------------------------] 100%
(69/78) quitando chromaprint                                       [-------------------------------------] 100%
(70/78) quitando celt                                              [-------------------------------------] 100%
(71/78) quitando evince                                            [-------------------------------------] 100%
(72/78) quitando libspectre                                        [-------------------------------------] 100%
(73/78) quitando ghostscript                                       [-------------------------------------] 100%
(74/78) quitando jbig2dec                                          [-------------------------------------] 100%
(75/78) quitando ijs                                               [-------------------------------------] 100%
(76/78) quitando libgxps                                           [-------------------------------------] 100%
(77/78) quitando gst-plugins-base-libs                             [-------------------------------------] 100%
(78/78) quitando gstreamer                                         [-------------------------------------] 100%
:: Ejecutando los «hooks» de posinstalación...
(1/5) Compiling GSettings XML schema files...
(2/5) Updating icon theme caches...
(3/5) Reloading system manager configuration...
(4/5) Arming ConditionNeedsUpdate...
(5/5) Updating the desktop file MIME type cache...

but now I get the following output when I try install that packages back:

┌————— [wyre] ————— [~] 
└▶ $ LC_ALL=C sudo pacman -S gst-plugins-base-libs evince gst-plugins-bad gst-plugins-base gst-plugins-good webkit2gtk wxgtk3 xfburn epiphany java-openjfx parole wxpython playonlinux
resolving dependencies...
:: There are 2 providers available for netcat:
:: Repository extra
   1) gnu-netcat
:: Repository community
   2) openbsd-netcat

Enter a number (default=1): 
looking for conflicting packages...

Packages (77) aalib-1.4rc5-12  cdparanoia-10.2-5  celt-0.11.3-3  chromaprint-1.4.3-1.0  faac-1.29.9.2-1.0  faad2-2.8.8-1.0  geoclue2-2.4.7-1  ghostscript-9.22-7.0
              gnu-netcat-0.7.1-6  graphene-1.8.0-1.0  gstreamer-1.14.0-1.0  icoutils-0.32.2-1  ijs-0.35-1  imagemagick-7.0.7.26-1.0  jbig2dec-0.14-1  ladspa-1.13-6
              libbs2b-3.1.0-6.0  libburn-1.4.8-1  libdc1394-2.2.5-1  libdca-0.0.5-5  libdv-1.0.0-7  libfdk-aac-0.1.6-1.0  libgme-0.6.1-1  libgxps-0.3.0-1
              libisofs-1.4.8-1  libmagick-7.0.7.26-1.0  libmms-0.6.4-2  libmp4v2-2.0.0-4  libmpcdec-1:0.1+r475-1  libmpeg2-0.5.1-5  libofa-0.9.3-7.1
              libshout-1:2.4.1-3  libspectre-0.2.8-1.1  libsrtp-1:2.1.0-1.0  libvisual-0.4.0-7.0  mjpegtools-2.1.0-3  openal-1.18.2-1  p7zip-16.02-4.0
              perl-encode-locale-1.05-3  perl-file-listing-6.04-4  perl-html-parser-3.72-5  perl-html-tagset-3.20-6  perl-http-cookies-6.04-2
              perl-http-daemon-6.01-5  perl-http-date-6.02-4  perl-http-message-6.14-1.0  perl-http-negotiate-6.01-4  perl-io-html-1.001-3  perl-libwww-6.31-1.0
              perl-lwp-mediatypes-6.02-4  perl-net-http-6.17-1  perl-try-tiny-0.30-1.0  perl-www-robotrules-6.02-4  rtmpdump-1:2.4.r96.fa8646d-3  sbc-1.3-1
              schroedinger-1.0.11-3  soundtouch-2.0.0-1  spandsp-0.0.6-1  vulkan-icd-loader-1.1.70.0-3.0  wavpack-5.1.0-2.0  wget-1.19.4-3.0  wildmidi-0.4.2-1.0
              wxgtk-common-3.0.4-1.0  zvbi-0.2.35-1  epiphany-3.26.6-1.0  evince-3.26.0+14+g2a499547-1  gst-plugins-bad-1.12.4-5.0  gst-plugins-base-1.14.0-1.0
              gst-plugins-base-libs-1.14.0-1.0  gst-plugins-good-1.12.4-2.0  java-openjfx-8.u172-1  parole-0.9.2-2.0  playonlinux-4.2.12-1  webkit2gtk-2.18.6-1.0
              wxgtk3-3.0.4-1.0  wxpython-3.0.2.0-7.0  xfburn-0.5.5-1.0

Total Installed Size:  467.23 MiB

:: Proceed with installation? [Y/n] 
(77/77) checking keys in keyring                                                                    [----------------------------------------------------------] 100%
(77/77) checking package integrity                                                                  [----------------------------------------------------------] 100%
(77/77) loading package files                                                                       [----------------------------------------------------------] 100%
(77/77) checking for file conflicts                                                                 [----------------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
/usr/include/gstreamer-1.0/gst/base/gstaggregator.h exists in both 'gstreamer' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/allocators/gstphysmemory.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/audio/gstaudioaggregator.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/egl/gstegl.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/egl/gsteglimage.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/egl/gstgldisplay_egl.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/egl/gstglmemoryegl.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gl.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/all_functions.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/base.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/blending.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/buffers.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/debug.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/eglimage.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/fbo.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/fixedfunction.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/gles.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/gstgl_compat.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/gstgl_gles2compat.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/opengl.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/query.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/shaders.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/sync.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/glprototypes/vao.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstgl_enums.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstgl_fwd.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglapi.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglbasefilter.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglbasememory.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglbuffer.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglbufferpool.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglcolorconvert.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglcontext.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstgldebug.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstgldisplay.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglfeature.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglfilter.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglformat.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglframebuffer.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglmemory.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglmemorypbo.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstgloverlaycompositor.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglquery.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglrenderbuffer.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglshader.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglshaderstrings.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglsl.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglslstage.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglsyncmeta.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglupload.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglutils.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglviewconvert.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/gstglwindow.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/wayland/gstgldisplay_wayland.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/include/gstreamer-1.0/gst/gl/x11/gstgldisplay_x11.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/lib/girepository-1.0/GstGL-1.0.typelib exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/lib/gstreamer-1.0/include/gst/gl/gstglconfig.h exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/lib/gstreamer-1.0/libgstaudiomixer.so exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/lib/libgstgl-1.0.so exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/lib/libgstgl-1.0.so.0 exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/lib/pkgconfig/gstreamer-gl-1.0.pc exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/share/gir-1.0/GstGL-1.0.gir exists in both 'gst-plugins-base-libs' and 'gst-plugins-bad'
/usr/lib/gstreamer-1.0/libgstopengl.so exists in both 'gst-plugins-bad' and 'gst-plugins-base'
Errors occurred, no packages were upgraded.

I think there is a big mess with gst-plugins-base-libs and gst-plugins-bad files in your repos. Any idea? Maybe should I use --force flag again?

Last edited by WyRe (2018-04-02 15:15:08)

Offline

#17 2018-04-02 16:24:09

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 608

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

yeah, you're right, there seems to be a mess with these packages in the repositories: the correct version of gst-plugins-bad is currently in testing. Unfortunately, I cannot do something about this, until rewbycraft fixes our buildmaster sad

Offline

#18 2018-04-04 09:09:48

WyRe
Member
Registered: 2018-03-03
Posts: 19

Re: gst-plugins-bad, gst-plugins-base-lib and gst-plugins-base: same files

Today I could upgrade system normally. Now it seems solved. I would mark it as [Solved]

Offline

Board footer

Powered by FluxBB