You are not logged in.

#1 2018-04-03 13:29:29

timsong
Member
Registered: 2018-04-03
Posts: 25

Samba services won't start

Samba wont start after recent updates, can anyone help ?

* nmbd.service - Samba NetBIOS name server
   Loaded: loaded (/usr/lib/systemd/system/nmbd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2018-04-03 14:09:03 BST; 3min 0s ago
  Process: 555 ExecStart=/usr/bin/nmbd -D (code=exited, status=1/FAILURE)

Apr 03 14:09:03 oldlaptop nmbd[555]: /usr/bin/nmbd: /usr/lib/samba/libCHARSET3-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/nmbd)
Apr 03 14:09:03 oldlaptop nmbd[555]: /usr/bin/nmbd: /usr/lib/samba/libcli-nbt-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/nmbd)
Apr 03 14:09:03 oldlaptop nmbd[555]: /usr/bin/nmbd: /usr/lib/samba/liblibsmb-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/nmbd)
Apr 03 14:09:03 oldlaptop nmbd[555]: /usr/bin/nmbd: /usr/lib/samba/libcli-smb-common-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/nmbd)
Apr 03 14:09:03 oldlaptop nmbd[555]: /usr/bin/nmbd: /usr/lib/samba/libgse-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/nmbd)
Apr 03 14:09:03 oldlaptop nmbd[555]: /usr/bin/nmbd: /usr/lib/samba/libsamba-sockets-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/nmbd)
Apr 03 14:09:03 oldlaptop nmbd[555]: /usr/bin/nmbd: /usr/lib/samba/libsamba-debug-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/nmbd)
Apr 03 14:09:03 oldlaptop systemd[1]: nmbd.service: Control process exited, code=exited status=1
Apr 03 14:09:03 oldlaptop systemd[1]: nmbd.service: Failed with result 'exit-code'.
Apr 03 14:09:03 oldlaptop systemd[1]: Failed to start Samba NetBIOS name server.

[root@oldlaptop tim]# pacman -Syu samba
:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
warning: samba-4.7.5-1.0 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) samba-4.7.5-1.0

Total Download Size:    5.16 MiB
Total Installed Size:  41.27 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] n

Thanks
Tim

Last edited by timsong (2018-04-03 18:35:10)

Offline

#2 2018-04-03 13:36:23

timsong
Member
Registered: 2018-04-03
Posts: 25

Re: Samba services won't start

Also smbd.service wont start

* smbd.service - Samba SMB/CIFS server
   Loaded: loaded (/usr/lib/systemd/system/smbd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2018-04-03 14:31:59 BST; 1min 25s ago
  Process: 758 ExecStart=/usr/bin/smbd -D (code=exited, status=1/FAILURE)

Apr 03 14:32:04 oldlaptop smbd[758]: /usr/bin/smbd: /usr/lib/samba/libsamba3-util-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/smbd)
Apr 03 14:32:04 oldlaptop smbd[758]: /usr/bin/smbd: /usr/lib/samba/libpopt-samba3-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/smbd)
Apr 03 14:32:04 oldlaptop smbd[758]: /usr/bin/smbd: /usr/lib/samba/libcliauth-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/smbd)
Apr 03 14:32:04 oldlaptop smbd[758]: /usr/bin/smbd: /usr/lib/samba/libsmbd-shim-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/smbd)
Apr 03 14:32:04 oldlaptop smbd[758]: /usr/bin/smbd: /usr/lib/samba/libsamba-debug-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/smbd)
Apr 03 14:32:04 oldlaptop smbd[758]: /usr/bin/smbd: /usr/lib/samba/libsmbd-base-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/smbd)
Apr 03 14:32:04 oldlaptop smbd[758]: /usr/bin/smbd: /usr/lib/samba/libauth-samba4.so: version `SAMBA_4.7.5' not found (required by /usr/bin/smbd)
Apr 03 14:31:59 oldlaptop systemd[1]: smbd.service: Control process exited, code=exited status=1
Apr 03 14:31:59 oldlaptop systemd[1]: smbd.service: Failed with result 'exit-code'.
Apr 03 14:31:59 oldlaptop systemd[1]: Failed to start Samba SMB/CIFS server.

Offline

#3 2018-04-03 18:34:26

timsong
Member
Registered: 2018-04-03
Posts: 25

Re: Samba services won't start

Temp Fix

Downgraded smbclient and libwbclient to versions 4.7.5-1

Related bug report

https://bugs.archlinux32.org/index.php? … task_id=32

Offline

#4 2018-04-04 19:52:46

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 510
Website

Re: Samba services won't start

We should maybe bump manually libwbclient, samba and smbclient to version 4.7.6 in stable?

Offline

Board footer

Powered by FluxBB