You are not logged in.

#1 2018-04-12 15:49:25

becoming_i
Member
From: Athens
Registered: 2018-03-10
Posts: 10
Website

[SOLVED]Chromium not working after system update

After an update i can't get chromium to run
In terminal i get

chromium
/usr/lib/chromium/chromium: error while loading shared libraries: libicui18n.so.60: cannot open shared object file: No such file or directory

And the icu package is on version 61

sudo pacman -Q icu                       
[sudo] password for becoming_i: 
icu 61.1-1.0

Edit: Solved by installing

icu60

from AUR

Seems that the current version (61.1) doesn't work with telegram,chromium,smtube and some others.

Last edited by becoming_i (2018-04-12 19:52:52)

Offline

#2 2018-04-13 08:23:26

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 608

Re: [SOLVED]Chromium not working after system update

I moved the next chromium version from testing to stable - it should work now.

Offline

#3 2018-04-13 08:51:56

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED]Chromium not working after system update

Tested an works.

Offline

#4 2018-04-13 15:14:51

Roboron3042
Member
Registered: 2018-04-13
Posts: 1

Re: [SOLVED]Chromium not working after system update

I'm having this issue with SDDM also.

Offline

#5 2018-04-14 09:13:57

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED]Chromium not working after system update

Yep. Can confirm. SDDM starred at me blanckly (or rather blackish) this morning. I have to check, what has
crept in this time..

Offline

#6 2018-04-14 09:49:02

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED]Chromium not working after system update

Aha. On stable I get:

Apr 14 10:44:33 arch32-stable sddm[273]: /usr/bin/sddm: error while loading shared libraries: libicui18n.so.60: cannot open shared object file: No such file or directory

I'll trigger a rebuild.

Offline

#7 2018-04-14 10:00:04

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED]Chromium not working after system update

Mmh. I have a really weird issue:

On my testing machine:

[root@arch32-testing ~]# pacman -Q | grep sddm
sddm 0.17.0-5.0

[root@arch32-testing ~]# ldd /usr/bin/sddm | grep icu
        libicui18n.so.61 => /usr/lib/libicui18n.so.61 (0xb6564000)
        libicuuc.so.61 => /usr/lib/libicuuc.so.61 (0xb63a9000)
        libicudata.so.61 => /usr/lib/libicudata.so.61 (0xb4822000)

on my stable:

[root@arch32-stable ~]# pacman -Q | grep sddm
sddm 0.17.0-5.0

[root@arch32-stable ~]# ldd /usr/bin/sddm | grep icu
        libicui18n.so.60 => not found
        libicuuc.so.60 => not found

This is exactly the same package versions of sddm,
so it must be a libraries inbetween using old ICUs on stable.

lddtree shows:

libQt5Core.so.5 => /lib/libQt5Core.so.5
        libicui18n.so.60 => None
        libicuuc.so.60 => None

libQt5Core.so.5 => /lib/libQt5Core.so.5
        libicui18n.so.61 => /lib/libicui18n.so.61
        libicuuc.so.61 => /lib/libicuuc.so.61
            libicudata.so.61 => /lib/libicudata.so.61

So qt5-base 5.10.1-6.0 should be upgraded to qt5-base 5.10.1-7.0.

Offline

#8 2018-04-14 10:01:20

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED]Chromium not working after system update

I think, I'll device a list a all icu.60 packages currently in one of the repos, so we can nudge them a little bit.. :-)

Offline

Board footer

Powered by FluxBB