You are not logged in.

#1 2018-05-05 01:39:59

anselm
Member
Registered: 2017-11-21
Posts: 30

Missing menus and fonts in XnviewMP picture viewer

I tried to install XnviewMP picture viewer 0.9, both version in the Aur repo was tested (xnviewmp-system-libs, and plain xnviewmp), with same result:

mGZzH8V.png

Other programs have the menus and fonts of course.

Offline

#2 2018-05-05 06:55:22

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 568
Website

Re: Missing menus and fonts in XnviewMP picture viewer

Mmh. When I start the program I get tons of errors like:

Fontconfig error: "/etc/fonts/fonts.conf", line 2: out of memory
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf
Fontconfig error: "/etc/fonts/conf.avail/10-autohint.conf", line 2: out of memory
Fontconfig error: "/etc/fonts/conf.avail/10-hinting-full.conf", line 2: out of memory
...

64-bit seems to work fine.

I'll check if there is a problem in the libfont library..

Offline

#3 2018-05-05 07:01:26

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 568
Website

Re: Missing menus and fonts in XnviewMP picture viewer

https://newsgroup.xnview.com/viewtopic.php?t=37097
https://newsgroup.xnview.com/viewtopic.php?f=62&t=36336
https://newsgroup.xnview.com/viewtopic.php?f=82&t=36326

The issue is in https://www.xnview.com/mantisbt/view.php?id=1315

They say fixed in 0.88, but obviously it is still there in 0.90.

This looks to my like an Xnview issue which should be resolved by the author.

Generally speaking, we don't provide support or fixes for packages in the AUR.

Offline

Board footer

Powered by FluxBB