You are not logged in.

#1 2018-05-10 17:00:11

TBone
Member
Registered: 2018-05-10
Posts: 4

Qemu not working with kernel >= 4.14

Good evening,

I have a problem starting qemu with kernel >= 4.14. Qemu runs, but the VM is not booting, either with the 4.16.7 nor with 4.14.39.
It is working with an old 4.9 lts kernel. Everything else up to date.

Can anyone confirm this issue?

Offline

#2 2018-05-10 23:20:28

judd
Member
Registered: 2018-04-23
Posts: 27

Re: Qemu not working with kernel >= 4.14

Are you working with this package ?
https://imgur.com/sfWZFBK

Offline

#3 2018-05-11 08:56:25

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 710
Website

Re: Qemu not working with kernel >= 4.14

So, you are running Archlinux32 inside a qemu client? Because running qemu 2.12.0 on Archlinux32 with a kernel 4.16.6 works for me without any problems (running another operating system).
There are issues with newer ISO images when booting the Archlinux32 ISO inside virtualbox or qemu.
(see also https://bugs.archlinux32.org/index.php? … ask_id=37). The last known ISO working
was 2018.02 or 2018.01 I think. This is always an option, use an older ISO to install the system.

What kind of error messages do you get? Do they look similar as the ones mentioned in the bug report?

Offline

#4 2018-05-11 14:35:58

TBone
Member
Registered: 2018-05-10
Posts: 4

Re: Qemu not working with kernel >= 4.14

I dont get an error message, qemu is running, but the VM is not starting. I use Debian 8 as guest and archlinux32 as host. With older kernel, the debian qcow2 image is starting.
I am pretty sure, it is qemu version 2.12, but I can look later to be sure

Offline

#5 2018-05-11 15:21:13

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 710
Website

Re: Qemu not working with kernel >= 4.14

ok, just booted a debian 9.4.9 xfce CD (i386) on an Archlinux32 (kernel 4.16.6, qemu 2.12.0) with:

qemu-system-i386 -cdrom debian-9.4.0-i386-xfce-CD-1.iso

I get a "sysenter_past_esp attempted to kill init" and kernel panic.

When adding '-m 1024' and using text install I get booting kernel..

Offline

#6 2018-05-12 10:53:49

TBone
Member
Registered: 2018-05-10
Posts: 4

Re: Qemu not working with kernel >= 4.14

Thank you very much, after increasing the amount of RAM to 1024M and waiting a long time, I get now:

The guest has not initialized the display (yet)

Then I tried the debian install CD with your command, and it works! So I reduced my command to find out, what is not working properly and it is: -enable-kvm
After removing it, I am able to boot with -m 256. (My original setting)
But the virtual machine is now very slow. (Running on linux-lts)

Thank you very much for helping me to find the issue, I have not thought of this at all, you saved me a lot of time!
Can you please confirm this issue on your machine? Maybe it is a problem only existent with the hardware. (Intel(R) Core(TM)2 CPU 6600  @ 2.40GHz)

Edit: I only have access to this machine over ssh and VPN (and somebody needs to turn on the machine for me), so I need a bit of time to try things.

Last edited by TBone (2018-05-12 10:55:35)

Offline

#7 2018-05-23 10:31:07

TBone
Member
Registered: 2018-05-10
Posts: 4

Re: Qemu not working with kernel >= 4.14

The system seams to be to slow for real usage. Has anybody any suggestions?

Offline

Board footer

Powered by FluxBB