You are not logged in.

#1 2018-05-11 08:25:35

SabinaS
Member
From: Italy
Registered: 2018-05-11
Posts: 6
Website

[SOLVED] Booting stopped at disk checking

Hello everyone!
I tried to install archlinux32 on my emachines netook after years and years of magnificent Architude... But something went wrong.

The booting process stops at this line:

starting versione 238
/dev/sda2: clean, 45494/3276800 files, 543672/13107200 blocks

sda2 is the partition where the root is mounted.

I've tried to disable the partition checking in fstab but it didn't work.

Can someone help me?

Thanks

Last edited by SabinaS (2018-05-28 10:55:52)

Offline

#2 2018-05-11 09:50:41

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED] Booting stopped at disk checking

Hi, can you add a 'debug' option to grub and see what the other messages are?

Offline

#3 2018-05-11 10:39:16

SabinaS
Member
From: Italy
Registered: 2018-05-11
Posts: 6
Website

Re: [SOLVED] Booting stopped at disk checking

Hi!
I added a debug option as described here but the grub seems to work fine, instead the booting continues to stopping at the same point with no other messages. sad

Last edited by SabinaS (2018-05-11 10:56:56)

Offline

#4 2018-05-11 16:45:32

Stefan_1957
Member
From: Sinnerthal
Registered: 2018-04-28
Posts: 5

Re: [SOLVED] Booting stopped at disk checking

Hi SabinaS,
press Ctrl Alt F2 after boot, is there a text mode? If so, login as root and delete the quiet option in /etc/default/grub.
Reboot and you can see what happens with your installation.
Good luck.
Stefan

Offline

#5 2018-05-11 17:37:40

SabinaS
Member
From: Italy
Registered: 2018-05-11
Posts: 6
Website

Re: [SOLVED] Booting stopped at disk checking

Hello Stefan!
Ctrl+Alt+F2 works fine and I could login as root.
I tried to remove the quiet option from /etc/default/grub but nothing seems happened.
So, I also tried to remove the quiet option from /boot/grub/grub.cfg from the line

 linux    /vmlinuz-linux root=UUID=xxxxx rw  quiet 

and that's the result: Image

It only stops some steps later hmm.

Offline

#6 2018-05-11 17:49:31

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED] Booting stopped at disk checking

So, can you try to log in into the text console and start X manually (startx)? Also check /var/log/Xorg.0.log for
errors..

Offline

#7 2018-05-11 17:54:18

SabinaS
Member
From: Italy
Registered: 2018-05-11
Posts: 6
Website

Re: [SOLVED] Booting stopped at disk checking

I have not installed Xorg yet.
This stop is what I get from the first reboot...

Offline

#8 2018-05-11 17:55:26

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED] Booting stopped at disk checking

Aeh. Graphical booting without Xorg will not work, just hang. :-)

Offline

#9 2018-05-11 18:04:29

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED] Booting stopped at disk checking

Intel GMA 3150 => hope xf86-video-intel works for you, if not, try xf86-video-vesa.

Offline

#10 2018-05-11 21:16:26

Stefan_1957
Member
From: Sinnerthal
Registered: 2018-04-28
Posts: 5

Re: [SOLVED] Booting stopped at disk checking

Hi, back again.
As Andreas said, install xf86-video-intel, xorg & co., a desktop and your favourite display manager.
Startx, systemctl start/enable all you want and enjoy.
Wish everyone a peaceful night.

Offline

#11 2018-05-28 10:13:14

SabinaS
Member
From: Italy
Registered: 2018-05-11
Posts: 6
Website

Re: [SOLVED] Booting stopped at disk checking

Hello,
thank you for your help.
I installed a display manager and so it runs correctly...
I have a question: in the 64bit versione, there's no necessity to install the desktop enviroment to run the system. What about this 32 bit version?
Let me explain better ... Can I use arch32 even without a graphic environment or is it strictly necessary?

Last edited by SabinaS (2018-05-28 10:14:20)

Offline

#12 2018-05-28 10:18:41

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: [SOLVED] Booting stopped at disk checking

Yes, no problem, sure you can use ist withou any graphical user environment.

Just don't enable any display managers as sddm, gdm, slim, etc in systemd.

You can still login via text mode and use 'startx' to get into the graphical desktop.

There is even a plain-text display manager for systemd logins, see
https://wiki.archlinux.org/index.php/display_manager

Offline

#13 2018-05-28 10:54:36

SabinaS
Member
From: Italy
Registered: 2018-05-11
Posts: 6
Website

Re: [SOLVED] Booting stopped at disk checking

Ok, thanks.
So maybe I had a different problem... Anyway, I solved it.

Bye!

Offline

Board footer

Powered by FluxBB