You are not logged in.

#1 2018-04-27 07:05:58

radli
Member
Registered: 2018-04-27
Posts: 4

[SOLVED] Can't update system due to outdated virtualbox-guest-module

The newest version is 5.2.10
https://www.archlinux.org/packages/comm … ules-arch/

archlinux32 has community/virtualbox-guest-modules-arch 5.2.8-11.0

This causes the upgrade problem.
error: failed to prepare transaction (could not satisfy dependencies)
virtualbox-guest-modules-arch: requires linux<4.16

[aim@xcart-aim-arch:pts/5][~]$ yaourt -Syau --needed
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
:: Replace compositeproto with extra/xorgproto? [Y/n] 
:: Replace damageproto with extra/xorgproto? [Y/n] 
:: Replace dmxproto with extra/xorgproto? [Y/n] 
warning: firefox: ignoring package upgrade (56.0.2-1 => 59.0.2-2.0)
:: Replace fixesproto with extra/xorgproto? [Y/n] 
:: Replace fontsproto with extra/xorgproto? [Y/n] 
:: Replace gnome-themes-standard with extra/gnome-themes-extra? [Y/n] 
:: Replace inputproto with extra/xorgproto? [Y/n] 
:: Replace kbproto with extra/xorgproto? [Y/n] 
:: Replace randrproto with extra/xorgproto? [Y/n] 
:: Replace recordproto with extra/xorgproto? [Y/n] 
:: Replace renderproto with extra/xorgproto? [Y/n] 
:: Replace scrnsaverproto with extra/xorgproto? [Y/n] 
:: Replace videoproto with extra/xorgproto? [Y/n] 
:: Replace xextproto with extra/xorgproto? [Y/n] 
:: Replace xf86dgaproto with extra/xorgproto? [Y/n] 
:: Replace xf86vidmodeproto with extra/xorgproto? [Y/n] 
warning: xfce4-terminal: ignoring package upgrade (0.6.3-3 => 0.8.7.3-1.0)
:: Replace xineramaproto with extra/xorgproto? [Y/n] 
:: Replace xproto with extra/xorgproto? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-guest-modules-arch: requires linux<4.16

[aim@xcart-aim-arch:pts/5][~]$ sudo pacman -S linux
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-guest-modules-arch: installing linux (4.16.3-1.0) breaks dependency 'linux<4.15'

[aim@xcart-aim-arch:pts/5][~]$ sudo pacman -Q linux
linux 4.14.15-1.0

[aim@xcart-aim-arch:pts/5][~]$ sudo pacman -S virtualbox-guest-modules-arch
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-guest-modules-arch: requires linux<4.16

[aim@xcart-aim-arch:pts/5][~]$ sudo pacman -Q virtualbox-guest-modules-arch
virtualbox-guest-modules-arch 5.2.6-3.0
[aim@xcart-aim-arch:pts/5][~]$ yaourt virtualbox-guest-modules-arch
1 community/virtualbox-guest-modules-arch 5.2.8-11.0 [installed: 5.2.6-3.0]
    Virtualbox guest kernel modules for Arch Kernel
==> Enter n° of packages to be installed (e.g., 1 2 3 or 1-3)
==> ---------------------------------------------------------
==> ^C

[aim@xcart-aim-arch:pts/5][~]$ yaourt virtualbox-guest-modules-arch
1 community/virtualbox-guest-modules-arch 5.2.8-11.0 [installed: 5.2.6-3.0]
    Virtualbox guest kernel modules for Arch Kernel
==> Enter n° of packages to be installed (e.g., 1 2 3 or 1-3)
==> ---------------------------------------------------------
==> 1

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-guest-modules-arch: requires linux<4.16

[aim@xcart-aim-arch:pts/5][~]$ sudo pacman -Syu --needed 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace compositeproto with extra/xorgproto? [Y/n] 
:: Replace damageproto with extra/xorgproto? [Y/n] 
:: Replace dmxproto with extra/xorgproto? [Y/n] 
warning: firefox: ignoring package upgrade (56.0.2-1 => 59.0.2-2.0)
:: Replace fixesproto with extra/xorgproto? [Y/n] 
:: Replace fontsproto with extra/xorgproto? [Y/n] 
:: Replace gnome-themes-standard with extra/gnome-themes-extra? [Y/n] 
:: Replace inputproto with extra/xorgproto? [Y/n] 
:: Replace kbproto with extra/xorgproto? [Y/n] 
:: Replace randrproto with extra/xorgproto? [Y/n] 
:: Replace recordproto with extra/xorgproto? [Y/n] 
:: Replace renderproto with extra/xorgproto? [Y/n] 
:: Replace scrnsaverproto with extra/xorgproto? [Y/n] 
:: Replace videoproto with extra/xorgproto? [Y/n] 
:: Replace xextproto with extra/xorgproto? [Y/n] 
:: Replace xf86dgaproto with extra/xorgproto? [Y/n] 
:: Replace xf86vidmodeproto with extra/xorgproto? [Y/n] 
warning: xfce4-terminal: ignoring package upgrade (0.6.3-3 => 0.8.7.3-1.0)
:: Replace xineramaproto with extra/xorgproto? [Y/n] 
:: Replace xproto with extra/xorgproto? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-guest-modules-arch: requires linux<4.16
[aim@xcart-aim-arch:pts/5][~]$ 

Last edited by radli (2018-05-08 07:20:41)

Offline

#2 2018-04-27 10:22:01

judd
Member
Registered: 2018-04-23
Posts: 27

Re: [SOLVED] Can't update system due to outdated virtualbox-guest-module

# pacman-key --populate archlinux32

and then

pacman -Syyu

Offline

#3 2018-04-27 10:45:03

tyzoid
Administrator
From: Ann Arbor, MI
Registered: 2017-06-17
Posts: 85

Re: [SOLVED] Can't update system due to outdated virtualbox-guest-module

Version 5.2.10 of virtualbox-guest-modules-arch is in [community-testing], so we'll have to get this moved over sooner.

Offline

#4 2018-04-27 12:30:53

radli
Member
Registered: 2018-04-27
Posts: 4

Re: [SOLVED] Can't update system due to outdated virtualbox-guest-module

Hello,

Thank you for your reply.

Unfortunately, it didn't help.

The reason is the same
:: virtualbox-guest-modules-arch: requires linux<4.16


[aim@xcart-aim-arch:pts/3][~]$ sudo pacman-key --populate archlinux32
==> Appending keys from archlinux32.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key CE0BDE71A759A87F23F0F7D8B61DBCE10901C163...
  -> Locally signing key 2FF1E976D6EB2E954A87DC14443904EC9EC51A8A...
  -> Locally signing key D92CDDC155BCC8F550B5FCEC30AB721FE7400FCD...
  -> Locally signing key A0B250C0FC9FC079EC04ADB7A50C0F20AEC3AF00...
  -> Locally signing key 194E37A47A4C671807BACB37B1117BC1094EA6E9...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
  -> Disabling key C3A8190912128B5A2E96C6023ED6490AEF932C8A...
==> Updating trust database...
gpg: next trustdb check due at 2018-05-15
[aim@xcart-aim-arch:pts/3][~]$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                                                                                     175.7 KiB   810K/s 00:00 [####################################################################] 100%
 extra                                                                                      2.3 MiB  2001K/s 00:01 [####################################################################] 100%
 community                                                                                  4.9 MiB  2.90M/s 00:02 [####################################################################] 100%
 archlinuxfr                                                                                7.5 KiB  0.00B/s 00:00 [####################################################################] 100%
:: Starting full system upgrade...
:: Replace compositeproto with extra/xorgproto? [Y/n] 
:: Replace damageproto with extra/xorgproto? [Y/n] 
:: Replace dmxproto with extra/xorgproto? [Y/n] 
warning: firefox: ignoring package upgrade (56.0.2-1 => 59.0.2-2.0)
:: Replace fixesproto with extra/xorgproto? [Y/n] 
:: Replace fontsproto with extra/xorgproto? [Y/n] 
:: Replace gnome-themes-standard with extra/gnome-themes-extra? [Y/n] 
:: Replace inputproto with extra/xorgproto? [Y/n] 
:: Replace kbproto with extra/xorgproto? [Y/n] 
:: Replace randrproto with extra/xorgproto? [Y/n] 
:: Replace recordproto with extra/xorgproto? [Y/n] 
:: Replace renderproto with extra/xorgproto? [Y/n] 
:: Replace scrnsaverproto with extra/xorgproto? [Y/n] 
:: Replace videoproto with extra/xorgproto? [Y/n] 
:: Replace xextproto with extra/xorgproto? [Y/n] 
:: Replace xf86dgaproto with extra/xorgproto? [Y/n] 
:: Replace xf86vidmodeproto with extra/xorgproto? [Y/n] 
warning: xfce4-terminal: ignoring package upgrade (0.6.3-3 => 0.8.7.3-1.0)
:: Replace xineramaproto with extra/xorgproto? [Y/n] 
:: Replace xproto with extra/xorgproto? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-guest-modules-arch: requires linux<4.16
[aim@xcart-aim-arch:pts/3][~]$ 

Offline

#5 2018-05-15 05:10:45

radli
Member
Registered: 2018-04-27
Posts: 4

Re: [SOLVED] Can't update system due to outdated virtualbox-guest-module

Upgrade to virtualbox-guest-modules-arch 5.2.10 helped me.

It should be updated again the new version is 5.2.12

Last edited by radli (2018-05-15 05:12:26)

Offline

Board footer

Powered by FluxBB