You are not logged in.

#1 2018-05-29 14:00:13

vaprovo
Member
Registered: 2018-05-29
Posts: 2

Brother MFC-J870DW Support

The AUR package has lib32-glibc listed as a dependency, but since I'm on arch32 can I just change it to glibc in the PKGBUILD?  Or would that not work?  I've never edited any PKGBUILD's so I'm lost.

Thanks!

Offline

#2 2018-05-29 14:07:14

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 568
Website

Re: Brother MFC-J870DW Support

Yes. You change 'lib32-glibc' to 'glibc' in the dependencies and add 'i686' to the 'arch' field.

Offline

#3 2018-05-29 14:09:33

vaprovo
Member
Registered: 2018-05-29
Posts: 2

Re: Brother MFC-J870DW Support

Ok cool, thank you so much!

Offline

#4 2018-05-29 14:14:32

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 568
Website

Re: Brother MFC-J870DW Support

On second view into the package itself:

arch=('i686' 'x86_64')
depends_x86_64=('lib32-glibc')

So the depends on lib32-glibc is only there for 64-bit and will be ignored if built on 32-bit.
So actually, you don't have to edit anything. :-)

Offline

Board footer

Powered by FluxBB