You are not logged in.

#1 2018-05-29 17:55:22

black-clover
Member
Registered: 2018-05-29
Posts: 6

Systemd module loading error

Hi everybody, here's the issue.
I have installed two identical Archlinux 32 in two partitions of the same laptop Compaq C500, and got in both the identical issue.
After installing the system and using netctl and wifi-menu to successfully connect several times automatically at boot, all of a sudden I got the error message at boot ... a start  job is running sys-subsystem-net-devices-wlan0.device.
I checked the various solution posted in different places and got rid of the error message once.
Then I got it again, so I tried to remove and reinstall nectl of the b43-firmware-classic module but the error persisted.
Note that once I log in after the 1:30 seconds usual delay (and of course wifi-menu does not connect at boot) I can connect loading the b43 module manually with modprobe and then running wifi-menu.
Therefore, I guess, the problem lies with something that changed installing some software and which impedes the b43 to be found by netctl at boot, which in turn prevents nectl to work and thus the delay error message.
This seems confirmed by netctl status:

● netctl@wlan0\x2dDepa\x202.service - Automatically generated profile by wifi-menu
   Loaded: loaded (/etc/systemd/system/netctl@wlan0\x2dDepa\x202.service; enabled; vendor preset: d>
   Active: inactive (dead)
     Docs: man:netctl.profile(5)

May 28 22:21:34 mac systemd[1]: Dependency failed for Automatically generated profile by wifi-menu.
May 28 22:21:34 mac systemd[1]: netctl@wlan0\x2dDepa\x202.service: Job netctl@wlan0\x2dDepa\x202.se>
lines 1-7/7 (END)

and also by the fact that lsmod does not show the module being loaded after booting as before.
here is some further info:

$ ls /etc/systemd/system
 display-manager.service   multi-user.target.wants
 getty.target.wants       'netctl@wlan0\x2dDepa\x202.service'
$ ls /etc/systemd/system/multi-user.target.wants
'netctl@wlan0\x2dDepa\x202.service'   remote-fs.target

Linux archtest 4.16.6-1.0-ARCH #1 SMP PREEMPT Wed May 2 23:35:27 CEST 2018 i686 GNU/Linux

By the way, I use nectl and wifi-menu on Manajro 32 on the same laptop and this hasn't happened.
How could I proceed to detect the cause and solve the problem?

Offline

Board footer

Powered by FluxBB