You are not logged in.

#1 2018-06-14 11:21:20

Sometwo
Member
Registered: 2018-06-14
Posts: 2

Qt library error

Hello all,

After installing akonadi and kmail, when trying to start kmail I get

Cannot mix incompatible Qt library (version 0x50a01) with this library (version 0x50b00)

Full output
Output of ldd /bin/kmail
Output of ldd /bin/akonadiserver

Both kmail and akonadi version is 18.04.1-1.0 and everything is up-to-date. Haven't done any partial upgrades, nor am I using the testing repos.

Seems like something is not built with the correct Qt libraries but what?

Offline

#2 2018-06-14 15:56:05

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: Qt library error

qt5-base 5.11.0-1.0
qt5-declarative 5.11.0-1.0
qt5-graphicaleffects 5.11.0-1.0
qt5-location 5.11.0-1.0
qt5-multimedia 5.11.0-1.0
qt5-quickcontrols 5.11.0-1.0
qt5-quickcontrols2 5.11.0-1.0
qt5-script 5.11.0-2.0
qt5-sensors 5.11.0-1.0
qt5-speech 5.11.0-1.0
qt5-svg 5.11.0-1.0
qt5-tools 5.11.0-1.0
qt5-webchannel 5.11.0-1.0
qt5-webengine 5.10.1-1.0
qt5-webkit 5.212.0alpha2-14.0
qt5-x11extras 5.11.0-1.0
qt5-xmlpatterns 5.11.0-1.0

qt5-webengine and qt5-webkit had issues, qt5-webkit builds now and is available in testing.
qt5-webengine still has a weird issue around QtDesigner plugins, which I don't understand (yet).

Offline

#3 2018-06-14 15:59:21

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: Qt library error

maybe also some kde libraries are not up to date.. we are behind with roughly 800 packages to be built..

Offline

#4 2018-06-14 17:26:02

Sometwo
Member
Registered: 2018-06-14
Posts: 2

Re: Qt library error

Good to know and thank you for your reply.

I have noticed that because of the occasional improper or just delayed build, sometimes what should be a full upgrade results in a somewhat partial one. Of course, I completely understand the lack of manpower (or any other power needed) and everything but I think there should be way for users to know what packages are behind schedule, so that we can delay doing an upgrade on our end. For me personally, a simple list of "packages needing rebuild" would suffice.

I'm saying this because especially people coming from Arch "proper" would not expect library mismatches and all that when doing an upgrade and it may lead to frustration.

Offline

#5 2018-06-14 21:55:01

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 608

Re: Qt library error

In principle, this is what should be caught by staging and testing. (e.g. wrongly linked packages should not be able to move from staging to testing or from testing to stable)
But unfortunately, qt version numbers are (not yet) included in the dependency list, so the automatic package-moving algorithm cannot pay attention to them :-/
I added a todo and probably fix it some time :-)

cheers, deep42thought

Offline

#6 2018-06-19 07:25:21

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: Qt library error

Offline

#7 2018-06-21 21:59:59

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 823
Website

Re: Qt library error

So, kmail should work now in [testing] as qt5-webengine has now the same version as the rest of the Qt libraries.

Offline

Board footer

Powered by FluxBB