You are not logged in.

#1 2018-08-17 16:33:06

eugen-b
Member
Registered: 2017-07-09
Posts: 55

[SOLVED] 'libx264.so=152-32' required by ffmpeg

I wanted to report that I cannot update because of ffmpeg 1:4.0.2-1.0

:: Replace libx264 with testing/x264? [Y/n] 
resolving dependencies...
looking for conflicting packages...
warning: removing 'libx264' from target list because it conflicts with 'x264'
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx264.so=152-32' required by ffmpeg
Error installing repo packages

Last edited by eugen-b (2018-09-01 21:20:39)

Offline

#2 2018-08-18 05:30:30

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Yes, this is currently a problem in testing/staging. I blacklisted libx264 and x264 temporarily on my test machines in order to
still be able to update. We should wait for the current big rebuild to finish, the problem may be sorted out automatically. :-)

Offline

#3 2018-08-18 19:00:43

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 461

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

I just said no to the swap and it went through fine for me.  I just have to remember to swap it over in the future; hopefully pacman -Syu will continue to ask me whether I want to swap it out this time; it has done so far.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#4 2018-08-20 15:46:09

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 461

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

I have raised a bug on the tracker for this: https://bugs.archlinux32.org/index.php? … task_id=49


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2018-08-26 17:20:37

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

This requires a rebuild and a push of all packages using libx264, like ffmpeg.

Offline

#6 2018-08-28 02:33:22

rogerthat
Member
Registered: 2018-08-14
Posts: 48

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

I am getting slightly different (not from the test repo)...

:: Replace libx264 with extra/x264? [Y/n] 

And then the same errors as others. Unable to upgrade.

Last edited by rogerthat (2018-08-28 02:43:09)

Offline

#7 2018-08-28 02:41:14

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 461

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

If it doesn't work, try again and say no the second time.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#8 2018-08-29 20:11:17

Framerius
Member
From: Czech Republic
Registered: 2018-08-29
Posts: 8

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Doesn't work for me. Firstly I get

Replace libx264 with extra/x264? [Y/n]

Answering "Y" produces error

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libx264 breaks dependency 'libx264.so=152-32' required by ffmpeg

Answering "n" raises second question

resolving dependencies...
looking for conflicting packages...
warning: removing 'libx264' from target list because it conflicts with 'x264'
:: x264 and libx264 are in conflict. Remove libx264? [y/N]

answering "y" produces error

error: failed to prepare transaction (could not satisfy dependencies)
:: removing libx264 breaks dependency 'libx264.so=152-32' required by ffmpeg

answering "N" produces error

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: x264 and libx264 are in conflict

Any ideas please?

Offline

#9 2018-08-29 20:39:56

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 461

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Do you have both x264 and libx264 installed somehow?  For me I answered 'y' the first time, that threw up a dependency error, then I was able to re-run it and answer no and it installed fine, so I'm not sure why it's saying you have libx264 and x264 when you answer 'n'.

Do a 'pacman -Qs x264' to show which versions you have installed.  If you have both libx264 and x264, I propose removing x264 because it's not quite ready for the prime time yet.  Issue a 'pacman -Rs x264' to do that (probably with sudo or logging into your root account first) to do that.

Last edited by levi (2018-08-29 20:41:22)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#10 2018-08-29 20:54:54

Framerius
Member
From: Czech Republic
Registered: 2018-08-29
Posts: 8

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

You are right, I have both of them

sudo pacman -Qs x264
local/libx264 2:152.20171224-1.0    Library for encoding H264/AVC video streams (8bit depth)
local/x264 2:152.20171224-2.1    CLI tools for encoding H264/AVC video streams

Problem is that when I try to remove 'pacman -Rs x264'

error: failed to prepare transaction (could not satisfy dependencies)
:: avidemux-qt: removing x264 breaks dependency 'x264'

and with 'pacman -Rs libx264' it is even worse (as expected)

error: failed to prepare transaction (could not satisfy dependencies)
:: avidemux-qt: removing libx264 breaks dependency 'libx264'
:: ffmpeg: removing libx264 breaks dependency 'libx264.so=152-32'
:: mplayer: removing libx264 breaks dependency 'libx264'

Offline

#11 2018-08-29 21:05:52

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 461

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Interesting, I don't know how you did that because they ought to conflict.  You can skip dependecy checks in pacman, but you need to explicitly provide that option as far as I know.

I'm not sure how to resolve the problems with removing packages.  Dependency 'x264' is provided by libx264 so that oughtn't be a problem.  You can try doing a '-R' without the 's' and see if that helps, but I don't know if it will.  You could furthermode try the '-Rd' option which ought to skip dependency checks, but I'd only do that last as it feels a little drastic to me.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#12 2018-08-30 05:44:17

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

I get all confused, I see

./extra/libx264-10bit-2:152.20171224-2.1-i686.pkg.tar.xz
./extra/libx264-all-2:152.20171224-2.1-i686.pkg.tar.xz
./extra/libx264-2:152.20171224-2.1-i686.pkg.tar.xz
./extra/x264-2:155.r0a84d986-2.0-i686.pkg.tar.xz
./extra/libx264-2:152.20171224-2.1-i686.pkg.tar.xz.sig

So, ffmpeg was rebuild, but linked weirdly. I think we have to delete some packages from
the stable repos and keep the right one, then rebuild ffmpeg again.

Currently trying that.

BTW: the right one being 'x264'. :-)

Offline

#13 2018-08-30 05:58:46

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Oi, this mess goes way deeper:

warning: cannot resolve "libx264.so=152-32", a dependency of "ffmpeg"
warning: cannot resolve "libavcodec.so=58-32", a dependency of "x264"
warning: cannot resolve "libx264.so=152-32", a dependency of "ffmpeg"
warning: cannot resolve "libavformat.so=58-32", a dependency of "x264"
warning: cannot resolve "libx264.so=152-32", a dependency of "ffmpeg"
warning: cannot resolve "libavutil.so=56-32", a dependency of "x264"
warning: cannot resolve "libx264.so=152-32", a dependency of "ffmpeg"
warning: cannot resolve "libswscale.so=5-32", a dependency of "x264"

We cannot really cope with renames, it seems.

I try to rebuild all those..

So, ffmpeg depends depends on itself? Or does ffmpeg depend on x264 and x264 on ffmepg?
This package is just a mess!

So I'm fed up: I'm removing x264 for now from ffmpeg.
Can be readded afterwards, when the cycle is broken.

Offline

#14 2018-08-30 09:21:14

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

So, I think, this should be fixed now in stable.
At least I was able to update x264, ffmpeg and mplayer. More packages may depend directly
on x264..

Offline

#15 2018-08-30 11:24:23

rogerthat
Member
Registered: 2018-08-14
Posts: 48

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Can anyone confirm success upgrading?
(I'd like to know before trying on my critical machine.)

Up until now, I was working around by saying "no" to the replace libx264 prompts.
But now, that strategy results in a pacman error:

:: x264 and libx264 are in conflict, Remove libx264? [y/N]

Last edited by rogerthat (2018-08-30 11:47:52)

Offline

#16 2018-08-30 11:28:17

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

What happens, if you press yes there?

Offline

#17 2018-08-30 16:32:31

becoming_i
Member
From: Athens
Registered: 2018-03-10
Posts: 9
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

andreas_baumann wrote:

What happens, if you press yes there?

You can see both scenarios

sudo pacman -Syu
[sudo] password for becoming_i: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace libx264 with extra/x264? [Y/n] n
:: Replace libx264-all with extra/x264? [Y/n] Y    
resolving dependencies...
looking for conflicting packages...
:: x264 and libx264 are in conflict. Remove libx264? [y/N] Y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libx264-all breaks dependency 'libx264-all' required by gst-plugins-ugly
sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace libx264 with extra/x264? [Y/n] n
:: Replace libx264-all with extra/x264? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
:: x264 and libx264 are in conflict. Remove libx264? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: x264 and libx264 are in conflict

Offline

#18 2018-08-30 16:35:11

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Thanks, this means we have more packages which need rebuilding like gst-plugins-ugly.

Offline

#19 2018-08-30 19:46:46

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 461

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

It seems to be working for me, although I don't have gst-plugins-ugly installed, only gst-plugins-good (when I can play even mp3s I stop installing codecs).  Yep, it's got as far as installing packages now so it looks good.

I do have the testing repos enabled on this machines still, fwiw.

Uh, seems to have a problem upgrading fontcache:

( 17/118) upgrading fontconfig                     [#######################] 100%
Rebuilding fontconfig cache...
error: command failed to execute correctly

And it seems to have stalled there.  Hmm, this could be fun.

But at least x264 can be installed now.  This seems to be a different problem to the one this thread is concerning.

Edit: I've just noticed I do have gst-plugins-bad installed (it's just been upgraded), I just don't have gst-plugins-ugly it seems.

Edit2: I killed the lagging pacman -Syu process, deleted the lock file, reran the upgrade (which didn't touch fontconfig, but continued the rest of the installation), then did a pacman -S fontconfig which reinstalled the package better the second time round.  Cannot reproduce this bug, but I think everything's installed good for now.

Last edited by levi (2018-08-30 20:27:35)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#20 2018-08-31 15:19:56

becoming_i
Member
From: Athens
Registered: 2018-03-10
Posts: 9
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

A today's update

sudo pacman -Syyu
[sudo] password for becoming_i: 
:: Synchronizing package databases...
 core                                      178.7 KiB  78.7K/s 00:02 [#####################################] 100%
 extra                                       2.4 MiB  64.7K/s 00:37 [#####################################] 100%
 community                                   5.2 MiB  55.5K/s 01:37 [#####################################] 100%
:: Starting full system upgrade...
:: Replace libx264 with extra/x264? [Y/n] n
:: Replace libx264-all with extra/x264? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: x264 and libx264 are in conflict. Remove libx264? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libx264-all breaks dependency 'libx264-all' required by gst-plugins-ugly
 sudo pacman -Syu 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace libx264 with extra/x264? [Y/n] n
:: Replace libx264-all with extra/x264? [Y/n] n
resolving dependencies...
looking for conflicting packages...
:: x264 and libx264 are in conflict. Remove libx264? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: x264 and libx264 are in conflict
sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace libx264 with extra/x264? [Y/n] y
:: Replace libx264-all with extra/x264? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libx264-all breaks dependency 'libx264-all' required by gst-plugins-ugly

Last edited by becoming_i (2018-08-31 15:20:40)

Offline

#21 2018-08-31 15:28:19

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

I priorized gst-plugins-ugly, but so far it has not been rebuild..

Offline

#22 2018-09-01 17:46:09

becoming_i
Member
From: Athens
Registered: 2018-03-10
Posts: 9
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Everything updated smoothly today, if anyone else does not have issues, can be marked as solved.

Offline

#23 2018-09-01 17:59:40

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 815
Website

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Cool. Thanks for the feedback. :-)

Offline

#24 2018-09-01 21:20:15

eugen-b
Member
Registered: 2017-07-09
Posts: 55

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

Very great! Finally it is resolved! Thank you, @andreas_baumann!

Offline

#25 2018-09-01 21:24:37

rogerthat
Member
Registered: 2018-08-14
Posts: 48

Re: [SOLVED] 'libx264.so=152-32' required by ffmpeg

We should say "yes" to replace, right?

Offline

Board footer

Powered by FluxBB