You are not logged in.

#1 2018-09-07 20:48:33

archlinux32forever
Member
Registered: 2018-05-21
Posts: 16

[SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

Hi

Upgrading system today I get this error:

[ ~]$ LC_ALL=C sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency of "speech-dispatcher"
:: The following package cannot be upgraded due to unresolvable dependencies:
      speech-dispatcher

:: Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libspeechd=0.8.8-2.0' required by speech-dispatcher
[ ~]$ 

Regards

Last edited by archlinux32forever (2018-09-08 19:12:43)

Offline

#2 2018-09-07 21:43:19

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 347

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

FWIW, libspeechd 0.8.8-2.0 is available in the testing repo, so hopefully can be promoted to stable without too much trouble (it claims to have no dependencies downstream).

Last edited by levi (2018-09-07 21:43:39)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2018-09-08 09:48:26

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 700
Website

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

Fixed that one. Moved manually to stable. I tested by installing 'orca' (which needs all the packages mentioned above).

Offline

#4 2018-09-08 16:52:21

archlinux32forever
Member
Registered: 2018-05-21
Posts: 16

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

I upgraded complete system without any error, but now I get an error trying to execute firefox:

[ ~]$ firefox 
XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
libicui18n.so.61: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
[ ~]$ 

I think that upgrade system gives a lot of issues. I know that is a complex task, but the system for me is  unstable. Just now, I don't know how many issues I will have.

You can ask the way the x86_64 team do it and do it in the same way. I don't have issues upgrading system with my x86_64 PC.

Regards

Last edited by archlinux32forever (2018-09-08 16:53:27)

Offline

#5 2018-09-08 17:05:12

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 347

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

Looks like your firefox is looking for outdated libs there.  Firefox not updating is a known issue for now; you either have to roll your own workaround, or use a different browser for now it seems.  I'm currently using timsong's PKGBUILDS to package up the prebuild mozilla provided bins; at the time of writing, use this PKGBUILD (create a new folder in your ~/builds directory called 'firefox' or something, make a file called PKGBUILD in there containing the pasted contents of timsong's code area, then follow the normal rules for building source packages)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#6 2018-09-08 17:10:42

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 700
Website

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

Or take my 'firefox-bin' and 'thunderbird-bin' from the AUR. :-)

We are currently trying to build firefox, thunderbird, firefox-developer-edition but we always run out
of virtual address space either in the locally bundled (yuck!) gold linker or in the rust compiler itself.
To me it's a total miracle, how Mozilla builds the software for 32-bit..

Building for 64-bit and 32-bit has differences, it's not just copying the PKBUILD from the 64-bit version,
otherwise Archlinux32 would hardly be necessary. :-)

Offline

#7 2018-09-08 17:13:42

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 700
Website

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

@archlinux32forever: a word from me in the role of moderator: please open a new topic, don't just append a completly unrelated error to an existing error.

Offline

#8 2018-09-08 18:07:37

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 347

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

andreas_baumann wrote:

Or take my 'firefox-bin' and 'thunderbird-bin' from the AUR. :-)

Thanks; this one, I presume.  Doing a 'git pull' is certainly preferable to doing a copy and paste from a forum posting to me

To my reading of this thread, the opened issue has now been solved.  Can you (ss a mod) mark the thread as solved, or is it required or preferable for the OP to do it?


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#9 2018-09-08 19:11:04

archlinux32forever
Member
Registered: 2018-05-21
Posts: 16

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

Thanks a lot!

I installed firefox-bin from AUR and now it works!

@andreas_baumann: Sorry for don't open new topic.

Offline

#10 2018-09-08 19:11:34

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 700
Website

Re: [SOLVED] warning: cannot resolve "libspeechd=0.8.8-2.0", a dependency

easy :-)
happy it works.

Offline

Board footer

Powered by FluxBB