You are not logged in.

#1 2018-09-28 21:52:04

mesxwo
Member
Registered: 2018-09-28
Posts: 2

PulseAudio no sound

After fresh archlinux installation i downloaded pulseaudio, pulseaudio-alsa. Trying to get sound from my laptop i have used:

speaker-test -c 2

and got this:  (no error messages)

speaker-test 1.1.6

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
0 - Front Left
1 - Front Right
Time per period = 10,993014
0 - Front Left
^C 1 - Front Right
Time per period = 5,509419

alsamixer is not muted

no error messages in pulseaudio -vv

no error messages after manually turning on and off pulseaudio

(there was XP installed on that lapotp and speakers were working)


so everything looks fine to me but still there is no sound from speakers during speaker-test and in apps like chromium etc.
any ideas?

Offline

#2 2018-09-28 22:28:29

levi
Member
From: UK
Registered: 2018-06-16
Posts: 131

Re: PulseAudio no sound

What does aplay -L give you?  You may need to configure pulseaudio to use the right device, but unfortunately at present I'm not able to remember what i did to configure mine when i changed the audio device I was using the last time.

Offline

#3 2018-09-29 09:16:56

mesxwo
Member
Registered: 2018-09-28
Posts: 2

Re: PulseAudio no sound

levi wrote:

What does aplay -L give you?  You may need to configure pulseaudio to use the right device, but unfortunately at present I'm not able to remember what i did to configure mine when i changed the audio device I was using the last time.

[mesxwo@aspire ~]$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=Intel
    HDA Intel, ALC883 Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, ALC883 Analog
    Front speakers
surround21:CARD=Intel,DEV=0
    HDA Intel, ALC883 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, ALC883 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, ALC883 Analog                                                                                                 
    4.1 Surround output to Front, Rear and Subwoofer speakers                                                               
surround50:CARD=Intel,DEV=0                                                                                                 
    HDA Intel, ALC883 Analog                                                                                                 
    5.0 Surround output to Front, Center and Rear speakers                                                                   
surround51:CARD=Intel,DEV=0                                                                                                 
    HDA Intel, ALC883 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, ALC883 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
    HDA Intel, ALC883 Digital
    IEC958 (S/PDIF) Digital Audio Output

and this is asound.conf

# Use PulseAudio by default
pcm.!default {
  type pulse
  fallback "sysdefault"
  hint {
    show on
    description "Default ALSA Output (currently PulseAudio Sound Server)"
  }
}

ctl.!default {
  type pulse
  fallback "sysdefault"
}

# vim:set ft=alsaconf:

Offline

#4 2018-09-29 19:10:49

levi
Member
From: UK
Registered: 2018-06-16
Posts: 131

Re: PulseAudio no sound

Ah, it seems I wrote a .asoundrc when I first started using this plug-in USB sound card in preference to the broken internal sound, but that was before I repartitioned this machine and rebuilt my home folder from a backup.  I can only find a .asoundrc in the remains of the backup, but it seems it's just working at present.

Here's the .asoundrc I did used to use:

pcm.copy {
type plug
slave {
pcm hw
}
route_policy copy
}

No idea where I got that from.  I've a vague recollection I added the slave section, but I'm really not too clear on what I did.

Looks like this build I got mplayer to work using my .mplayer/config file:

# Write your default config options here!
stop-xscreensaver=1
ao=pulse
nolirc=1

Stop-xscreensaver doesn't work for me, and the nolirc line is just to stop mplayer moaning about remote controls every time I start it IIRC.  ao=pulse is the line you want.

Also, claws-mail seems to bing at me regardless.  I guess pulseaudio support is baked in there.

If you're sure you're using pulseaudio and you're getting no sound, use 'pavucontrol' and scroll the tab bar all the way to the right to get to the 'configuration' tab where you can pick the hardware device to use.   I don't know where that stores it's settings off hand, so I don't know if I used it initially to get pulse to work.

Offline

Board footer

Powered by FluxBB