You are not logged in.

#1 2018-09-02 07:27:15

Framerius
Member
From: Czech Republic
Registered: 2018-08-29
Posts: 8

[Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Hello, by trying to update by "sudo pacman -Syu" I'm receiving the following warning:

warning: cannot resolve "protobuf=3.6.0.1", a dependency of "python-protobuf"
:: The following package cannot be upgraded due to unresolvable dependencies:
      python-protobuf

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'protobuf=3.6.0.1' required by python-protobuf

By selecting "y" package is skipped and I can upgrade other ones without any problem.

In order to provide more informations:

sudo pacman -Q |grep protobuf
protobuf 3.5.2-1.0
protobuf-c 1.3.0-2.0
python-protobuf 3.5.2-1.0

Last edited by Framerius (2018-12-02 09:26:40)

Offline

#2 2018-09-02 08:09:51

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 661
Website

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Aha. python-protobuf is linked against 3.6.0.1, protobuf in stable is protobuf-3.5.2. So protobuf must be pushed to stable.

Offline

#3 2018-09-02 17:08:26

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 661
Website

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Aeh. I have to force rebuild of python-protobuf. This one is still the old one.

Offline

#4 2018-09-21 20:33:44

Framerius
Member
From: Czech Republic
Registered: 2018-08-29
Posts: 8

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Any update on this topic? On my system the issue is still valid.

Offline

#5 2018-09-22 02:37:12

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 326

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Looks to me like protobuf 6.0 still needs to be pushed from testing.  I dunno if it works though; I have it installed from installing pidgin I think, but I don't knowingly use it.  I think I stopped using pidgin before this update (I've switched to weechat these days), but it at least installs.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#6 2018-10-28 08:40:16

Framerius
Member
From: Czech Republic
Registered: 2018-08-29
Posts: 8

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Another month have passed and I still see the warning message about the protobuf package every time I'm updating my system. Have I missed something?

Offline

#7 2018-10-28 17:35:08

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 326

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

I've raised this on the bug tracker, so it's less likely to get lost in the traffic than here: https://bugs.archlinux32.org/index.php? … task_id=55

In an ideal world, more of these things would be raised directly on the bug tracker, but the problem is even after you register for an account you need to badger the team to be able to raise bugs (last time I checked at least).  I'm not sure if you can even watch a task without elevated privileges.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#8 2018-10-29 11:35:40

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 404

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

I moved the respective packages - can you check if the problem persist on your end?

Offline

#9 2018-10-29 13:25:19

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 661
Website

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Thanks for moving: I can confirm on stable protobuf 3.6.1-1.4 and python-protobuf 3.6.1-1.4

Offline

#10 2018-11-22 08:30:03

Framerius
Member
From: Czech Republic
Registered: 2018-08-29
Posts: 8

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Hello again,

it has been working for a while but now I have this error message when trying to update the system:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing protobuf (3.6.1-1.4) breaks dependency 'protobuf=3.6.0.1' required by python-protobuf

It completely blocks me from any updating. Shall I raise it on a bug tracer?

Offline

#11 2018-11-22 08:31:14

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 404

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

I'll look into it.

Offline

#12 2018-11-22 08:34:09

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 404

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

python-protobuf 3.6.1-1.4 is now in [extra]

Offline

#13 2018-11-22 21:05:49

Framerius
Member
From: Czech Republic
Registered: 2018-08-29
Posts: 8

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

Working perfectly, thank you.

Offline

#14 2018-11-22 22:38:46

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 404

Re: [Solved]cannot resolve "protobuf=3.6.0.1", a dependency of "python-p..

can you change the title of the thread to [solved], then, please?

regards,
deep42thought

Offline

Board footer

Powered by FluxBB