You are not logged in.

#1 2018-10-29 07:37:54

timsong
Member
Registered: 2018-04-03
Posts: 29

vlc broken because of libidn

Just performed a pacman -Syu this morning and vlc is still not running. Again I ask, Why are packages being upgraded on the mirrors without all their dependancies being met ? Crazy system.

[tim@oldlaptop ~]$ sudo pacman -Syu
:: Synchronising package databases...
 core                     177.4 KiB   739K/s 00:00 [######################] 100%
 extra                      2.3 MiB   747K/s 00:03 [######################] 100%
 community                  5.4 MiB   753K/s 00:07 [######################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (92) acl-2.2.53-1.3  argon2-20171227-3.3  attica-5.50.0-1.0
              attr-2.4.48-1.3  automake-1.16.1-1.0  bzip2-1.0.6-8.6
              coreutils-8.30-1.5  cracklib-2.9.6-1.4  cryptsetup-2.0.4-1.4
              device-mapper-2.02.181-1.5  docbook-xml-4.5-8.0
              docbook-xsl-1.79.2-4.1  emovix-0.9.0-7.1  fribidi-1.0.5-1.2
              gawk-4.2.1-1.5  gtk-doc-1.29-1.1  intltool-0.51.0-3.2
              java-environment-common-3-1.2  java-runtime-common-3-1.2
              karchive-5.50.0-1.0  kauth-5.50.0-1.1  kbookmarks-5.50.0-1.1
              kcmutils-5.50.0-1.1  kcodecs-5.50.0-1.1  kcompletion-5.50.0-1.1
              kconfig-5.50.0-1.1  kconfigwidgets-5.50.0-1.1
              kcoreaddons-5.50.0-1.1  kcrash-5.50.0-1.1  kdbusaddons-5.50.0-1.1
              kdeclarative-5.50.0-1.1  kdewebkit-5.50.0-1.1
              kfilemetadata-5.50.0-1.1  kglobalaccel-5.50.0-1.1
              kguiaddons-5.50.0-1.1  ki18n-5.50.0-1.1  kiconthemes-5.50.0-1.1
              kio-5.50.0-1.1  kitemviews-5.50.0-1.1  kjobwidgets-5.50.0-1.1
              knewstuff-5.50.0-1.1  knotifications-5.50.0-1.1
              knotifyconfig-5.50.0-1.1  kpackage-5.50.0-1.1  kparts-5.50.0-1.1
              kservice-5.50.0-1.1  ktextwidgets-5.50.0-1.1  kwallet-5.50.0-1.1
              kwidgetsaddons-5.50.0-1.1  kwindowsystem-5.50.0-1.1
              kxmlgui-5.50.0-1.1  lcms2-2.9-1.2  ldns-1.7.0-4.3  less-530-1.5
              libavc1394-0.5.4-3.2  libcap-2.25-1.4  libdrm-2.4.96-1.0
              libgpg-error-1.32-1.3  libiec61883-1.2.0-5.2  libksba-1.3.5-1.2
              libmp4v2-2.0.0-5.2  libnl-3.4.0-1.3  libpipeline-1.5.0-1.4
              libtasn1-4.13-1.3  libusb-1.0.22-1.5  libutf8proc-2.2.0-1.1
              libx11-1.6.7-1.0  libxmu-1.1.2-2.2  libxpm-3.5.12-1.2
              lua-5.3.5-1.2  lvm2-2.02.181-1.5  lzop-1.04-1.2  mdadm-4.0-1.10
              mobile-broadband-provider-info-20170310-1.2  ncurses-6.1-4.0
              oxygen-icons-1:5.51.0-1.0  pacman-5.1.1-1.6  pciutils-3.6.1-1.7
              pcre2-10.32-1.0  perl-sub-uplevel-0.2800-2.1
              perl-tree-dag-node-1.31-1.2  perl-xml-namespacesupport-1.12-2.1
              perl-xml-sax-1.00-1.1  perl-xml-sax-base-1.09-2.1
              perl-xml-sax-expat-0.51-5.2  popt-1.16-9.3
              python-packaging-18.0-1.0  python2-packaging-18.0-1.0
              solid-5.50.0-1.1  sonnet-5.50.0-1.1  vlc-3.0.4-1.0
              xorg-docs-1.7.1-2.1

Total Download Size:    93.09 MiB
Total Installed Size:  324.83 MiB
Net Upgrade Size:        2.29 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 attr-2.4.48-1.3-i686      67.0 KiB   744K/s 00:00 [######################] 100%
 acl-2.2.53-1.3-i686      135.7 KiB   754K/s 00:00 [######################] 100%
 argon2-20171227-3.3...    35.5 KiB   709K/s 00:00 [######################] 100%
 ncurses-6.1-4.0-i686    1108.6 KiB   754K/s 00:01 [######################] 100%
 bzip2-1.0.6-8.6-i686      55.1 KiB   788K/s 00:00 [######################] 100%
 libcap-2.25-1.4-i686      39.1 KiB   652K/s 00:00 [######################] 100%
 libgpg-error-1.32-1...   193.0 KiB   622K/s 00:00 [######################] 100%
 libusb-1.0.22-1.5-i686    57.9 KiB   827K/s 00:00 [######################] 100%
 libtasn1-4.13-1.3-i686   120.2 KiB   751K/s 00:00 [######################] 100%
 device-mapper-2.02....   278.9 KiB   715K/s 00:00 [######################] 100%
 popt-1.16-9.3-i686        67.0 KiB   745K/s 00:00 [######################] 100%
 cryptsetup-2.0.4-1....   359.8 KiB   750K/s 00:00 [######################] 100%
 pcre2-10.32-1.0-i686     981.1 KiB   755K/s 00:01 [######################] 100%
 cracklib-2.9.6-1.4-i686  248.5 KiB   753K/s 00:00 [######################] 100%
 libnl-3.4.0-1.3-i686     362.9 KiB   756K/s 00:00 [######################] 100%
 coreutils-8.30-1.5-i686    2.3 MiB   754K/s 00:03 [######################] 100%
 automake-1.16.1-1.0-any  601.4 KiB   752K/s 00:01 [######################] 100%
 gawk-4.2.1-1.5-i686     1052.8 KiB   752K/s 00:01 [######################] 100%
 lvm2-2.02.181-1.5-i686  1364.4 KiB   754K/s 00:02 [######################] 100%
 mdadm-4.0-1.10-i686      442.4 KiB   750K/s 00:01 [######################] 100%
 libksba-1.3.5-1.2-i686   123.2 KiB   770K/s 00:00 [######################] 100%
 ldns-1.7.0-4.3-i686      449.3 KiB   761K/s 00:01 [######################] 100%
 less-530-1.5-i686        107.9 KiB   770K/s 00:00 [######################] 100%
 libpipeline-1.5.0-1...    39.2 KiB   784K/s 00:00 [######################] 100%
 pacman-5.1.1-1.6-i686    763.3 KiB   741K/s 00:01 [######################] 100%
 pciutils-3.6.1-1.7-i686   90.4 KiB   822K/s 00:00 [######################] 100%
 libx11-1.6.7-1.0-i686      2.0 MiB   752K/s 00:03 [######################] 100%
 libdrm-2.4.96-1.0-i686   251.8 KiB   720K/s 00:00 [######################] 100%
 libxmu-1.1.2-2.2-i686     74.4 KiB   826K/s 00:00 [######################] 100%
 attica-5.50.0-1.0-i686   536.0 KiB   755K/s 00:01 [######################] 100%
 docbook-xml-4.5-8.0-any   85.7 KiB   779K/s 00:00 [######################] 100%
 docbook-xsl-1.79.2-...   739.7 KiB   755K/s 00:01 [######################] 100%
 fribidi-1.0.5-1.2-i686    40.4 KiB   674K/s 00:00 [######################] 100%
 python-packaging-18...    31.8 KiB   795K/s 00:00 [######################] 100%
 gtk-doc-1.29-1.1-any     269.4 KiB   748K/s 00:00 [######################] 100%
 intltool-0.51.0-3.2-any   41.3 KiB   688K/s 00:00 [######################] 100%
 java-environment-co...     2.6 KiB  0.00B/s 00:00 [######################] 100%
 java-runtime-common...     5.1 KiB   509K/s 00:00 [######################] 100%
 karchive-5.50.0-1.0...   336.3 KiB   764K/s 00:00 [######################] 100%
 kcoreaddons-5.50.0-...  1022.8 KiB   752K/s 00:01 [######################] 100%
 kauth-5.50.0-1.1-i686    307.2 KiB   768K/s 00:00 [######################] 100%
 kdbusaddons-5.50.0-...   191.1 KiB   764K/s 00:00 [######################] 100%
 kconfig-5.50.0-1.1-i686  925.3 KiB   740K/s 00:01 [######################] 100%
 kwindowsystem-5.50....   578.8 KiB   752K/s 00:01 [######################] 100%
 kcrash-5.50.0-1.1-i686   113.2 KiB   755K/s 00:00 [######################] 100%
 kglobalaccel-5.50.0...   234.3 KiB   756K/s 00:00 [######################] 100%
 kwidgetsaddons-5.50...     3.3 MiB   751K/s 00:05 [######################] 100%
 kcompletion-5.50.0-...   486.4 KiB   685K/s 00:01 [######################] 100%
 ki18n-5.50.0-1.1-i686   1379.2 KiB   746K/s 00:02 [######################] 100%
 kservice-5.50.0-1.1...   668.4 KiB   751K/s 00:01 [######################] 100%
 kcodecs-5.50.0-1.1-i686  334.6 KiB   760K/s 00:00 [######################] 100%
 kguiaddons-5.50.0-1...   238.3 KiB   701K/s 00:00 [######################] 100%
 kconfigwidgets-5.50...   827.9 KiB   753K/s 00:01 [######################] 100%
 kitemviews-5.50.0-1...   375.0 KiB   750K/s 00:01 [######################] 100%
 kiconthemes-5.50.0-...   417.0 KiB   732K/s 00:01 [######################] 100%
 sonnet-5.50.0-1.1-i686   474.6 KiB   742K/s 00:01 [######################] 100%
 ktextwidgets-5.50.0...   577.6 KiB   750K/s 00:01 [######################] 100%
 kxmlgui-5.50.0-1.1-i686 1316.4 KiB   752K/s 00:02 [######################] 100%
 kbookmarks-5.50.0-1...   349.8 KiB   729K/s 00:00 [######################] 100%
 solid-5.50.0-1.1-i686    637.4 KiB   750K/s 00:01 [######################] 100%
 kjobwidgets-5.50.0-...   261.6 KiB   769K/s 00:00 [######################] 100%
 knotifications-5.50...   346.3 KiB   770K/s 00:00 [######################] 100%
 kwallet-5.50.0-1.1-i686  507.7 KiB   758K/s 00:01 [######################] 100%
 kio-5.50.0-1.1-i686        6.0 MiB   753K/s 00:08 [######################] 100%
 kpackage-5.50.0-1.1...   335.3 KiB   745K/s 00:00 [######################] 100%
 kdeclarative-5.50.0...   400.5 KiB   756K/s 00:01 [######################] 100%
 kcmutils-5.50.0-1.1...   485.0 KiB   746K/s 00:01 [######################] 100%
 kparts-5.50.0-1.1-i686   791.4 KiB   761K/s 00:01 [######################] 100%
 kdewebkit-5.50.0-1....    68.7 KiB   763K/s 00:00 [######################] 100%
 libavc1394-0.5.4-3....    31.7 KiB   793K/s 00:00 [######################] 100%
 libiec61883-1.2.0-5...    32.9 KiB   658K/s 00:00 [######################] 100%
 lcms2-2.9-1.2-i686       193.4 KiB   774K/s 00:00 [######################] 100%
 kfilemetadata-5.50....   314.7 KiB   749K/s 00:00 [######################] 100%
 knewstuff-5.50.0-1....  1361.7 KiB   752K/s 00:02 [######################] 100%
 libxpm-3.5.12-1.2-i686    52.6 KiB   752K/s 00:00 [######################] 100%
 lua-5.3.5-1.2-i686       247.2 KiB   706K/s 00:00 [######################] 100%
 vlc-3.0.4-1.0-i686        10.5 MiB   747K/s 00:14 [######################] 100%
 knotifyconfig-5.50....   174.9 KiB   760K/s 00:00 [######################] 100%
 libmp4v2-2.0.0-5.2-i686  391.0 KiB   752K/s 00:01 [######################] 100%
 lzop-1.04-1.2-i686        68.5 KiB   761K/s 00:00 [######################] 100%
 mobile-broadband-pr...    41.7 KiB   834K/s 00:00 [######################] 100%
 oxygen-icons-1:5.51...    30.3 MiB   752K/s 00:41 [######################] 100%
 perl-xml-namespaces...    11.8 KiB  1175K/s 00:00 [######################] 100%
 perl-xml-sax-base-1...    23.8 KiB   794K/s 00:00 [######################] 100%
 perl-xml-sax-1.00-1...    41.0 KiB   820K/s 00:00 [######################] 100%
 python2-packaging-1...    31.2 KiB   779K/s 00:00 [######################] 100%
 xorg-docs-1.7.1-2.1-any  195.2 KiB   751K/s 00:00 [######################] 100%
 emovix-0.9.0-7.1-any       9.7 MiB   751K/s 00:13 [######################] 100%
 libutf8proc-2.2.0-1...    55.3 KiB   790K/s 00:00 [######################] 100%
 perl-sub-uplevel-0....    11.0 KiB  1099K/s 00:00 [######################] 100%
 perl-tree-dag-node-...    50.1 KiB   835K/s 00:00 [######################] 100%
 perl-xml-sax-expat-...     8.6 KiB   430K/s 00:00 [######################] 100%
(92/92) checking keys in keyring                   [######################] 100%
(92/92) checking package integrity                 [######################] 100%
(92/92) loading package files                      [######################] 100%
(92/92) checking for file conflicts                [######################] 100%
(92/92) checking available disk space              [######################] 100%
:: Processing package changes...
( 1/92) upgrading attr                             [######################] 100%
( 2/92) upgrading acl                              [######################] 100%
( 3/92) upgrading argon2                           [######################] 100%
( 4/92) upgrading ncurses                          [######################] 100%
( 5/92) upgrading bzip2                            [######################] 100%
( 6/92) upgrading libcap                           [######################] 100%
( 7/92) upgrading libgpg-error                     [######################] 100%
( 8/92) upgrading libusb                           [######################] 100%
( 9/92) upgrading libtasn1                         [######################] 100%
(10/92) upgrading libx11                           [######################] 100%
(11/92) upgrading libdrm                           [######################] 100%
(12/92) upgrading device-mapper                    [######################] 100%
(13/92) upgrading popt                             [######################] 100%
(14/92) upgrading cryptsetup                       [######################] 100%
(15/92) upgrading pcre2                            [######################] 100%
(16/92) upgrading cracklib                         [######################] 100%
(17/92) upgrading libnl                            [######################] 100%
(18/92) upgrading coreutils                        [######################] 100%
(19/92) upgrading libxmu                           [######################] 100%
(20/92) upgrading attica                           [######################] 100%
(21/92) upgrading automake                         [######################] 100%
(22/92) upgrading docbook-xml                      [######################] 100%
(23/92) upgrading docbook-xsl                      [######################] 100%
(24/92) upgrading emovix                           [######################] 100%
(25/92) upgrading fribidi                          [######################] 100%
(26/92) upgrading gawk                             [######################] 100%
(27/92) upgrading python-packaging                 [######################] 100%
(28/92) upgrading gtk-doc                          [######################] 100%
(29/92) upgrading intltool                         [######################] 100%
(30/92) upgrading java-environment-common          [######################] 100%
(31/92) upgrading java-runtime-common              [######################] 100%
(32/92) upgrading karchive                         [######################] 100%
(33/92) upgrading kcoreaddons                      [######################] 100%
(34/92) upgrading kauth                            [######################] 100%
(35/92) upgrading kdbusaddons                      [######################] 100%
(36/92) upgrading kconfig                          [######################] 100%
(37/92) upgrading kwindowsystem                    [######################] 100%
(38/92) upgrading kcrash                           [######################] 100%
(39/92) upgrading kglobalaccel                     [######################] 100%
(40/92) upgrading kwidgetsaddons                   [######################] 100%
(41/92) upgrading kcompletion                      [######################] 100%
(42/92) upgrading ki18n                            [######################] 100%
(43/92) upgrading kservice                         [######################] 100%
(44/92) upgrading kcodecs                          [######################] 100%
(45/92) upgrading kguiaddons                       [######################] 100%
(46/92) upgrading kconfigwidgets                   [######################] 100%
(47/92) upgrading kitemviews                       [######################] 100%
(48/92) upgrading kiconthemes                      [######################] 100%
New optional dependencies for kiconthemes
    breeze-icons: fallback icon theme
(49/92) upgrading sonnet                           [######################] 100%
(50/92) upgrading ktextwidgets                     [######################] 100%
(51/92) upgrading kxmlgui                          [######################] 100%
(52/92) upgrading kbookmarks                       [######################] 100%
(53/92) upgrading lvm2                             [######################] 100%
(54/92) upgrading mdadm                            [######################] 100%
(55/92) upgrading libksba                          [######################] 100%
(56/92) upgrading solid                            [######################] 100%
(57/92) upgrading kjobwidgets                      [######################] 100%
(58/92) upgrading knotifications                   [######################] 100%
(59/92) upgrading kwallet                          [######################] 100%
(60/92) upgrading kio                              [######################] 100%
(61/92) upgrading kpackage                         [######################] 100%
(62/92) upgrading kdeclarative                     [######################] 100%
(63/92) upgrading kcmutils                         [######################] 100%
(64/92) upgrading kparts                           [######################] 100%
(65/92) upgrading kdewebkit                        [######################] 100%
(66/92) upgrading libavc1394                       [######################] 100%
(67/92) upgrading libiec61883                      [######################] 100%
(68/92) upgrading lcms2                            [######################] 100%
(69/92) upgrading kfilemetadata                    [######################] 100%
(70/92) upgrading knewstuff                        [######################] 100%
(71/92) upgrading libxpm                           [######################] 100%
(72/92) upgrading lua                              [######################] 100%
(73/92) upgrading vlc                              [######################] 100%
New optional dependencies for vlc
    aribb24: ARIB subtitles
    x264: H264 encoding [installed]
(74/92) upgrading knotifyconfig                    [######################] 100%
(75/92) upgrading ldns                             [######################] 100%
(76/92) upgrading less                             [######################] 100%
(77/92) upgrading libmp4v2                         [######################] 100%
(78/92) upgrading libpipeline                      [######################] 100%
(79/92) upgrading libutf8proc                      [######################] 100%
(80/92) upgrading lzop                             [######################] 100%
(81/92) upgrading mobile-broadband-provider-info   [######################] 100%
(82/92) upgrading oxygen-icons                     [######################] 100%
(83/92) upgrading pacman                           [######################] 100%
(84/92) upgrading pciutils                         [######################] 100%
(85/92) upgrading perl-sub-uplevel                 [######################] 100%
(86/92) upgrading perl-tree-dag-node               [######################] 100%
(87/92) upgrading perl-xml-namespacesupport        [######################] 100%
(88/92) upgrading perl-xml-sax-base                [######################] 100%
(89/92) upgrading perl-xml-sax                     [######################] 100%
(90/92) upgrading perl-xml-sax-expat               [######################] 100%
(91/92) upgrading python2-packaging                [######################] 100%
(92/92) upgrading xorg-docs                        [######################] 100%
:: Running post-transaction hooks...
( 1/10) Updating linux-lts initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 4.14.70-1.0-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 4.14.70-1.0-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
==> Image generation successful
( 2/10) Updating icon theme caches...
( 3/10) Reloading system manager configuration...
( 4/10) Creating temporary files...
( 5/10) Reloading device manager configuration...
( 6/10) Arming ConditionNeedsUpdate...
( 7/10) Updating the info directory file...
( 8/10) Updating the desktop file MIME type cache...
( 9/10) Updating the MIME type database...
(10/10) Updating the vlc plugin cache...
/usr/lib/vlc/vlc-cache-gen: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory
error: command failed to execute correctly
[tim@oldlaptop ~]$ vlc
vlc: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory
[tim@oldlaptop ~]$ 

Last edited by timsong (2018-10-29 07:58:22)

Offline

#2 2018-10-29 11:17:17

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 436

Re: vlc broken because of libidn

Some words in our defense:
vlc is already scheduled and needs to be built, but is blocked due to "broken" libxml2 (see archlinux' bug 60381) - which was fixed in trunk and is now in x86_64's staging (e.g. the build system won't see it, because it builds the packages from core/extra/community).
With this in mind, the answer to your question "Why are packages being upgraded on the mirrors without all their dependancies being met ?" is simple: so we can update packages at all (have a look at the dependency nightmare created by haskell packages).
Give us a few more hands (maybe 4?) and we can look into all issues manually. Then we might be able to upgrade packages w/o breaking dependencies (besides haskell dependencies - they're probably beyond all hope) smile

Something else to think about:
Upstream (= archlinux for x86_64) does not officially support partial upgrades.
So in order to make the packages built by the build system as good as the x86_64 packages, we'd need to build the exact same packages in the exact same order as upstream does - which we can't because, some packages simply don't build on i686 - or we need to fix them manually which would block all packages that upstream built at a later time ...

regards,
deep42thought

Offline

#3 2018-11-03 18:15:00

timsong
Member
Registered: 2018-04-03
Posts: 29

Re: vlc broken because of libidn

Could you let me know when it is safe to do pacman -Syu please ?

Offline

#4 2018-11-04 09:37:00

archlinux32forever
Member
Registered: 2018-05-21
Posts: 16

Re: vlc broken because of libidn

I have similar problem today:

[user@user ~]$ LC_ALL=C sudo pacman -Syu
[sudo] password for user: 
:: Synchronizing package databases...
 core                                              176.6 KiB   441K/s 00:00 [###########################################] 100%
 extra                                               2.3 MiB  1362K/s 00:02 [###########################################] 100%
 community                                           5.4 MiB  1531K/s 00:04 [###########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (94) acl-2.2.53-1.3  alsa-lib-1.1.6-1.2  alsa-utils-1.1.6-1.1  apache-2.4.37-1.0  archlinux-keyring-20181031-1.0
              argon2-20171227-3.3  attr-2.4.48-1.3  automake-1.16.1-1.0  bc-1.07.1-1.3  bzip2-1.0.6-8.6  cairo-1.15.14-1.0
              chmlib-0.40-5.2  coreutils-8.30-1.5  cracklib-2.9.6-1.4  cryptsetup-2.0.4-1.4  device-mapper-2.02.181-1.5
              exempi-2.4.5-1.2  file-5.35-1.0  fribidi-1.0.5-1.2  gawk-4.2.1-1.5  geoclue2-2.4.12-1.1  geoip-1.6.12-1.2
              ghostscript-9.25-4.0  gnome-desktop-1:3.30.1-1.0  gpm-1.20.7.r27.g1fd1941-1.0  gvfs-1.38.1-1.0
              gvfs-mtp-1.38.1-1.0  intltool-0.51.0-3.2  iproute2-4.19.0-1.0  iptables-1:1.8.0-1.0  lcms2-2.9-1.2
              ldns-1.7.0-4.3  less-530-1.5  libavc1394-0.5.4-3.2  libcap-2.25-1.4  libdrm-2.4.96-1.0  libevdev-1.5.9-1.2
              libgpg-error-1.32-1.3  libiec61883-1.2.0-5.2  libksba-1.3.5-1.2  libmp4v2-2.0.0-5.2
              libnetfilter_acct-1.0.3-1.2  libnl-3.4.0-1.3  libpipeline-1.5.0-1.4  libsigc++-2.10.0-1.1  libtasn1-4.13-1.3
              libusb-1.0.22-1.5  libutf8proc-2.2.0-1.1  libx11-1.6.7-1.0  libxmu-1.1.2-2.2  libxnvctrl-410.57-2.0
              libxpm-3.5.12-1.2  linux-4.18.16.arch1-1.0  linux-firmware-20181018.d877533-1.0  lua-5.3.5-1.2
              lvm2-2.02.181-1.5  lynx-2.8.9-2.0  mate-icon-theme-1.20.2-1.0  mdadm-4.0-1.10  menumaker-0.99.10-1.2
              mkinitcpio-24-3.0  ncurses-6.1-4.0  pacman-5.1.1-1.6  parted-3.2-7.0  pciutils-3.6.1-1.7  pcre2-10.32-1.0
              perl-clone-0.41-1.0  perl-error-0.17027-1.0  perl-xml-namespacesupport-1.12-2.1  perl-xml-sax-1.00-1.1
              perl-xml-sax-base-1.09-2.1  pkgconf-1.5.3-1.3  podofo-0.9.6-2.0  popt-1.16-9.3  protobuf-3.6.0.1-1.1
              python-3.7.1-1.0  python-packaging-18.0-1.0  python-setuptools-1:40.5.0-1.0  python2-mechanize-1:0.3.7-1.0
              python2-packaging-18.0-1.0  python2-setuptools-1:40.5.0-1.0  qt5-webkit-5.212.0alpha2-20.0  sdl2-2.0.8-10.0
              sgml-common-0.6.3-5.1  upower-0.99.9-1.0  v4l-utils-1.16.0-1.0  valgrind-3.14.0-1.0  vlc-3.0.4-1.0
              vte-common-0.54.1-1.0  vte3-0.54.1-1.0  webkit2gtk-2.22.2-1.0  x11-ssh-askpass-1.2.4.1-6.1
              xf86-video-intel-1:2.99.917+847+g25c9a2fc-1.0  xfsprogs-4.18.0-1.0

Total Download Size:    313.87 MiB
Total Installed Size:  1206.36 MiB
Net Upgrade Size:       140.95 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 attr-2.4.48-1.3-i686                               67.0 KiB   268K/s 00:00 [###########################################] 100%
 acl-2.2.53-1.3-i686                               135.7 KiB   969K/s 00:00 [###########################################] 100%
 ncurses-6.1-4.0-i686                             1108.6 KiB  1179K/s 00:01 [###########################################] 100%
 pciutils-3.6.1-1.7-i686                            90.4 KiB  1507K/s 00:00 [###########################################] 100%
 libcap-2.25-1.4-i686                               39.1 KiB  3.82M/s 00:00 [###########################################] 100%
 coreutils-8.30-1.5-i686                             2.3 MiB  1286K/s 00:02 [###########################################] 100%
 libgpg-error-1.32-1.3-i686                        193.0 KiB   772K/s 00:00 [###########################################] 100%
 cracklib-2.9.6-1.4-i686                           248.5 KiB  1036K/s 00:00 [###########################################] 100%
 bzip2-1.0.6-8.6-i686                               55.1 KiB  2.69M/s 00:00 [###########################################] 100%
 archlinux-keyring-20181031-1.0-any                616.1 KiB  1120K/s 00:01 [###########################################] 100%
 argon2-20171227-3.3-i686                           35.5 KiB  3.46M/s 00:00 [###########################################] 100%
 automake-1.16.1-1.0-any                           601.4 KiB   955K/s 00:01 [###########################################] 100%
 device-mapper-2.02.181-1.5-i686                   278.9 KiB   996K/s 00:00 [###########################################] 100%
 popt-1.16-9.3-i686                                 67.0 KiB  2.18M/s 00:00 [###########################################] 100%
 cryptsetup-2.0.4-1.4-i686                         359.8 KiB   800K/s 00:00 [###########################################] 100%
 file-5.35-1.0-i686                                287.0 KiB   700K/s 00:00 [###########################################] 100%
 gawk-4.2.1-1.5-i686                              1052.8 KiB   993K/s 00:01 [###########################################] 100%
 libtasn1-4.13-1.3-i686                            120.2 KiB  1092K/s 00:00 [###########################################] 100%
 libusb-1.0.22-1.5-i686                             57.9 KiB  1930K/s 00:00 [###########################################] 100%
 libnl-3.4.0-1.3-i686                              362.9 KiB  1037K/s 00:00 [###########################################] 100%
 iptables-1:1.8.0-1.0-i686                         372.9 KiB  1008K/s 00:00 [###########################################] 100%
 pcre2-10.32-1.0-i686                              981.1 KiB  1022K/s 00:01 [###########################################] 100%
 gpm-1.20.7.r27.g1fd1941-1.0-i686                  132.0 KiB  1100K/s 00:00 [###########################################] 100%
 lvm2-2.02.181-1.5-i686                           1364.4 KiB  1083K/s 00:01 [###########################################] 100%
 mdadm-4.0-1.10-i686                               442.4 KiB   983K/s 00:00 [###########################################] 100%
 xfsprogs-4.18.0-1.0-i686                          988.6 KiB   924K/s 00:01 [###########################################] 100%
 libksba-1.3.5-1.2-i686                            123.2 KiB  1120K/s 00:00 [###########################################] 100%
 iproute2-4.19.0-1.0-i686                          864.2 KiB  1067K/s 00:01 [###########################################] 100%
 ldns-1.7.0-4.3-i686                               449.3 KiB  1152K/s 00:00 [###########################################] 100%
 less-530-1.5-i686                                 107.9 KiB  1541K/s 00:00 [###########################################] 100%
 libpipeline-1.5.0-1.4-i686                         39.2 KiB  3.83M/s 00:00 [###########################################] 100%
 linux-firmware-20181018.d877533-1.0-any            73.5 MiB  1397K/s 00:54 [###########################################] 100%
 mkinitcpio-24-3.0-any                              40.2 KiB  3.93M/s 00:00 [###########################################] 100%
 linux-4.18.16.arch1-1.0-i686                       59.0 MiB  1361K/s 00:44 [###########################################] 100%
 pacman-5.1.1-1.6-i686                             763.3 KiB  1139K/s 00:01 [###########################################] 100%
 pkgconf-1.5.3-1.3-i686                             55.2 KiB  1840K/s 00:00 [###########################################] 100%
 alsa-lib-1.1.6-1.2-i686                           407.2 KiB  1044K/s 00:00 [###########################################] 100%
 alsa-utils-1.1.6-1.1-i686                         955.8 KiB   956K/s 00:01 [###########################################] 100%
 apache-2.4.37-1.0-i686                           1602.3 KiB  1021K/s 00:02 [###########################################] 100%
 bc-1.07.1-1.3-i686                                 87.7 KiB  1755K/s 00:00 [###########################################] 100%
 libx11-1.6.7-1.0-i686                               2.0 MiB   997K/s 00:02 [###########################################] 100%
 cairo-1.15.14-1.0-i686                            767.0 KiB   935K/s 00:01 [###########################################] 100%
 chmlib-0.40-5.2-i686                               24.7 KiB  2.41M/s 00:00 [###########################################] 100%
 exempi-2.4.5-1.2-i686                             542.6 KiB  1005K/s 00:01 [###########################################] 100%
 fribidi-1.0.5-1.2-i686                             40.4 KiB  2021K/s 00:00 [###########################################] 100%
 geoclue2-2.4.12-1.1-i686                          151.1 KiB  1162K/s 00:00 [###########################################] 100%
 geoip-1.6.12-1.2-i686                              76.3 KiB  1908K/s 00:00 [###########################################] 100%
 lcms2-2.9-1.2-i686                                193.4 KiB  1209K/s 00:00 [###########################################] 100%
 ghostscript-9.25-4.0-i686                          12.5 MiB  1245K/s 00:10 [###########################################] 100%
 libdrm-2.4.96-1.0-i686                            251.8 KiB   513K/s 00:00 [###########################################] 100%
 gnome-desktop-1:3.30.1-1.0-i686                   499.6 KiB   999K/s 00:01 [###########################################] 100%
 parted-3.2-7.0-i686                               430.1 KiB   956K/s 00:00 [###########################################] 100%
 gvfs-1.38.1-1.0-i686                              905.3 KiB   854K/s 00:01 [###########################################] 100%
 gvfs-mtp-1.38.1-1.0-i686                           44.8 KiB  2.19M/s 00:00 [###########################################] 100%
 intltool-0.51.0-3.2-any                            41.3 KiB  2.02M/s 00:00 [###########################################] 100%
 libavc1394-0.5.4-3.2-i686                          31.7 KiB  3.10M/s 00:00 [###########################################] 100%
 libevdev-1.5.9-1.2-i686                            52.1 KiB  1737K/s 00:00 [###########################################] 100%
 libiec61883-1.2.0-5.2-i686                         32.9 KiB  3.21M/s 00:00 [###########################################] 100%
 libmp4v2-2.0.0-5.2-i686                           391.0 KiB   954K/s 00:00 [###########################################] 100%
 libnetfilter_acct-1.0.3-1.2-i686                    7.6 KiB  0.00B/s 00:00 [###########################################] 100%
 libsigc++-2.10.0-1.1-i686                          67.1 KiB  1678K/s 00:00 [###########################################] 100%
 libxmu-1.1.2-2.2-i686                              74.4 KiB  1487K/s 00:00 [###########################################] 100%
 libxnvctrl-410.57-2.0-i686                         77.8 KiB  1945K/s 00:00 [###########################################] 100%
 libxpm-3.5.12-1.2-i686                             52.6 KiB  1755K/s 00:00 [###########################################] 100%
 lua-5.3.5-1.2-i686                                247.2 KiB   989K/s 00:00 [###########################################] 100%
 lynx-2.8.9-2.0-i686                              1168.1 KiB   950K/s 00:01 [###########################################] 100%
 python-3.7.1-1.0-i686                              35.2 MiB  1394K/s 00:26 [###########################################] 100%
 perl-clone-0.41-1.0-i686                           10.1 KiB  0.00B/s 00:00 [###########################################] 100%
 perl-error-0.17027-1.0-any                         22.2 KiB  1108K/s 00:00 [###########################################] 100%
 perl-xml-namespacesupport-1.12-2.1-any             11.8 KiB  0.00B/s 00:00 [###########################################] 100%
 perl-xml-sax-base-1.09-2.1-any                     23.8 KiB  2.33M/s 00:00 [###########################################] 100%
 perl-xml-sax-1.00-1.1-any                          41.0 KiB  1367K/s 00:00 [###########################################] 100%
 protobuf-3.6.0.1-1.1-i686                        1620.3 KiB  1514K/s 00:01 [###########################################] 100%
 python-packaging-18.0-1.0-any                      31.8 KiB  1589K/s 00:00 [###########################################] 100%
 python-setuptools-1:40.5.0-1.0-any                290.9 KiB   808K/s 00:00 [###########################################] 100%
 python2-packaging-18.0-1.0-any                     31.2 KiB  1039K/s 00:00 [###########################################] 100%
 python2-setuptools-1:40.5.0-1.0-any               272.9 KiB   853K/s 00:00 [###########################################] 100%
 qt5-webkit-5.212.0alpha2-20.0-i686                 12.0 MiB  1238K/s 00:10 [###########################################] 100%
 sdl2-2.0.8-10.0-i686                              592.8 KiB  1317K/s 00:00 [###########################################] 100%
 sgml-common-0.6.3-5.1-any                          40.2 KiB  2011K/s 00:00 [###########################################] 100%
 upower-0.99.9-1.0-i686                            132.1 KiB   186K/s 00:01 [###########################################] 100%
 v4l-utils-1.16.0-1.0-i686                        1049.9 KiB   789K/s 00:01 [###########################################] 100%
 valgrind-3.14.0-1.0-i686                           41.7 MiB  1431K/s 00:30 [###########################################] 100%
 vlc-3.0.4-1.0-i686                                 10.5 MiB  1257K/s 00:09 [###########################################] 100%
 vte-common-0.54.1-1.0-i686                          4.6 KiB  0.00B/s 00:00 [###########################################] 100%
 vte3-0.54.1-1.0-i686                              283.1 KiB  1231K/s 00:00 [###########################################] 100%
 webkit2gtk-2.22.2-1.0-i686                         25.7 MiB  1547K/s 00:17 [###########################################] 100%
 x11-ssh-askpass-1.2.4.1-6.1-i686                   22.2 KiB  2.17M/s 00:00 [###########################################] 100%
 xf86-video-intel-1:2.99.917+847+g25c9a2fc-1....   723.0 KiB  1291K/s 00:01 [###########################################] 100%
 libutf8proc-2.2.0-1.1-i686                         55.3 KiB  1844K/s 00:00 [###########################################] 100%
 mate-icon-theme-1.20.2-1.0-any                     12.2 MiB  1385K/s 00:09 [###########################################] 100%
 menumaker-0.99.10-1.2-any                          87.5 KiB  1750K/s 00:00 [###########################################] 100%
 podofo-0.9.6-2.0-i686                             719.2 KiB  1262K/s 00:01 [###########################################] 100%
 python2-mechanize-1:0.3.7-1.0-any                 164.0 KiB   136K/s 00:01 [###########################################] 100%
(94/94) checking keys in keyring                                            [###########################################] 100%
(94/94) checking package integrity                                          [###########################################] 100%
(94/94) loading package files                                               [###########################################] 100%
(94/94) checking for file conflicts                                         [###########################################] 100%
(94/94) checking available disk space                                       [###########################################] 100%
:: Processing package changes...
( 1/94) upgrading attr                                                      [###########################################] 100%
( 2/94) upgrading acl                                                       [###########################################] 100%
( 3/94) upgrading alsa-lib                                                  [###########################################] 100%
( 4/94) upgrading ncurses                                                   [###########################################] 100%
( 5/94) upgrading pciutils                                                  [###########################################] 100%
( 6/94) upgrading alsa-utils                                                [###########################################] 100%
( 7/94) upgrading libcap                                                    [###########################################] 100%
( 8/94) upgrading coreutils                                                 [###########################################] 100%
( 9/94) upgrading libgpg-error                                              [###########################################] 100%
(10/94) upgrading cracklib                                                  [###########################################] 100%
(11/94) upgrading bzip2                                                     [###########################################] 100%
(12/94) upgrading apache                                                    [###########################################] 100%
(13/94) upgrading archlinux-keyring                                         [###########################################] 100%
==> Appending keys from archlinux.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
  -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
  -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
  -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
  -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
  -> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
  -> Disabling key 5357F3B111688D88C1D88119FCF2CB179205AC90...
  -> Disabling key 5559BC1A32B8F76B3FCCD9555FA5E5544F010D48...
  -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
  -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
  -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
  -> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
  -> Disabling key FB871F0131FEA4FB5A9192B4C8880A6406361833...
  -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
  -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
  -> Disabling key 50F33E2E5B0C3D900424ABE89BDCF497A4BBCC7F...
  -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
  -> Disabling key 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A...
  -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
  -> Disabling key 40776A5221EF5AD468A4906D42A1DB15EC133BAD...
  -> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
  -> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
  -> Disabling key 5A2257D19FF7E1E0E415968CE62F853100F0D0F0...
  -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
  -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
  -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
  -> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
  -> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
  -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
  -> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
  -> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
  -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
  -> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
==> Updating trust database...
gpg: next trustdb check due at 2019-03-29
(14/94) upgrading argon2                                                    [###########################################] 100%
(15/94) upgrading automake                                                  [###########################################] 100%
(16/94) upgrading bc                                                        [###########################################] 100%
(17/94) upgrading libx11                                                    [###########################################] 100%
(18/94) upgrading cairo                                                     [###########################################] 100%
(19/94) upgrading chmlib                                                    [###########################################] 100%
(20/94) upgrading device-mapper                                             [###########################################] 100%
(21/94) upgrading popt                                                      [###########################################] 100%
(22/94) upgrading cryptsetup                                                [###########################################] 100%
(23/94) upgrading exempi                                                    [###########################################] 100%
(24/94) upgrading file                                                      [###########################################] 100%
(25/94) upgrading fribidi                                                   [###########################################] 100%
(26/94) upgrading gawk                                                      [###########################################] 100%
(27/94) upgrading libtasn1                                                  [###########################################] 100%
(28/94) upgrading geoclue2                                                  [###########################################] 100%
(29/94) upgrading geoip                                                     [###########################################] 100%
(30/94) upgrading lcms2                                                     [###########################################] 100%
(31/94) upgrading libusb                                                    [###########################################] 100%
(32/94) upgrading ghostscript                                               [###########################################] 100%
(33/94) upgrading libdrm                                                    [###########################################] 100%
(34/94) upgrading libnl                                                     [###########################################] 100%
(35/94) upgrading iptables                                                  [###########################################] 100%
(36/94) upgrading pcre2                                                     [###########################################] 100%
(37/94) upgrading gnome-desktop                                             [###########################################] 100%
(38/94) upgrading gpm                                                       [###########################################] 100%
(39/94) upgrading lvm2                                                      [###########################################] 100%
(40/94) upgrading mdadm                                                     [###########################################] 100%
(41/94) upgrading parted                                                    [###########################################] 100%
(42/94) upgrading xfsprogs                                                  [###########################################] 100%
(43/94) upgrading libksba                                                   [###########################################] 100%
(44/94) upgrading gvfs                                                      [###########################################] 100%
(45/94) upgrading gvfs-mtp                                                  [###########################################] 100%
(46/94) upgrading intltool                                                  [###########################################] 100%
(47/94) upgrading iproute2                                                  [###########################################] 100%
(48/94) upgrading ldns                                                      [###########################################] 100%
(49/94) upgrading less                                                      [###########################################] 100%
(50/94) upgrading libavc1394                                                [###########################################] 100%
(51/94) upgrading libevdev                                                  [###########################################] 100%
(52/94) upgrading libiec61883                                               [###########################################] 100%
(53/94) upgrading libmp4v2                                                  [###########################################] 100%
(54/94) upgrading libnetfilter_acct                                         [###########################################] 100%
(55/94) upgrading libpipeline                                               [###########################################] 100%
(56/94) upgrading libsigc++                                                 [###########################################] 100%
(57/94) upgrading libutf8proc                                               [###########################################] 100%
(58/94) upgrading libxmu                                                    [###########################################] 100%
(59/94) upgrading libxnvctrl                                                [###########################################] 100%
(60/94) upgrading libxpm                                                    [###########################################] 100%
(61/94) upgrading linux-firmware                                            [###########################################] 100%
(62/94) upgrading mkinitcpio                                                [###########################################] 100%
(63/94) upgrading linux                                                     [###########################################] 100%
(64/94) upgrading lua                                                       [###########################################] 100%
(65/94) upgrading lynx                                                      [###########################################] 100%
(66/94) upgrading mate-icon-theme                                           [###########################################] 100%
(67/94) upgrading python                                                    [###########################################] 100%
(68/94) upgrading menumaker                                                 [###########################################] 100%
(69/94) upgrading pacman                                                    [###########################################] 100%
(70/94) upgrading perl-clone                                                [###########################################] 100%
(71/94) upgrading perl-error                                                [###########################################] 100%
(72/94) upgrading perl-xml-namespacesupport                                 [###########################################] 100%
(73/94) upgrading perl-xml-sax-base                                         [###########################################] 100%
(74/94) upgrading perl-xml-sax                                              [###########################################] 100%
(75/94) upgrading pkgconf                                                   [###########################################] 100%
(76/94) upgrading podofo                                                    [###########################################] 100%
(77/94) upgrading protobuf                                                  [###########################################] 100%
(78/94) upgrading python-packaging                                          [###########################################] 100%
(79/94) upgrading python-setuptools                                         [###########################################] 100%
(80/94) upgrading python2-mechanize                                         [###########################################] 100%
(81/94) upgrading python2-packaging                                         [###########################################] 100%
(82/94) upgrading python2-setuptools                                        [###########################################] 100%
(83/94) upgrading qt5-webkit                                                [###########################################] 100%
(84/94) upgrading sdl2                                                      [###########################################] 100%
New optional dependencies for sdl2
    jack2: JACK audio driver
(85/94) upgrading sgml-common                                               [###########################################] 100%
(86/94) upgrading upower                                                    [###########################################] 100%
(87/94) upgrading v4l-utils                                                 [###########################################] 100%
(88/94) upgrading valgrind                                                  [###########################################] 100%
(89/94) upgrading vlc                                                       [###########################################] 100%
New optional dependencies for vlc
    aribb24: ARIB subtitles
    x264: H264 encoding [installed]
(90/94) upgrading vte-common                                                [###########################################] 100%
(91/94) upgrading vte3                                                      [###########################################] 100%
(92/94) upgrading webkit2gtk                                                [###########################################] 100%
(93/94) upgrading x11-ssh-askpass                                           [###########################################] 100%
(94/94) upgrading xf86-video-intel                                          [###########################################] 100%
:: Running post-transaction hooks...
( 1/15) Updating linux module dependencies...
( 2/15) Updating linux-lts initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 4.14.70-1.0-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [lvm2]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 4.14.70-1.0-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [lvm2]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
==> Image generation successful
( 3/15) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.18.16-arch1-1.0-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [lvm2]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 4.18.16-arch1-1.0-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [lvm2]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
( 4/15) Warn about old perl modules
( 5/15) Updating GIO module cache...
( 6/15) Compiling GSettings XML schema files...
( 7/15) Updating icon theme caches...
( 8/15) Reloading GVFS config...
( 9/15) Reloading system manager configuration...
(10/15) Creating temporary files...
(11/15) Reloading device manager configuration...
(12/15) Arming ConditionNeedsUpdate...
(13/15) Updating the info directory file...
(14/15) Updating the desktop file MIME type cache...
(15/15) Updating the vlc plugin cache...
/usr/lib/vlc/vlc-cache-gen: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory
error: command failed to execute correctly
[user@user ~]$ 

My question is: Because the vlc plugin cache wasn't updated how can we update manually the vlc cache?

Last edited by archlinux32forever (2018-11-04 09:37:34)

Offline

#5 2018-11-04 15:20:53

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 429

Re: vlc broken because of libidn

FWIW, that doesn't appear to me to be a similar error; it looks like the same error to me.

I wonder how you're planning to manually update the vlc cache?  Because if you're planning to use vlc-cache-gen, it appears not to load because of tis shared lib version mismatch that's the root cause of this problem.

I'm a little confused by this issue still occurring though, it seems to me there was a release including /usr/lib/libidn.so.12 made mid october, and it's in core already  Your -Syu didn't detect an update to that package though; I wonder if it's perhaps been slow to propagate through the mirrors (you may have thought two weeks would be long enough though) and perhaps your mirror selection is suboptimal.  I've just checked the first half dozen of my mosly west-european mirrors though, and they all seem to have the latest libidn in their core repo; they all contain libidn-1.35.1 packages.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#6 2018-11-05 13:53:09

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 436

Re: vlc broken because of libidn

the problem is, libidn was updated _before_ vlc (and libvlccore.so) - I'll move vlc from testing to stable, that should fix this issue

Offline

#7 2018-11-05 14:06:03

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 436

Re: vlc broken because of libidn

I just test installed vlc on a box running on stable and it shows no linking problems (can't run it there - this box is w/o graphics):

[vagrant@archlinux ~]$ sudo pacman -S vlc
warning: vlc-3.0.4-6.0 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) vlc-3.0.4-6.0

Total Installed Size:  57.49 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) reinstalling vlc                             [######################] 100%
:: Running post-transaction hooks...
(1/4) Updating icon theme caches...
(2/4) Arming ConditionNeedsUpdate...
(3/4) Updating the desktop file MIME type cache...
(4/4) Updating the vlc plugin cache...
[vagrant@archlinux ~]$ 

I think, you're safe to upgrade vlc.
sry for the trouble,
deep42thought

Offline

#8 2018-11-07 11:09:08

timsong
Member
Registered: 2018-04-03
Posts: 29

Re: vlc broken because of libidn

Thank-you

Offline

#9 2018-11-08 18:09:59

archlinux32forever
Member
Registered: 2018-05-21
Posts: 16

Re: vlc broken because of libidn

Thanks a lot!

I just ran a full system upgrade and vlc upgrades the plugin cache without errors:

[user@user ~]$ LC_ALL=C sudo pacman -Syu
[sudo] password for user: 
:: Synchronizing package databases...
 core                                              176.1 KiB   160K/s 00:01 [###########################################] 100%
 extra                                               2.3 MiB   402K/s 00:06 [###########################################] 100%
 community                                           5.4 MiB   603K/s 00:09 [###########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (53) alsa-lib-1.1.7-1.0  alsa-utils-1.1.7-1.0  aribb24-1.0.3-2.0  boost-libs-1.68.0-2.0  brotli-1.0.7-1.0
              cryptsetup-2.0.5-1.1  enca-1.19-2.1  farstream-0.2.8-1.1  gconf-3.2.6+11+g07808097-4.0  gnucash-3.2-6.0
              gstreamer-1.14.4-1.0  harfbuzz-icu-2.1.0-1.0  icu-63.1-2.0  libabw-0.1.2-1.1  libcdr-0.1.4-5.0
              libe-book-0.1.3-4.0  libevdev-1.6.0-1.0  libfbclient-2.5.8.27089-3.0  libgcrypt-1.8.4-1.0  libmspub-0.1.4-4.0
              libmtp-1.1.16-1.0  libnumbertext-1.0-1.1  libqxp-0.0.1-4.0  libvisio-0.1.6-5.0  libvoikko-4.2-1.0
              libxml2-2.9.8-6.0  libzmf-0.0.2-5.0  linux-lts-4.14.78-1.0  linux-lts-headers-4.14.78-1.0  mesa-18.2.3-1.0
              mkinitcpio-25-1.0  netdata-1.10.0-1.1  obmenu-1.0-11.3  pangomm-2.40.1-2.1  perl-dbi-1.642-1.0
              poppler-0.67.0-1.2  poppler-glib-0.67.0-1.2  python2-dateutil-2.7.5-1.0  qt4-4.8.7-25.0  qt5-base-5.11.2-3.0
              qt5-declarative-5.11.2-1.0  qt5-location-5.11.2-2.1  qt5-sensors-5.11.2-1.0  qt5-svg-5.11.2-1.0
              qt5-webchannel-5.11.2-1.0  qt5-webkit-5.212.0alpha2-21.0  qt5-x11extras-5.11.2-1.0  qt5-xmlpatterns-5.11.2-1.0
              raptor-2.0.15-10.0  recode-3.7.1-1.0  tzdata-2018g-1.0  vlc-3.0.4-6.0  webkit2gtk-2.22.3-1.0

Total Download Size:   202.18 MiB
Total Installed Size:  834.44 MiB
Net Upgrade Size:        3.24 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 tzdata-2018g-1.0-i686   
...
(13/16) Arming ConditionNeedsUpdate...
(14/16) Updating the info directory file...
(15/16) Updating the desktop file MIME type cache...
(16/16) Updating the vlc plugin cache...
[user@user ~]$

Offline

Board footer

Powered by FluxBB