You are not logged in.

#1 2018-04-17 09:50:55

WyRe
Member
Registered: 2018-03-03
Posts: 18

[Solved] Recent texlive-bin upgrade has got issues with libpoppler

I've upgraded my system recently, but newest texlive-bin upgrade broke itself, apparently texlive-bin depends on libpoppler.so.74, but the newest version of libpoppler.so in my system is libpoppler.so.72

I've found two possible solutions,

First and which I've used ... downgrade texlive-bin to texlive-bin-2017.44590-10.1-i686.pkg.tar.xz present in my pacman cache (I guess may be used downgrade binary to do the same)

Second and not tested by me ... create a symbolic link to libpoppler.so.74 from libpoppler.so.72

sudo ln -s /usr/lib/libpoppler.so.72 /usr/lib/libpoppler.so.74

I don't like this second solution because libpoppler 74 version is newest than 72, It would be a proper solution if texlive-bin would need an older libpoppler version. That's because I've not tested even.




Edit:

Ok, I've checking the posible causes and the point is this issue is caused by poppler 0.63 version testing stage.

I'm waiting to poppler 0.63 version be passed to stable repo.

Last edited by WyRe (2018-04-17 19:46:05)

Offline

#2 2018-04-18 10:18:00

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 347

Re: [Solved] Recent texlive-bin upgrade has got issues with libpoppler

ok, I moved poppler 0.63 to [extra], possibly breaking other stuff hmm

Offline

#3 2018-09-08 06:07:51

kde35
Member
Registered: 2017-12-18
Posts: 24

Re: [Solved] Recent texlive-bin upgrade has got issues with libpoppler

Today upgrading texlive-bin broke my latex installation

[2018-09-08 07:52] [ALPM] upgraded texlive-bin (2018.47465-2.0 -> 2018.47465-3.0)
[2018-09-08 07:52] [ALPM] transaction completed
[2018-09-08 07:52] [ALPM] running 'mktexlsr.hook'...
[2018-09-08 07:52] [ALPM-SCRIPTLET] texlua: error while loading shared libraries: libpoppler.so.78: cannot open shared object file: No such file
 or directory

I downgraded texlive-bin, so now latex works, but xelatex is broken. 

xelatex: error while loading shared libraries: libicuuc.so.61: cannot open shared object file: No such file or directory

Now the version of libicuuc.so is 62.1.  I could downgrade icu, but if I keep downgrading individual packages this way, wouldn't I end up breaking something else?
Besides, xelatex wants libicuuc.so.61, so would there be a "clean" way to have both libicuuc.so.61 and libcuuic.so.62 so that the symbolic link
/usr/lib/libicuuc.so still points to libcuuic.so.62?

Last edited by kde35 (2018-09-08 06:31:44)

Offline

#4 2018-09-08 10:07:26

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 568
Website

Re: [Solved] Recent texlive-bin upgrade has got issues with libpoppler

So, I pushed poppler out of the door (sorry - to stable), should work now.
Thanks for reporting. :-)

Offline

#5 2018-09-09 06:01:45

kde35
Member
Registered: 2017-12-18
Posts: 24

Re: [Solved] Recent texlive-bin upgrade has got issues with libpoppler

Now xelatex works, thank you very much.

Offline

#6 2018-11-08 15:22:11

kde35
Member
Registered: 2017-12-18
Posts: 24

Re: [Solved] Recent texlive-bin upgrade has got issues with libpoppler

Today, I got

pacman -Syu
...
( 4/11) Updating TeXLive filename database...
texlua: error while loading shared libraries: libpoppler.so.82: cannot open shared object file: No such file or directory
( 5/11) Reloading system manager configuration...
( 6/11) Creating system user accounts...
( 7/11) Creating temporary files...
( 8/11) Arming ConditionNeedsUpdate...
( 9/11) Updating the info directory file...
(10/11) Updating TeXLive font maps...
(11/11) Updating the desktop file MIME type cache...

And, of course, if I do

login@host pwd #latex
latex: error while loading shared libraries: libpoppler.so.82: cannot open shared object file: No such file or directory

Offline

#7 2018-11-08 18:08:10

levi
Moderator
From: UK
Registered: 2018-06-16
Posts: 201

Re: [Solved] Recent texlive-bin upgrade has got issues with libpoppler

You should avoid using thread marked solved for new bug reports.  Either a new thread or a bug on the bug tracker would do.

But either way, while texlive-bin does depend on poppler (which provides libpoppler.so.*), it doesn't specify a version and as far as I can see my up to date libpoppler.so is still at version 67.  If the maintainers just update poppler they risk breaking libreoffice-still though, as that's why I have poppler installed (I use mupdf for viewing my pdfs).

For you though, as a quick fix you might just need to degrade texlive-bin to an older version still in you cache, then exclude it from future updates until this can be fixed properly.

Offline

#8 2018-11-15 16:28:28

kde35
Member
Registered: 2017-12-18
Posts: 24

Re: [Solved] Recent texlive-bin upgrade has got issues with libpoppler

Solved by poppler update again.  Thanks.

Offline

Board footer

Powered by FluxBB