You are not logged in.

#1 2018-11-10 21:40:27

arch32yes
Member
Registered: 2017-09-30
Posts: 54

archlinux32 - Falkon will not work - lxqt

Falkon is not starting, the lxqt DE i can use.

I go back to my save image from 10/2018.
This image is working.

How can i solved my problem?
Did archlinux32 lxqt have a problem at this time?

Greetz

arch32yes


falkon
falkon: /usr/lib/libssh.so.4: no version information available (required by /usr/lib/libavformat.so.58)
/usr/lib/qt/libexec/QtWebEngineProcess: /usr/lib/libssh.so.4: no version information available (required by /usr/lib/libavformat.so.58)
Failed to load python support plugin "Cannot load library /usr/lib/qt/plugins/falkon/PyFalkon.so: (libshiboken2.cpython-37m-i386-linux-gnu.so.5.11: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden)"
Falkon: 1 extensions loaded
Fatal: Cannot mix incompatible Qt library (version 0x50b01) with this library (version 0x50b02)
Received signal 6
#0 0x0000b1b46e9b <unknown>
#1 0x0000b1b474a2 <unknown>
#2 0x0000b1b47a8d <unknown>
#3 0x0000b7fd0d38 ([vdso]+0xd37)
#4 0x0000b7fd0d21 ([vdso]+0xd20)
#5 0x0000b6c7d736 __GI_raise
#6 0x0000b6c671e3 __GI_abort
#7 0x000000459a8d <unknown>
#8 0x0000b7042a01 <unknown>
#9 0x0000b7042e01 <unknown>
#10 0x0000b700d75d QMessageLogger::fatal()
#11 0x0000b7024759 <unknown>
#12 0x0000b75b91fd QWidgetPrivate::QWidgetPrivate()
#13 0x0000b6b25330 <unknown>
#14 0x0000b6b2582f QQuickWidget::QQuickWidget()
#15 0x0000b6c354f2 <unknown>
#16 0x0000b6c1f79f <unknown>
#17 0x0000b04f6af3 <unknown>
#18 0x0000b1051729 <unknown>
#19 0x0000b106ac3a <unknown>
#20 0x0000b04eb17e QtWebEngineCore::WebContentsAdapter::initialize()
#21 0x0000b04ec6e5 QtWebEngineCore::WebContentsAdapter::load()
#22 0x0000b7ddd37e WebView::loadRequest()
#23 0x0000b7ddd495 WebView::load()
#24 0x0000b7d9e0d7 TabWidget::addView()
#25 0x0000b7d9e13a TabWidget::addView()
#26 0x0000b7c75b7c BrowserWindow::postLaunch()
#27 0x0000b7dfac7a <unknown>
#28 0x0000b7217566 QMetaCallEvent::placeMetaCall()
#29 0x0000b721ae8b QObject::event()
#30 0x0000b75d62a6 QWidget::event()
#31 0x0000b76f9840 QMainWindow::event()
#32 0x0000b7590919 QApplicationPrivate::notify_helper()
#33 0x0000b7598a82 QApplication::notify()
#34 0x0000b71ef515 QCoreApplication::notifyInternal2()
#35 0x0000b71f281a QCoreApplicationPrivate::sendPostedEvents()
#36 0x0000b71f2c29 QCoreApplication::sendPostedEvents()
#37 0x0000b7247064 <unknown>
#38 0x0000aed21a8e g_main_context_dispatch
#39 0x0000aed23b6a <unknown>
#40 0x0000aed23bb6 g_main_context_iteration
#41 0x0000b72465cb QEventDispatcherGlib::processEvents()
#42 0x0000a85d6974 <unknown>
#43 0x0000b71edfa6 QEventLoop::exec()
#44 0x0000b71f67db QCoreApplication::exec()
#45 0x000000459374 <unknown>
#46 0x0000b6c68a49 __libc_start_main
#47 0x0000004596ef <unknown>
  gs: 00000033  fs: 00000000  es: 0000007b  ds: 0000007b
 edi: 00000000 esi: 00000008 ebp: bfdac1fc esp: bfdac1e0
 ebx: 00000002 edx: 00000000 ecx: bfdac1fc eax: 00000000
 trp: 00000000 err: 00000000  ip: b7fd0d21  cs: 00000073
 efl: 00000246 usp: bfdac1e0  ss: 0000007b
[end of stack trace]
Calling _exit(1). Core file will not be generated.

Last edited by arch32yes (2018-11-10 21:42:06)

Offline

#2 2018-11-11 08:42:03

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 568
Website

Re: archlinux32 - Falkon will not work - lxqt

So, there is a mix of Qt libraries in stable:

Fatal: Cannot mix incompatible Qt library (version 0x50b01) with this library (version 0x50b02)
Received signal 6

qt5-base 5.11.2-3.0
qt5-declarative 5.11.2-1.0
qt5-location 5.11.2-2.1
qt5-sensors 5.11.2-1.0
qt5-svg 5.11.2-1.0
qt5-webchannel 5.11.2-1.0
qt5-webengine 5.11.1-3.0
qt5-webkit 5.212.0alpha2-21.0
qt5-x11extras 5.11.2-1.0
qt5-xmlpatterns 5.11.2-1.0

deep42thought is currently reapplying the needed patchwork to qt5-webkit, qt5-webengine.

Offline

#3 2018-11-11 10:45:25

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 347

Re: archlinux32 - Falkon will not work - lxqt

When I learn how to (programatically) extract the qt version ("0x50b01" vs. "0x20b02"), I'll add that to the database and we should be able to avoid such situations: TODO88

Regards,
deep42thought

Offline

#4 2018-11-16 21:00:32

arch32yes
Member
Registered: 2017-09-30
Posts: 54

Re: archlinux32 - Falkon will not work - lxqt

Hello Maintainer,

when did you think we get a working Falkon?

Greetz

arch32yes

Offline

#5 2018-11-19 09:26:44

arch32yes
Member
Registered: 2017-09-30
Posts: 54

Re: archlinux32 - Falkon will not work - lxqt

Hello, where can i find a workaround to use Falkon?

Greetz

arch32yes

Offline

#6 2018-11-20 16:39:37

PS0
Member
Registered: 2017-10-30
Posts: 2

Re: archlinux32 - Falkon will not work - lxqt

The .BUILDINFO of qt5-declarative-5.11.2-1.0-i686.pkg.tar.xz tells us that it was built with qt5-base-5.11.1-3.1-i686. This explains the compatibility error. I did a quick scan on my locally installed qt5 packages and found that qt5-xmlpatterns-5.11.2-1.0-i686.pkg.tar.xz is also built with an old qt5-base. It's probably best to check all available Qt5 packages.

Offline

#7 2018-11-21 06:06:14

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 347

Re: archlinux32 - Falkon will not work - lxqt

indeed - packages built against qt5*-5.11.1-*:
qterminal-0.9.0-1.1-i686.pkg.tar.xz
qt5-webengine-5.11.1-3.0-i686.pkg.tar.xz
qt5-examples-5.11.2-1.0-any.pkg.tar.xz
qt5-webview-5.11.2-1.0-i686.pkg.tar.xz
qtermwidget-0.9.0-1.1-i686.pkg.tar.xz
qt5ct-0.36-1.1-i686.pkg.tar.xz
qtox-1.16.3-5.1-i686.pkg.tar.xz
qt5-feedback-0.0.0.20150918-3.1-i686.pkg.tar.xz
qt5-examples-5.11.1-1.0-any.pkg.tar.xz
qt5pas-2.6.r57934-2.0-i686.pkg.tar.xz
qtkeychain-0.9.1-1.0-i686.pkg.tar.xz
qtractor-0.9.2-1.0-i686.pkg.tar.xz
qtspim-9.1.20-2.1-i686.pkg.tar.xz
qt5-systems-5.4.0.20160303-2.3-i686.pkg.tar.xz
qt5ct-0.36-1.0-i686.pkg.tar.xz
qt5-virtualkeyboard-5.11.2-1.0-i686.pkg.tar.xz
qtikz-0.12-1.1-i686.pkg.tar.xz
qt5pas-2.6.r57934-2.1-i686.pkg.tar.xz
qt5-xmlpatterns-5.11.2-1.0-i686.pkg.tar.xz
qt5-declarative-5.11.2-1.0-i686.pkg.tar.xz
qtkeychain-0.9.1-1.2-i686.pkg.tar.xz
qtpass-1.2.3-1.1-i686.pkg.tar.xz

Offline

#8 2018-11-21 06:29:23

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 347

Re: archlinux32 - Falkon will not work - lxqt

I just rescheduled those - I'll move them to stable asap when they have been built

Offline

#9 2018-11-26 08:01:21

arch32yes
Member
Registered: 2017-09-30
Posts: 54

Re: archlinux32 - Falkon will not work - lxqt

Hello deep42thought,

did you have move them to stable?
Should Falkon now work?

Greetz

arch32yes

Last edited by arch32yes (2018-11-26 08:02:31)

Offline

#10 2018-11-26 08:02:51

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 347

Re: archlinux32 - Falkon will not work - lxqt

sorry, I forgot about that - I'll take a look right away

Offline

#11 2018-11-26 08:10:36

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 347

Re: archlinux32 - Falkon will not work - lxqt

It looks, like all of them could be replaced by newly built ones - let's hope, the new ones are ok in all other aspects, too.

Offline

#12 2018-11-26 17:55:30

arch32yes
Member
Registered: 2017-09-30
Posts: 54

Re: archlinux32 - Falkon will not work - lxqt

Hello, thank you, Falkon now work without problems.

Greetz

arch32yes

Offline

Board footer

Powered by FluxBB