You are not logged in.

#1 2019-03-04 15:14:28

megafreakshow
Member
Registered: 2018-03-09
Posts: 7

[SOLVED] cannot resolve jdk10-openjdk dependencies

Hi,

I've been unable to update to jdk10-openjdk

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "jre10-openjdk-headless=10.0.2.u13-1.2", a dependency of "jre10-openjdk"
warning: cannot resolve "jre10-openjdk=10.0.2.u13-1.2", a dependency of "jdk10-openjdk"
warning: cannot resolve "jre10-openjdk-headless=10.0.2.u13-1.2", a dependency of "jre10-openjdk"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      jdk10-openjdk  jre10-openjdk

:: Do you want to skip the above packages for this upgrade? [y/N]

Here is my mirrorlist

Server = https://mirror.archlinux32.org/$arch/$repo
Server = https://archlinux32.vollzornbrot.de/$arch/$repo
Server = https://archlinux32.mirror.roelf.org/$arch/$repo

Is this a problem on my end?
Cheers!

Last edited by megafreakshow (2019-03-07 12:39:01)

Offline

#2 2019-03-05 21:28:40

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 431

Re: [SOLVED] cannot resolve jdk10-openjdk dependencies

Looks like packages need to be pushed from testing.  If I run my check script without excluding testing, it works, but as soon as I exclude the testing repo from the check, it reports these as missing.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2019-03-07 07:41:48

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 436

Re: [SOLVED] cannot resolve jdk10-openjdk dependencies

jre10-openjdk and jre10-openjdk-headles versions *-1.2 are now in [extra] - I hope, I didn't break anything by moving them big_smile

Offline

Board footer

Powered by FluxBB