You are not logged in.

#1 2019-05-24 18:12:49

ApB
Member
Registered: 2019-05-24
Posts: 6

Problem Building package (pentium4)

Hello. I am trying to build this > https://aur.archlinux.org/packages/efl-git

Changed i686 to pentium4 in the PKGBUILD and have an updated makepkg.conf.

I get:

error: failed to prepare transaction (package architecture is not valid)
:: package efl-git-1.22.99.62220.g00851ea53b-1-pentium4 does not have a valid architecture
:: package efl-git-debug-1.22.99.62220.g00851ea53b-1-pentium4 does not have a valid architecture

Even using i686 everywhere doens't make a difference and i am stuck.

Any ideas??

Offline

#2 2019-05-24 18:46:09

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 661
Website

Re: Problem Building package (pentium4)

I get:

/usr/share/makepkg/buildenv/buildflags.sh: line 28: build_options: readonly variable
/usr/share/makepkg/buildenv/compiler.sh: line 30: build_options: readonly variable
/usr/share/makepkg/buildenv/makeflags.sh: line 28: build_options: readonly variable

then and endless loop in

/usr/share/makepkg/lint_pkgbuild/arch_specific.sh: line 73: exists_function_variable: command not found

bash 5.0.007-1.0

bash-5.0.003-1.2

Same. I don't get that.

Without being able to reproduce it, I can think of /etc/makepkg.conf which should contain:

CARCH="pentium4"

Offline

#3 2019-05-24 18:54:31

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 661
Website

Re: Problem Building package (pentium4)

Staging and real stable machines work, just my stable test machines are borked, no clue why..

Offline

#4 2019-05-24 20:32:29

ApB
Member
Registered: 2019-05-24
Posts: 6

Re: Problem Building package (pentium4)

andreas_baumann wrote:

Without being able to reproduce it, I can think of /etc/makepkg.conf which should contain:

CARCH="pentium4"

I have CARCH set to pentium4.

Offline

#5 2019-05-24 20:42:54

ApB
Member
Registered: 2019-05-24
Posts: 6

Re: Problem Building package (pentium4)

Ok found what is causing it. If Architecture is set to Auto in pacman.conf it throws the message. if i set it to pentium4 it installs. hmm pacman bug maybe???

BTW one thing that also broke is the mirrors. the $arch part in the url doesn't work with pentium4 and it doesn't download the db. there is no pentium4 directory on the servers. if you set it to i686 it works.

Offline

#6 2019-05-24 21:35:01

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 326

Re: Problem Building package (pentium4)

Most of the mirrors I've looked at now ship the pentium4 arch folder as well as the i686 folder.  What's the top entry in your mirrorlist, of interest?


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#7 2019-05-25 07:44:18

ApB
Member
Registered: 2019-05-24
Posts: 6

Re: Problem Building package (pentium4)

levi wrote:

Most of the mirrors I've looked at now ship the pentium4 arch folder as well as the i686 folder.  What's the top entry in your mirrorlist, of interest?

Works now. No idea what was going on yesterday. hmm

Offline

Board footer

Powered by FluxBB