You are not logged in.

#1 2019-07-24 10:08:54

lavekkia
Member
Registered: 2019-07-24
Posts: 3

[Kodi] [Pentium4] crash on missing libcdio.so.18 (out of date ?!?)

Greetings to everyone,

as the title says on my computer Kodi crash with complaining of a missing so library (libcdio.so.18)
I have checked and libcdio is installed but has an higher version (libcdio.so.19); since this is a new installation i can t downgrade
Digging further i have discovered that the Pentium4 version of Kodi is 17.6 and the i686 version is 18.2, sorry i can t be more specific but i can t access to the packages page on the site (502 bad gateway, already reported elsewhere in the forum).

Question time: Is ther any way i can fix it (short of build the package, the machine would not handle the load) or i have to wait for the updated package ?

Thanks to everyone in advance

Offline

#2 2019-07-24 16:17:08

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 462

Re: [Kodi] [Pentium4] crash on missing libcdio.so.18 (out of date ?!?)

Sounds similar to the bug stopping libreoffice from running, although that's a unfulfilled dependency on an old version of libicuuc.  I think mplayer used to be broken looking for an old version of libcdio, but a rebuild of mplayer fixed that.

Assuming there's a reason why kodi can't be rebuilt (it's a big project so I suspect there is), you can unpack an old version of the libcdio package somewhere out of the way (I have a /opt/oldlibs folder for that purpose) and prepend the invocation of kodi with 'LD_LIBRARY_PATH=/opt/oldlibs '


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB