You are not logged in.

#1 2019-07-30 15:24:33

scottmoree
Member
Registered: 2019-07-30
Posts: 3

kde some system settings showing blank

I am rather proficient with arch linux, but I don't know how to fix this one.
quite a few system settings are showing blank. It looks like something to do with kirigami.
I have kirigami2-5.57.0-1.0, plasma-desktop-5.15.5-1.0, archlinux 32, and do tell if there is any other info you need



This is me going to the "workspace theme" (it's not just this settings group).

[user@archlinux ~]$ systemsettings5
org.kde.kcoreaddons: Error loading plugin "kcm_lookandfeel" "The shared library was not found."
Plugin search paths are ("/usr/lib/qt/plugins", "/usr/bin")
The environment variable QT_PLUGIN_PATH might be not correctly set
file:///usr/lib/qt/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:91: TypeError: Cannot read property 'globalToolBarStyle' of null
"file:///usr/share/kpackage/kcms/kcm_lookandfeel/contents/ui/main.qml"
"Error loading QML file.\n27: Type KCM.GridViewKCM unavailable\n113: Type KCM.GridView unavailable\n32: Type QtControls.ScrollView unavailable\n26: module \"org.kde.kirigami\" version 2.9 is not installed\n"
file:///usr/lib/qt/qml/org/kde/kirigami.2/PageRow.qml:211: TypeError: Cannot read property 'createObject' of null
org.kde.kcoreaddons: Error loading plugin "kcm_desktoptheme" "The shared library was not found."
Plugin search paths are ("/usr/lib/qt/plugins", "/usr/bin")
The environment variable QT_PLUGIN_PATH might be not correctly set
file:///usr/lib/qt/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:91: TypeError: Cannot read property 'globalToolBarStyle' of null
"file:///usr/share/kpackage/kcms/kcm_desktoptheme/contents/ui/main.qml"
"Error loading QML file.\n29: Type KCM.GridViewKCM unavailable\n113: Type KCM.GridView unavailable\n32: Type QtControls.ScrollView unavailable\n26: module \"org.kde.kirigami\" version 2.9 is not installed\n"
file:///usr/lib/qt/qml/org/kde/kirigami.2/PageRow.qml:211: TypeError: Cannot read property 'createObject' of null
org.kde.kcoreaddons: Error loading plugin "kcm_cursortheme" "The shared library was not found."
Plugin search paths are ("/usr/lib/qt/plugins", "/usr/bin")
The environment variable QT_PLUGIN_PATH might be not correctly set
file:///usr/lib/qt/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:91: TypeError: Cannot read property 'globalToolBarStyle' of null
"file:///usr/share/kpackage/kcms/kcm_cursortheme/contents/ui/main.qml"
"Error loading QML file.\n30: Type KCM.GridViewKCM unavailable\n113: Type KCM.GridView unavailable\n32: Type QtControls.ScrollView unavailable\n26: module \"org.kde.kirigami\" version 2.9 is not installed\n"
file:///usr/lib/qt/qml/org/kde/kirigami.2/PageRow.qml:211: TypeError: Cannot read property 'createObject' of null
org.kde.kcoreaddons: Error loading plugin "kcm_splashscreen" "The shared library was not found."
Plugin search paths are ("/usr/lib/qt/plugins", "/usr/bin")
The environment variable QT_PLUGIN_PATH might be not correctly set
file:///usr/lib/qt/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:91: TypeError: Type error
"file:///usr/share/kpackage/kcms/kcm_splashscreen/contents/ui/main.qml"
"Error loading QML file.\n26: Type KCM.GridViewKCM unavailable\n113: Type KCM.GridView unavailable\n32: Type QtControls.ScrollView unavailable\n26: module \"org.kde.kirigami\" version 2.9 is not installed\n"
file:///usr/lib/qt/qml/org/kde/kirigami.2/PageRow.qml:211: TypeError: Type error






In Desktop behavior/screen locking inside the appearance tab shows this error in the tab.

Error:Could not load:file:///usr/share/plasma/wallpaers/org.kde.image/contents/ui/config.qml:243 Type QtControls2.ScrollView unavailable
file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ScrollView.qml:26 module "org.kde.kirigami" version 2.9 is not installed

Offline

#2 2019-07-30 15:54:38

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 389

Re: kde some system settings showing blank

Do you have any or all of those files mentioned in the error?  Looks to me like some of those errors are probably the result of earlier missing files, but it's a little hard for me to grok as is.

I'd look at least for *kcm_lookandfeel* in either /usr/bin or /usr/lib/qt/plugins, and *kcm_desktoptheme* (maybe that's both defined in the same kcm.so, but I don't know these packages).  Everything else I can see at this point might be because it can't load those for whatever reason.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2019-07-30 21:33:14

scottmoree
Member
Registered: 2019-07-30
Posts: 3

Re: kde some system settings showing blank

In /usr/lib/qt/plugins, I have both kcm_lookandfeel.so and kcm_desktoptheme.so.

Last edited by scottmoree (2019-07-30 21:33:51)

Offline

#4 2019-07-31 04:00:02

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 389

Re: kde some system settings showing blank

Hmm that's weird then.  The log file seems to be lying in that case.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2019-08-01 11:30:28

scottmoree
Member
Registered: 2019-07-30
Posts: 3

Re: kde some system settings showing blank

As far as I can tell there is nothing wrong with my installation. So I guess it's something KDE needs to fix.
I ended up changing all my setting manually, so we can close this one.

Check out my Github I've got some real cool programs and scripts there https://github.com/DSMJR/dsmrepo.

Last edited by scottmoree (2019-08-01 11:36:02)

Offline

Board footer

Powered by FluxBB