You are not logged in.

#1 2019-08-22 16:27:31

bernadoanon
Member
Registered: 2019-05-19
Posts: 8

xfce4-pulseaudio-plugin crashes after update

Hello. After I restarted the desktop following the system update, I was greeted with the following message:

“Plugin “PulseAudio Plugin” unexpectedly left the panel, do you want to restart it?”

There are two buttons: “Execute” and “Remove”. If I choose execute, the message pops up again with the same choice, so I have to remove it.

sudo pacman -Syu
extra/alsa-lib                    1.1.9-1.1               1.1.9-2.0                  0,00 MiB                     
extra/colord                      1.4.4-2.0               1.4.4-2.1                  0,00 MiB                     
core/cryptsetup                   2.1.0-1.0               2.2.0-1.0                  0,37 MiB             0,47 MiB
core/dbus                         1.12.16-1.1             1.12.16-2.0                0,01 MiB                     
extra/exo                         0.12.6-1.0              0.12.8-1.1                 0,05 MiB                     
extra/garcon                      0.6.2-1.1               0.6.4-1.1                  0,05 MiB                     
extra/gconf                       3.2.6+11+g07808097-4.0  3.2.6+11+g07808097-4.1     0,03 MiB                     
extra/git                         2.22.1-1.0              2.23.0-1.0                -3,82 MiB             5,68 MiB
core/gnutls                       3.6.9-1.0               3.6.9-1.2                 -0,01 MiB                     
extra/js60                        60.7.2-1.0              60.8.0-1.1                 0,04 MiB                     
extra/karchive                    5.60.0-1.0              5.61.0-1.0                 0,00 MiB             0,34 MiB
extra/kdoctools                   5.60.0-1.0              5.61.0-1.0                -0,87 MiB             0,47 MiB
extra/libheif                     1.4.0-3.1               1.5.0-1.0                  0,04 MiB             0,19 MiB
extra/libmm-glib                  1.10.4-1.1              1.10.4-1.2                 0,00 MiB                     
extra/libnm                       1.18.0-1.0              1.20.0-1.0                 0,14 MiB                     
extra/libpulse                    12.2-2.4                12.2-2.6                   0,00 MiB             0,34 MiB
core/libseccomp                   2.4.1-2.1               2.4.1-2.4                  0,00 MiB                     
community/libwrap                 7.6.24-4.2              7.6.28-1.0                 0,00 MiB                     
extra/libxfce4ui                  4.13.5-1.0              4.14.1-2.1                 0,08 MiB                     
extra/libxfce4util                4.14.0-1.0              4.14.0-1.2                 0,00 MiB                     
core/linux                        5.2.8.arch1-1.0         5.2.9.arch1-1.0           -0,01 MiB            64,30 MiB
extra/llvm-libs                   8.0.0-2.0               8.0.1-2.0                  2,82 MiB                     
extra/networkmanager              1.18.0-1.0              1.20.0-1.0                 0,15 MiB                     
extra/networkmanager-openvpn      1.8.10-1.0              1.8.10-1.1                 0,00 MiB                     
extra/orage                       4.12.1-4.1              4.12.1-4.3                -0,02 MiB                     
community/parole                  1.0.2-1.1               1.0.2-2.1                  0,00 MiB                     
extra/polkit                      0.116-2.0               0.116-2.1                  0,00 MiB                     
extra/pulseaudio                  12.2-2.4                12.2-2.6                   0,00 MiB             1,05 MiB
community/python-yaml             5.1.1-1.0               5.1.2-1.0                  0,00 MiB             0,16 MiB
extra/recode                      3.7.1-1.2               3.7.2-1.0                  0,05 MiB             0,32 MiB
community/ristretto               0.8.4-1.0               0.10.0-2.3                -0,07 MiB                     
core/systemd                      242.84-1.0              242.84-2.0                 0,00 MiB                     
core/systemd-libs                 242.84-1.0              242.84-2.0                 0,00 MiB                     
extra/thunar                      1.8.7-1.0               1.8.9-2.2                  0,32 MiB             1,11 MiB
extra/thunar-archive-plugin       0.4.0-1.1               0.4.0-1.3                  0,00 MiB                     
extra/thunar-media-tags-plugin    0.3.0-1.1               0.3.0-1.3                  0,00 MiB                     
extra/thunar-volman               0.9.3-1.0               0.9.5-2.1                  0,00 MiB                     
extra/tumbler                     0.2.7-1.0               0.2.7-1.3                  0,00 MiB                     
extra/udisks2                     2.8.3-1.1               2.8.4-1.0                  0,02 MiB                     
extra/xf86-input-libinput         0.28.2-1.2              0.29.0-1.0                 0,00 MiB                     
extra/xfce4-appfinder             4.12.0-5.0              4.14.0-1.1                 0,12 MiB                     
extra/xfce4-battery-plugin        1.1.2-1.0               1.1.3-1.1                  0,01 MiB                     
extra/xfce4-clipman-plugin        1.4.3-1.0               1.4.3-2.1                  0,00 MiB                     
extra/xfce4-cpufreq-plugin        1.2.1-1.1               1.2.1-1.3                  0,00 MiB                     
extra/xfce4-cpugraph-plugin       1.1.0-1.1               1.1.0-1.3                  0,00 MiB                     
extra/xfce4-datetime-plugin       0.7.1-1.0               0.8.0-1.1                  0,02 MiB                     
extra/xfce4-diskperf-plugin       2.6.1-2.0               2.6.2-1.1                  0,01 MiB                     
extra/xfce4-eyes-plugin           4.5.0-1.2               4.5.0-1.4                  0,00 MiB                     
extra/xfce4-fsguard-plugin        1.1.0-2.0               1.1.1-1.1                  0,02 MiB                     
extra/xfce4-genmon-plugin         4.0.1-1.2               4.0.2-1.1                  0,03 MiB                     
extra/xfce4-mailwatch-plugin      1.2.0-8.0               1.2.0-8.2                  0,00 MiB                     
extra/xfce4-mount-plugin          1.1.3-1.1               1.1.3-1.3                  0,00 MiB                     
extra/xfce4-mpc-plugin            0.5.1-1.0               0.5.2-1.1                  0,03 MiB                     
extra/xfce4-netload-plugin        1.3.1-2.0               1.3.2-1.1                  0,01 MiB                     
extra/xfce4-notifyd               0.4.4-1.0               0.4.4-2.1                  0,00 MiB                     
extra/xfce4-panel                 4.12.2-1.2              4.14.0-1.1                 0,48 MiB                     
extra/xfce4-power-manager         1.6.1-1.2               1.6.5-2.1                  0,17 MiB                     
extra/xfce4-screenshooter         1.9.5-1.0               1.9.5-1.2                  0,00 MiB                     
extra/xfce4-sensors-plugin        1.3.92-1.0              1.3.92-1.2                 0,00 MiB                     
extra/xfce4-session               4.12.1-11.0             4.14.0-2.1                -0,66 MiB                     
extra/xfce4-settings              4.12.4-2.0              4.14.0-1.1                 0,66 MiB                     
extra/xfce4-smartbookmark-plugin  0.5.0-2.0               0.5.1-1.1                  0,03 MiB                     
extra/xfce4-systemload-plugin     1.2.2-1.0               1.2.3-1.1                  0,00 MiB                     
extra/xfce4-time-out-plugin       1.0.2-3.0               1.0.3-1.1                  0,04 MiB                     
extra/xfce4-timer-plugin          1.7.0-1.2               1.7.0-1.4                  0,00 MiB                     
extra/xfce4-verve-plugin          2.0.0-1.1               2.0.0-1.3                  0,00 MiB                     
extra/xfce4-wavelan-plugin        0.6.0-2.0               0.6.1-1.1                  0,00 MiB                     
extra/xfce4-weather-plugin        0.8.11-1.0              0.8.11-1.2                -0,01 MiB                     
extra/xfconf                      4.12.1-7.0              4.14.1-1.3                 0,19 MiB                     
extra/xfdesktop                   4.13.5-1.0              4.14.1-2.1                 0,05 MiB                     
extra/xfwm4                       4.12.5-1.2              4.14.0-1.2                 0,02 MiB             0,42 MiB
xfce4-pulseaudio-plugin 0.4.1-1.2

By running in a terminal:

PANEL_DEBUG=1 xfce4-panel
(xfce4-panel:4765): Gtk-CRITICAL **: 12:59:38.697: gtk_widget_grab_default: assertion 'gtk_widget_get_can_default (widget)' failed
xfce4-panel(module-factory): reading /usr/share/xfce4/panel/plugins
xfce4-panel(module-factory): reading /usr/share/xfce4/panel-plugins
xfce4-panel(external): register dbus path /org/xfce/Panel/Wrapper/4
xfce4-panel(module): new item (type=external-wrapper, name=pulseaudio, id=4)
xfce4-panel(external): pulseaudio-4: child spawned; pid=4797, argc=8
xfce4-panel(application): saving /panels/panel-1: ids=true, providers=false

(process:4797): GLib-WARNING **: 12:59:46.223: (../glib/glib/gerror.c:409):g_error_new_valist: runtime check failed: (domain != 0)

(process:4797): xfce4-panel-wrapper-CRITICAL **: 12:59:46.228: Wrapper pulseaudio-4: Failed to open plugin module "/usr/lib/xfce4/panel/plugins/libpulseaudio-plugin.so": libxfconf-0.so.2: cannot open shared object file: No such file or directory.
xfce4-panel(external): pulseaudio-4: child exited with status 256
xfce4-panel-Message: 12:59:46.233: Plugin pulseaudio-4 has been automatically restarted after crash.
xfce4-panel(external): pulseaudio-4: scheduled a respawn of the child
xfce4-panel(external): pulseaudio-4: child spawned; pid=4798, argc=8
xfconf 4.14.1-1.3
pacman -Ql xfconf | grep so
xfconf /usr/lib/libxfconf-0.so
xfconf /usr/lib/libxfconf-0.so.3
xfconf /usr/lib/libxfconf-0.so.3.0.0

Offline

#2 2019-08-22 16:44:05

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 817
Website

Re: xfce4-pulseaudio-plugin crashes after update

Thanks, I rescheduled xfce4-pulseaudio-plugin for a rebuild.

Offline

#3 2019-08-22 16:46:37

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 817
Website

Re: xfce4-pulseaudio-plugin crashes after update

Actually, we rescheduled most packages for a rebuild, as you can see here :-)

https://archlinux32.org/buildmaster/

Offline

#4 2019-08-22 17:42:08

bernadoanon
Member
Registered: 2019-05-19
Posts: 8

Re: xfce4-pulseaudio-plugin crashes after update

Thanks.

Offline

Board footer

Powered by FluxBB