You are not logged in.

Announcement

The recovered forum pages can be found here.
Bugs can be entered here, anyone can open an account now.

#1 2019-12-02 23:29:57

arch32yes
Member
Registered: 2019-11-17
Posts: 4

LXQt will not start

Hello,

if i make this "pacman -Syu" my LXQt doesn`t start.

:: Synchronisiere Paketdatenbanken...
 core                            157,3 KiB   787 KiB/s 00:00 [################################] 100%
 extra                             2,0 MiB   825 KiB/s 00:02 [################################] 100%
 community                         5,1 MiB   833 KiB/s 00:06 [################################] 100%
:: Starte vollständige Systemaktualisierung...
Warnung: python-pyparsing: Ignoriere Paket-Aktualisierung (2.4.4-1.0 => 2.4.5-1.0)
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (94) alsa-lib-1.2.1.2-2.0  alsa-topology-conf-1.2.1-1.0  alsa-ucm-conf-1.2.1.2-1.0
            audit-2.8.5-6.0  avahi-0.7+18+g1b5f401-3.0  blueman-2.1.1-2.0  bluez-5.52-1.2
            bluez-libs-5.52-1.2  brotli-1.0.7-3.0  btrfs-progs-5.3.1-3.1  cifs-utils-6.9-1.3
            cups-2.3.0-4.2  falkon-3.1.0-8.0  file-5.37-5.0  firefox-70.0.1-3.2  gc-8.0.4-3.0
            gobject-introspection-runtime-1.62.0-3.0  gpgme-1.13.1-3.8  gptfdisk-1.0.4-1.4
            gtk-update-icon-cache-1:3.24.13-1.1  gtk3-1:3.24.13-1.1  hexchat-2.14.2-6.0
            iproute2-5.4.0-1.0  libcap-ng-0.7.10-1.0  libcups-2.3.0-4.2
            libdbusmenu-qt5-0.9.3+16.04.20160218-4.2  libfm-qt-0.14.1-1.3  libgusb-0.3.1-1.0
            libimobiledevice-1.2.0+87+g92c5462-5.0  liblouis-3.11.0-3.0  libmm-glib-1.12.0-2.0
            libnm-1.20.8-1.1  libnma-1.8.24-1.2  libplist-2.1.0-2.0  libproxy-0.4.15-13.0
            libqtxdg-3.4.0-1.1  librsvg-2:2.46.4-1.1  libteam-1.29-4.0  libutil-linux-2.34-8.0
            libvoikko-4.3-1.0  libxml2-2.9.9-6.0  lightdm-1:1.30.0-2.3  link-grammar-5.7.0-2.0
            linux-5.3.13.1-1.4  lximage-qt-0.14.1-2.1  lxqt-config-0.14.1-1.4
            lxqt-powermanagement-0.14.1-1.3  lxqt-qtplugin-0.14.0-2.3  mc-4.8.23-1.4
            mesa-19.2.6-1.0  network-manager-applet-1.8.24-1.2  networkmanager-1.20.8-1.1
            nm-connection-editor-1.8.24-1.2  notepadqq-1.4.8-2.3  obconf-qt-0.14.1-1.1
            polkit-qt5-0.113.0-1.2  python-3.8.0-1.0  python-appdirs-1.4.3-5.0
            python-cairo-1.18.2-3.1  python-dbus-1.2.14-1.0  python-dbus-common-1.2.14-1.0
            python-docopt-0.6.2-7.0  python-keyutils-0.6-4.1  python-ordered-set-3.1.1-1.0
            python-packaging-19.2-5.0  python-setuptools-1:41.6.0-1.0  python-six-1.13.0-2.0
            python-yaml-5.1.2-3.0  qt5-declarative-5.13.2-1.1  qt5-multimedia-5.13.2-1.0
            qt5-sensors-5.13.2-1.1  qt5-svg-5.13.2-1.1  qt5-tools-5.13.2-1.0
            qt5-webchannel-5.13.2-1.0  qt5-webengine-5.13.2-2.0  qt5-x11extras-5.13.2-1.1
            qt5-xmlpatterns-5.13.2-1.1  qterminal-0.14.1-1.3  qtermwidget-0.14.1-1.5
            rubberband-1.8.2-3.1  speedcrunch-0.12.0-2.4  systemd-243.162-2.0
            systemd-libs-243.162-2.0  systemd-sysvcompat-243.162-2.0  talloc-2.3.0-1.0
            tdb-1.3.18-4.1  tevent-1:0.9.39-4.1  udiskie-1.7.7-2.0  util-linux-2.34-8.0
            x264-3:0.157.r2980.34c06d1-2.0  xf86-video-intel-1:2.99.917+897+g0867eea6-1.0
            xorg-server-1.20.6-1.0  xorg-server-common-1.20.6-1.0  youtube-dl-2019.11.28-1.0

Gesamtgröße des Downloads:            290,47 MiB
Gesamtgröße der installierten Pakete:  1016,26 MiB
Größendifferenz der Aktualisierung:    -5,07 MiB

Lightdm start's - black screen - Lightdm t's again

How can i solved the problem?

Greetz

arch32yes

Last edited by arch32yes (2019-12-03 08:35:57)

Offline

#2 2019-12-03 04:05:43

levi
Administrator
Registered: 2019-11-16
Posts: 23

Re: LXQt will not start

Ah, makes me glad I stopped using a display manager and instead just startx manually after logging into the terminal.  I even used to use lightdm by choice as well.

The workaround to achieve that state as I understand it is to:

  • systemctl disable lightdm.service

  • Add the appropriate incantation to the .xinitrc in your login user's root folder.  I use a minimised lxde/openbox myself and the magic word for that is 'startlxde' on a new line at the end of the file, I imagine there's something similar for your desktop environment

Offline

#3 2019-12-04 07:49:47

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 14
Website

Re: LXQt will not start

`journalctl -fl -u lightdm` in a text console gives you some hint, what went wrong (sorry, didn't test yet). I bet it's something along the lines of 'Qt incompatible versions'..

Offline

#4 2019-12-04 21:48:16

standreas2
Member
Registered: 2019-12-04
Posts: 1

Re: LXQt will not start

Same here, every qt app does complain about incompatible libraries and dumbs core.
I've no terminal which allows me copying... but

pacman -Q |grep qt5 

shows for all 5.13.2-* but for qt5-base it's 5.13.1-2.2

Please update it...

Offline

#5 Yesterday 10:45:50

arch32yes
Member
Registered: 2019-11-17
Posts: 4

Re: LXQt will not start

Hello Developer,

did you have solved this problem?

Greetz

arch32yes

Offline

#6 Yesterday 16:42:36

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 14
Website

Re: LXQt will not start

which architecure? i686 or pentium4? output of journalctl -fl?

Offline

#7 Yesterday 17:24:26

levi
Administrator
Registered: 2019-11-16
Posts: 23

Re: LXQt will not start

The one qt test app I use 'keepassxc' started working after updates to both it and the qt-base package (as I recall), but that's a rather different beastie to lightdm.  The only way to find it it to try it and see.

Offline

#8 Yesterday 17:33:01

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 14
Website

Re: LXQt will not start

I used lightdm yesterday on stable i686 and pentium4 without problems.. but I'll also test now..

Offline

#9 Yesterday 17:42:32

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 14
Website

Re: LXQt will not start

Ok, both lightdm and LxQt work in i686 and pentium4 on my qemu test machines.
So, the only option is it doesn't run on real SSE2 hardware for i686, but I'm not close to those real machines at the moment..
..so I'll test later.

Offline

#10 Yesterday 22:02:54

levi
Administrator
Registered: 2019-11-16
Posts: 23

Re: LXQt will not start

I just installed and tested lightdm with lightdm-gtk-greeter on my eeepc.  It launched, but I couldn't get it to talk to my keyboard and mouse, and I had a bit of trouble killing it so I could carry on with my normal session (turned out I needed to kill the zephyr and light-dm processes at the same time, doing them sequentially resulted in them restarting each other).  But it runs and never crashed, so I'd count that as a good sign even if I can't actually test it out.

Offline

Board footer

Powered by FluxBB